PDA

View Full Version : SLED 15 Suse 15 nslookup NXDOMAIN and wicked issue



sapldt
10-Mar-2019, 14:11
Hey,
I use Suse 15 , 4.12.14-25.25-default , using wicked 0.6.52- virtual machine.


when i try to nslookup hostname \ ip i get this error :




server can't find HOTNAME \ IP NXDOMAIN
the way i got to fix it (temporary for 1 hour or so) i run this :




systemctl restart wicked.service
service sssd restart
and it does fix it! but then it goes back to not working.
/etc/resolve contains private DNS servers and domaines which work on other servers fine.



errors in /var/log/messages


GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Clock skew too great)


GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Server not found in Kerberos database)

also,
restart to wicked or even wating 2 hours - you see the machine change ip randomly.
and this is the error :


wickedd-dhcp4[856]: unable to renew lease within renewal period; trying to rebind
when i disable wicked and replace it to NetworkManager all works fine!
is there any bugs in wicked for suse 15 ?

malcolmlewis
10-Mar-2019, 15:18
Hi and welcome to the Forum :)
So your kernel information output indicated the system is not up to date, can you update your system as I see in the SLE update repository wicked at version 0.6.53-3.8.1.

sapldt
10-Mar-2019, 16:56
Hi and welcome to the Forum :)
So your kernel information output indicated the system is not up to date, can you update your system as I see in the SLE update repository wicked at version 0.6.53-3.8.1.

i see the kernel 14.12.14 is the latest for suse 15
https://software.opensuse.org/package/kernel-default

i tried to upgrade wicked but i cant
i dont have any repo of it and when i try by rpms i get this error:

EDIT- never mind i hit ignor "i" and it has continue the installtion ill update soon if it helped.


zypper install libwicked-0-6-0.6.53-184.1.x86_64.rpm wicked-0.6.53-184.1.x86_64.rpm wicked-service-0.6.53-184.1.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
libwicked-0-6 wicked

The following package is going to be upgraded:
wicked-service

The following package is going to change vendor:
wicked-service SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/network

The following 3 packages have no support information from their vendor:
libwicked-0-6 wicked wicked-service

1 package to upgrade, 2 new, 1 to change vendor.
Overall download size: 1.2 MiB. Already cached: 0 B. After the operation, additional 3.4 MiB will be used.
Continue? [y/n/...? shows all options] (y): y
Retrieving package libwicked-0-6-0.6.53-184.1.x86_64 (1/3), 564.2 KiB ( 1.6 MiB unpacked)
libwicked-0-6-0.6.53-184.1.x86_64.rpm:
Header V3 RSA/SHA256 Signature, key ID 17280ddf: NOKEY

Looking for gpg key ID 17280DDF in cache /var/cache/zypp/pubkeys.
Repository Plain RPM files cache does not define additional 'gpgkey=' URLs.
libwicked-0-6-0.6.53-184.1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]

sapldt
10-Mar-2019, 17:18
same error with new version..


2019-03-10T18:04:28.369930+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Request to acquire DHCPv4 lease with UUID 8c35855c-1c85-0500-cb03-000003000000
2019-03-10T18:04:28.464460+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Declining DHCPv4 lease with address XX.XX.XX.104
2019-03-10T18:04:43.404870+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: defer timeout 15 reached (state SELECTING)
2019-03-10T18:04:50.898207+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Committed DHCPv4 lease with address XX.XX.XX.104 (lease time 3600 sec, renew in 1800 sec, rebind in 3150 sec)
2019-03-10T18:09:39.438303+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Request to release DHCPv4 lease with UUID X-1c85-0500-Y-000003000000: releasing...
2019-03-10T18:09:39.845552+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Request to acquire DHCPv4 lease with UUID X-1c85-0500-Y-000007000000
2019-03-10T18:09:50.233243+02:00 tlvl34370286d wickedd-dhcp4[871]: unable to confirm lease
2019-03-10T18:09:55.232354+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: defer timeout 15 reached (state INIT)
2019-03-10T18:10:30.260212+02:00 tlvl34370286d wickedd-dhcp4[871]: eth0: Committed DHCPv4 lease with address XX.XX.XX.88 (lease time 3600 sec, renew in 1800 sec, rebind in 3150 sec)



rpm -qa | grep wicked
libwicked-0-6-0.6.53-184.1.x86_64
wicked-service-0.6.53-184.1.x86_64
wicked-0.6.53-184.1.x86_64


systemctl list-unit-files | grep -E 'Network|icked'
dbus-org.opensuse.Network.AUTO4.service enabled
dbus-org.opensuse.Network.DHCP4.service enabled
dbus-org.opensuse.Network.DHCP6.service enabled
dbus-org.opensuse.Network.Nanny.service enabled
wicked.service enabled
wickedd-auto4.service enabled
wickedd-dhcp4.service enabled
wickedd-dhcp6.service enabled
wickedd-nanny.service enabled
wickedd-pppd@.service static
wickedd.service indirect

malcolmlewis
10-Mar-2019, 17:34
Hi
Why don't you register the machine so you can get proper updates? Getting files from the openSUSE Build Service will probably create additional issues...

Is the system syncing to a time source as well, since your clock seems out of sync?

sapldt
11-Mar-2019, 09:35
Hi
Why don't you register the machine so you can get proper updates? Getting files from the openSUSE Build Service will probably create additional issues...

Is the system syncing to a time source as well, since your clock seems out of sync?

Hey,

i see that since yesterday i dont have thous errors and that nslookup works fine right after i updated wicked.
but ip still changes :

wickedd-dhcp4[871]: unable to renew lease within renewal period; trying to rebind
wickedd-dhcp4[871]: unable to rebind lease

the only solution is to install from repos ?
maybe there is a setting that making this happan ?

Thanks.

sapldt
11-Mar-2019, 10:18
Hey,

i see that since yesterday i dont have thous errors and that nslookup works fine right after i updated wicked.
but ip still changes :

wickedd-dhcp4[871]: unable to renew lease within renewal period; trying to rebind
wickedd-dhcp4[871]: unable to rebind lease

the only solution is to install from repos ?
maybe there is a setting that making this happan ?

Thanks.

also i see there was a bug on this maybe its related ?
https://tickets.puppetlabs.com/browse/IMAGES-903?focusedCommentId=583954&page=com.atlassian.jira.plugin.system.issuetabpane ls%3Acomment-tabpanel#comment-583954

sapldt
11-Mar-2019, 11:01
also i see there was a bug on this maybe its related ?
https://tickets.puppetlabs.com/browse/IMAGES-903?focusedCommentId=583954&page=com.atlassian.jira.plugin.system.issuetabpane ls%3Acomment-tabpanel#comment-583954


I installed wicked 0.6.53 from repo, the random ip issue is still happen.

malcolmlewis
11-Mar-2019, 16:53
I installed wicked 0.6.53 from repo, the random ip issue is still happen.
Hi
Until you register the system and get the system up to date with supported packages your unlikely to resolve the issue by just installing a rpm from the Build Service.

Also have you set the system to sync with an ntp server?

sapldt
12-Mar-2019, 13:42
Hi
Until you register the system and get the system up to date with supported packages your unlikely to resolve the issue by just installing a rpm from the Build Service.

Also have you set the system to sync with an ntp server?

but i did add all the new Suse15 repo and update everything.
why you think somthing is not updated ?

i re-imaged suse 15 - added the repo and installed wicked 0.6.53 the newest ( not using the rpm's)
using zypper install wicked

and ntp-server is fine also the errors on the clock disapperd after updated wicked to latest.
the only thing having an issue is the wicked. as i said NetworkManager not making ANY issue.
all other suse servers are OK except the suse 15.

I even opened a BUG : https://bugzilla.opensuse.org/show_bug.cgi?id=1128698

i hope somone could help me soon.
this only happand on VM's.

malcolmlewis
12-Mar-2019, 14:11
but i did add all the new Suse15 repo and update everything.
why you think somthing is not updated ?

i re-imaged suse 15 - added the repo and installed wicked 0.6.53 the newest ( not using the rpm's)
using zypper install wicked

and ntp-server is fine also the errors on the clock disapperd after updated wicked to latest.
the only thing having an issue is the wicked. as i said NetworkManager not making ANY issue.
all other suse servers are OK except the suse 15.

I even opened a BUG : https://bugzilla.opensuse.org/show_bug.cgi?id=1128698

i hope somone could help me soon.
this only happand on VM's.
Hi
Can you show the output from the command;



zypper lr -d

sapldt
13-Mar-2019, 09:47
Hi
Can you show the output from the command;



zypper lr -d




Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type |
--+--------------------+--------------------+---------+-----------+---------+----------+--------+
1 | sle_product | sle_product | Yes | (r ) Yes | Yes | 99 | rpm-md |
2 | slemod_app_product | slemod_app_product | Yes | (r ) Yes | Yes | 99 | rpm-md |
3 | slemod_product | slemod_product | Yes | (r ) Yes | Yes | 99 | rpm-md |
4 | slemodapp_update | slemodapp_update | Yes | (r ) Yes | Yes | 99 | rpm-md |
5 | slemodbase_update | slemodbase_update | Yes | (r ) Yes | Yes | 99 | rpm-md |
6 | sleprod_update | sleprod_update | Yes | (r ) Yes | Yes | 99 | rpm-md |
7 | zabbix_repo | zabbix_repo | Yes | ( ) No | No | 99 | rpm-md |


i updated everything from repo and rebooted , i deleted privet URI .
Kernel now : 4.12.14-25.28-default

errors still :


wickedd-dhcp4[808]: eth0: timeout in state RENEWING
wickedd-dhcp4[808]: unable to renew lease within renewal period; trying to rebind
wickedd-dhcp4[808]: eth0: Initiating rebind of DHCPv4 lease
wickedd-dhcp4[808]: eth0: incoming dhcp4 packet from XXX
wickedd-dhcp4[808]: eth0: server does not send client-id back



i think its related to the bug i sent you about "server does not send client-id back" - >
https://tickets.puppetlabs.com/browse/IMAGES-903?focusedCommentId=583954&page=com.atlassian.jira.plugin.system.issuetabpane ls%3Acomment-tabpanel#comment-583954

let me know what we can do.

sapldt
13-Mar-2019, 15:08
Ok, so i also created /etc/wicked/local.xml:
<config>
<addrconf>
<dhcp4>
<create-cid>rfc2132</create-cid>
</dhcp4>
</addrconf>
</config>

as they said to do on this bug :
https://bugzilla.opensuse.org/show_bug.cgi?id=1080832

and it seems to fix it.
can you tell me why i dont already had this fix ? its a bug from 2018

Thanks

malcolmlewis
13-Mar-2019, 15:19
Ok, so i also created /etc/wicked/local.xml:
<config>
<addrconf>
<dhcp4>
<create-cid>rfc2132</create-cid>
</dhcp4>
</addrconf>
</config>

as they said to do on this bug :
https://bugzilla.opensuse.org/show_bug.cgi?id=1080832

and it seems to fix it.
can you tell me why i dont already had this fix ? its a bug from 2018

Thanks
Hi
Likely because you switch to the OBS version which appears to have this problem....

Can you switch it back to the version from your update repository which should be version;



Information for package wicked:
-------------------------------
Repository : SLE-Module-Basesystem15-Updates for x86_64
Name : wicked
Version : 0.6.53-3.8.1
Arch : x86_64
Vendor : SUSE LLC <https://www.suse.com/>


Are you connected to a Suma or SMT instance, maybe it needs to be synced to ensure it's all up to date.

sapldt
14-Mar-2019, 10:04
Hi
Likely because you switch to the OBS version which appears to have this problem....

Can you switch it back to the version from your update repository which should be version;



Information for package wicked:
-------------------------------
Repository : SLE-Module-Basesystem15-Updates for x86_64
Name : wicked
Version : 0.6.53-3.8.1
Arch : x86_64
Vendor : SUSE LLC <https://www.suse.com/>


Are you connected to a Suma or SMT instance, maybe it needs to be synced to ensure it's all up to date.

i see the same version you posted on my machine :

Information for package wicked:
-------------------------------
Repository : @System
Name : wicked
Version : 0.6.53-3.8.1
Arch : x86_64
Vendor : SUSE LLC <https://www.suse.com/>
Support Level : unknown
Installed Size : 1.8 MiB
Installed : Yes
Status : up-to-date
Source package : wicked-0.6.53-3.8.1.src
Summary : Network configuration infrastructure

malcolmlewis
14-Mar-2019, 14:24
On Thu 14 Mar 2019 09:14:02 AM CDT, sapldt wrote:

malcolmlewis;57160 Wrote:
> Hi
> Likely because you switch to the OBS version which appears to have
> this problem....
>
> Can you switch it back to the version from your update repository
> which should be version;
>
> >
Code:
--------------------
> >
> Information for package wicked:
> -------------------------------
> Repository : SLE-Module-Basesystem15-Updates for x86_64
> Name : wicked
> Version : 0.6.53-3.8.1
> Arch : x86_64
> Vendor : SUSE LLC <https://www.suse.com/>
>
--------------------
> >
>
> Are you connected to a Suma or SMT instance, maybe it needs to be
> synced to ensure it's all up to date.

i see the same version you posted on my machine :

Information for package wicked:
-------------------------------
Repository : @System
Name : wicked
Version : 0.6.53-3.8.1
Arch : x86_64
Vendor : SUSE LLC <https://www.suse.com/>
Support Level : unknown
Installed Size : 1.8 MiB
Installed : Yes
Status : up-to-date
Source package : wicked-0.6.53-3.8.1.src
Summary : Network configuration infrastructure




Hi
The problem is that yours is @System rather than from
SLE-Module-Basesystem15-Updates for x86_64 repository. That show it's
not a supported package, this can also indicate that other supporting
packages may not be present which could be exacerbating the issue...

What is the host operating system, are you connecting via NAT or a
bridge?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

AndreasMeyer
16-Mar-2019, 23:54
Bring your system in a clean state before you ask community and SUSE for help:

=> check the configuration files of zypp/zypper
https://forums.suse.com/showthread.php?13317-apache2-498-patchset-install-problem&p=56987#post56987

=> remove all non-official SLE-packages sources
=> For security reason, you should use only GPG-signed repositories!

# zypper services
# zypper repos -P

=> check for new updates

# zypper list-updates

=> cross-check, if the latest updates are installed:
https://download.suse.com/patch/finder/

=> search all unsupported packages

# zypper packages --orphaned

=> uninstall/remove all unsupported packages

# zypper remove <xy>

=> check dependencies of all installed packages

# zypper verify

=> check integrity of all installed packages

# rpm -Va

For help from SUSE, read:
https://forums.suse.com/showthread.php?12156-how-to-report-an-issue&p=52768#post52768

sapldt
17-Mar-2019, 13:18
Bring your system in a clean state before you ask community and SUSE for help:

=> check the configuration files of zypp/zypper
https://forums.suse.com/showthread.php?13317-apache2-498-patchset-install-problem&p=56987#post56987

=> remove all non-official SLE-packages sources
=> For security reason, you should use only GPG-signed repositories!

# zypper services
# zypper repos -P

=> check for new updates

# zypper list-updates

=> cross-check, if the latest updates are installed:
https://download.suse.com/patch/finder/

=> search all unsupported packages

# zypper packages --orphaned

=> uninstall/remove all unsupported packages

# zypper remove <xy>

=> check dependencies of all installed packages

# zypper verify

=> check integrity of all installed packages

# rpm -Va

For help from SUSE, read:
https://forums.suse.com/showthread.php?12156-how-to-report-an-issue&p=52768#post52768



Bring your system in a clean state before you ask community and SUSE for help:

=> check the configuration files of zypp/zypper
https://forums.suse.com/showthread.php?13317-apache2-498-patchset-install-problem&p=56987#post56987

=> remove all non-official SLE-packages sources
=> For security reason, you should use only GPG-signed repositories!

# zypper services
# zypper repos -P

=> check for new updates

# zypper list-updates

=> cross-check, if the latest updates are installed:
https://download.suse.com/patch/finder/

=> search all unsupported packages

# zypper packages --orphaned

=> uninstall/remove all unsupported packages

# zypper remove <xy>

=> check dependencies of all installed packages

# zypper verify

=> check integrity of all installed packages

# rpm -Va

For help from SUSE, read:
https://forums.suse.com/showthread.php?12156-how-to-report-an-issue&p=52768#post52768


about the @system repo - it was a mistake this is the correct one
we do take the correct package and this is a clean suse install .

this is a machine on vSphere with a network we set


the package updated :
Information for package wicked:
-------------------------------
Repository : slemodbase_update
Name : wicked
Version : 0.6.53-3.8.1
Arch : x86_64
Vendor : SUSE LLC <https://www.suse.com/>
Support Level : Level 3
Installed Size : 1.8 MiB
Installed : Yes
Status : up-to-date
Source package : wicked-0.6.53-3.8.1.src
Summary : Network configuration infrastructure


also i see with qpm -ql that none of the packages would provide the local.xml for the fix.
my system is up to date i even got the cups update today

rpm -ql wicked | grep local.xml
rpm -ql wicked-service | grep local.xml
rpm -ql libwicked | grep local.xml


zypper services
# | Alias | Name | Enabled | GPG Check | Refresh | Type
--+--------------------+--------------------+---------+-----------+---------+-------
1 | sle_product | sle_product | Yes | (r ) Yes | Yes | rpm-md
2 | slemod_app_product | slemod_app_product | Yes | (r ) Yes | Yes | rpm-md
3 | slemod_product | slemod_product | Yes | (r ) Yes | Yes | rpm-md
4 | slemodapp_update | slemodapp_update | Yes | (r ) Yes | Yes | rpm-md
5 | slemodbase_update | slemodbase_update | Yes | (r ) Yes | Yes | rpm-md
6 | sleprod_update | sleprod_update | Yes | (r ) Yes | Yes | rpm-md



zypper repos -P
# | Alias | Name | Enabled | GPG Check | Refresh | Priority
--+--------------------+--------------------+---------+-----------+---------+---------
1 | sle_product | sle_product | Yes | (r ) Yes | Yes | 99
2 | slemod_app_product | slemod_app_product | Yes | (r ) Yes | Yes | 99
3 | slemod_product | slemod_product | Yes | (r ) Yes | Yes | 99
4 | slemodapp_update | slemodapp_update | Yes | (r ) Yes | Yes | 99
5 | slemodbase_update | slemodbase_update | Yes | (r ) Yes | Yes | 99
6 | sleprod_update | sleprod_update | Yes | (r ) Yes | Yes | 99



zypper list-updates
Loading repository data...
Reading installed packages...
No updates found.



zypper verify
Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.




all i care about is that why i didnt have the fix already in the new install ?
please let me know if theres more info you need.

i cannot delete all unsupported packages as we have a sap image which containes mcafee agent and more stuff that does not come from your repo.
if it was a bug in wicked the only package which need to affect the fix is wicked.

KBOYLE
17-Mar-2019, 16:27
all i care about is that why i didnt have the fix already in the new install ?


Please keep in mind that the Knowledge Partners (https://wiki.microfocus.com/index.php?title=Knowledge_Partner_Program) are not SUSE employees. We are Community Members, like yourself, who volunteer our time to help other Community Members as best we can.

If you suspect you have discovered a bug, you can open a Service Request with SUSE so the bug can be verified and the appropriate corrective action can be taken. You can do this via the SUSE Customer Center (https://scc.suse.com/).

You may also find it helpful to review the SUSE Technical Support Handbook (https://www.suse.com/support/handbook/?_ga=2.35815008.1393230893.1552778402-1267726928.1482351745#software) for more information.