PDA

View Full Version : SLES 15 ntpd will not start on reboot



cisaksen
09-Apr-2019, 14:14
Recently configured ntpd on SUSE 15 server (physical) and it is set to enabled but it doesn't start on a reboot.

I see in messages that the NTP client\server started successfully but I believe that's the YAST client version of ntp. I see no signs that the actual ntpd.service file is ever tried to start.

Any ideas on how I might get a closer look at the boot up process ? It there is an ntp.log file I set in ntp.conf but I'm not sure the proper syntax to set the logging to debug.

Thanks

AndreasMeyer
09-Apr-2019, 19:16
Please read SLE Administration Guide, chaptre "13.2":

https://www.suse.com/documentation/

https://www.suse.com/documentation/sles-15/book_sle_admin/data/sec_boot_systemd_basics.html

Hint: MY_SERVICE => ntpd.service

cisaksen
09-Apr-2019, 21:02
What exactly are you referring to by this ? The service is enabled - systemctl enable ntpd or systemctl is-enabled ntpd = enabled The service starts just fine manually - systemctl start ntpd

What I saying is that there is no indication that the service is even trying to start during the boot process. There are no log message anywhere that I can find that even shows the ntpd is even attempted to be started or even started and failed.

ab
09-Apr-2019, 22:12
A few things may give you clues:



systemctl status ntpd


That should tell you anything about the service that is current, including
when it last ran.



systemctl is-active ntpd


Indicates whether or not the service is currently active.



systemd-analyze blame


Look through the output looking for your service. The idea with this
command is to show what caused the startup to take as long as it did (so
you can optimize that), but as a result it shows all of the starting
services, in order, which may be useful.

Along with all of that it may be useful to know how you are testing
whether or not the service is running, just in case your test is invalid.

Finally, "Yast' doesn't have an NTP client or service of its own; it
configures the system one. I only mention this in case you feel Yast is
somehow doing something other than setting things up, or if you believe
its tool is a separate one; it's not.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

cisaksen
09-Apr-2019, 22:44
After a reboot
systemctl status ntpd
ntpd.service - NTP Server Daemon
Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:ntpd(1)

systemd-analyze blame
ntpd.service is not listed

yet
systemctl is-enabled ntpd
enabled

Something is amiss - I'm opening a case.

Thanks

malcolmlewis
10-Apr-2019, 00:58
On Tue 09 Apr 2019 09:54:02 PM CDT, cisaksen wrote:

After a reboot
systemctl status ntpd
ntpd.service - NTP Server Daemon
Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor
preset: disabled)
Active: inactive (dead)
Docs: man:ntpd(1)

systemd-analyze blame
ntpd.service is not listed

yet
systemctl is-enabled ntpd
enabled

Something is amiss - I'm opening a case.

Thanks




Hi
Not at all, it's using chronyd these days...

https://www.suse.com/releasenotes/x86_64/SUSE-SLES/15/

Section 9.1.7 ntpd Has Been Replaced With Chrony

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-150.14-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

cisaksen
10-Apr-2019, 16:47
Support confirmed that chrony was conflicting with the ntpd service. Once I disabled chronyd service ntpd start just fine now.

AndreasMeyer
10-Apr-2019, 18:18
You should replace ntpd with chrony if possible.
https://chrony.tuxfamily.org/faq.html