PDA

View Full Version : SUSE SP4 upgrade block



sbedard
11-Apr-2019, 15:12
Hello,

I'm trying to update a SUSE 11 SP3 to SP4 and I'm having a block due to an extension not being available in SP4. For some strange reason, only the newest VMs I had created have this issue.

When I do a zypper migration, I get the following:


Unavailable migrations (product is not mirrored):

SUSE Linux Enterprise Server 12 SP4 x86_64
SUSE Linux Enterprise Software Development Kit 12 SP4 x86_64
SUSE Package Hub 12 SP4 x86_64 (not available)
Web and Scripting Module 12 x86_64 (already installed)
Toolchain Module 12 x86_64 (already installed)
Containers Module 12 x86_64 (already installed)
Public Cloud Module 12 x86_64 (already installed)
Advanced Systems Management Module 12 x86_64 (already installed)
Legacy Module 12 x86_64 (already installed)


Here's the output of SUSEConnect:


command 'zypper --non-interactive removeservice 'SMT-http_smt-ec2_susecloud_net'' failed
Error: zypper returned (1) with 'Unexpected exception.
[SMT-http_smt-ec2_susecloud_net|file:/usr/lib/zypp/plugins/services/SMT-http_smt-ec2_susecloud_net] Can't figure out where the service is stored.
Please file a bug report about this.
See http://en.opensuse.org/Zypper/Troubleshooting for instructions.'


It seems the SUSE Package Hub 12 SP3 x86_64 (Installed) extension is blocking the migration path as it's not available in SP4, but I'm unable to remove it...


# SUSEConnect -d -p PackageHub/12.3/x86_64
Error: Registration server returned 'Single product deactivation is not available when registration sharing is enabled' (422)


If I try to enable the product extension in SUSEConnect, I get the following:


# SUSEConnect -p PackageHub/12.4/x86_64
Error: Registration server returned 'Product not (fully) mirrored on this server.
Mirroring of the following repos has to be enabled on the SMT server:
* SUSE-PackageHub-12-SP4-Pool (PackageHub,12.4,x86_64)
* SUSE-PackageHub-12-SP4-Standard-Pool (PackageHub,12.4,x86_64)
' (422)


Thanks for your help

rjschwei
15-Apr-2019, 01:45
Hi,

You will need to remove PackageHub from your instances that you want to upgrade. At this point PackageHub repositories are not consistently mirrored on the update infrastructure. Not having PackageHub available is on purpose at this point. We are working to refresh the update infrastructure. After this is completed later this year PackageHub repos will be available from the update infrastructure.

sbedard
15-Apr-2019, 18:49
I tried but it's not letting me remove it:



SUSEConnect -d -p PackageHub/12.3/x86_64
Error: Registration server returned 'Single product deactivation is not available when registration sharing is enabled' (422)

rjschwei
30-Apr-2019, 18:25
I tried but it's not letting me remove it:



SUSEConnect -d -p PackageHub/12.3/x86_64
Error: Registration server returned 'Single product deactivation is not available when registration sharing is enabled' (422)


Sorry for not being more specific. SUSEConnect will always go back to where the RIS (Repository Information Service) is connected to. But that obviously is not working. You have to do all of this manually.

rm -rf /etc/zypp/repos.d/*PackageHub*

Verify the repo is not connected to a service

grep PackageHub /etc/zypp/services.d/*

if the grep command returns something then the error is likely to re-appear and we'll have to pull the errant setup of PackageHub on the server. If the grep command returns empty then migration should work.