PDA

View Full Version : libstdc++43-4.3.3_20081022 confliting issue



scottjsn
02-Aug-2012, 18:27
In the process of installing the Oracle Grid (11g R2) on SUSE Linux 11. When the installer reached the Prerequisite Checks step, it displayed an error:

The following packages are missing:

libstdc++43-4.3.3_20081022
libstdc++43-32bit-4.3.3_20081022
libstdc++43-devel-32bit-4.3.3_20081022
libgcc43-4.3.3_20081022

So I downloaded the libstdc++43-4.3.3_20081022 for SUSE 11. When I tried to install it, conflicting was found and it tried to deinstall the following:

libstdc++46-4.6
libstdc++43-devel-4.3
libstdc++devel-4.3
gcc43-c++-4.3
gcc-c++-4.3

Currently, it pauses, waiting for my action. If I OK it, sure it will delete the existing packages. But the problem is I tried to remove libstdc++46-4.6 before, it actually removed whole bunch of related files including the operating system files that make the SUSE unusable.

What should I do?

scottjsn
02-Aug-2012, 18:44
Also, like to know the following:

1) Does the ASM need those packages at all?
2) If I do not intend to compile and run any C++ program, do I still need the packages?

malcolmlewis
02-Aug-2012, 18:57
In the process of installing the Oracle Grid (11g R2) on SUSE Linux 11.
When the installer reached the Prerequisite Checks step, it displayed an
error:

The following packages are missing:

libstdc++43-4.3.3_20081022
libstdc++43-32bit-4.3.3_20081022
libstdc++43-devel-32bit-4.3.3_20081022
libgcc43-4.3.3_20081022

So I downloaded the libstdc++43-4.3.3_20081022 for SUSE 11. When I
tried to install it, conflicting was found and it tried to deinstall the
following:

libstdc++46-4.6
libstdc++43-devel-4.3
libstdc++devel-4.3
gcc43-c++-4.3
gcc-c++-4.3

Currently, it pauses, waiting for my action. If I OK it, sure it will
delete the existing packages. But the problem is I tried to remove
libstdc++46-4.6 before, it actually removed whole bunch of related files
including the operating system files that make the SUSE unusable.

What should I do?



Hi
You should be using the versions as indicated;


Repository: SLED11-SP2-Core
Name: libstdc++43-devel
Version: 4.3.4_20091019-0.22.17

Can you check;


zypper if libstdc++43-devel

I would assume that later versions should work. Can you provide a
download link to what your trying to install.


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 4 days 14:28, 3 users, load average: 0.22, 0.35, 0.39
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

scottjsn
02-Aug-2012, 19:38
Downloaded libstdc++43-4.3.3_20081022 from

http://rpm.pbone.net/index.php3/stat/4/idpl/11105685/dir/opensuse_11.x/com/libstdc++43-4.3.3_20081022-9.8.x86_64.rpm.html

malcolmlewis
02-Aug-2012, 20:00
Downloaded libstdc++43-4.3.3_20081022 from

http://rpm.pbone.net/index.php3/stat/4/idpl/11105685/dir/opensuse_11.x/com/libstdc++43-4.3.3_20081022-9.8.x86_64.rpm.html



Hi
Sorry, I meant the oracle stuff your trying to install, want to look at
the setup script....

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 4 days 15:33, 3 users, load average: 0.40, 0.39, 0.39
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU