PDA

View Full Version : .local dns zones



maxx
10-Aug-2012, 14:31
In earlier versions of SLES i was able to fix a name resolution problem
by adding mdns off to the /etc/host.conf file.

What can i do with SLES11 servers? I read that this entry is no longer
supported.

malcolmlewis
10-Aug-2012, 14:49
In earlier versions of SLES i was able to fix a name
resolution problem by adding mdns off to the /etc/host.conf file.

What can i do with SLES11 servers? I read that this entry is no longer
supported.

Hi
Try adding the following to your grub boot option;


nomdns=1

See section 2.13;
http://www.suse.com/documentation/sled11/singlehtml/book_sle_admin/book_sle_admin.html

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 12 days 10:20, 2 users, load average: 0.87, 0.58, 0.54
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

maxx
10-Aug-2012, 17:22
Hi thanks,
according the manual this solution is for the installation. the manual
references to the documentation of host.conf. A paramter for multicast
dns is not defined anymore :

http://man.sourcentral.org/SLES11/5+host.conf



On 10.08.2012 15:49, malcolmlewis wrote:
>
In earlier versions of SLES i was able to fix a name
> resolution problem by adding mdns off to the /etc/host.conf file.
>
> What can i do with SLES11 servers? I read that this entry is no longer
> supported.
>
> Hi
> Try adding the following to your grub boot option;
>

> nomdns=1
>
> See section 2.13;
> http://www.suse.com/documentation/sled11/singlehtml/book_sle_admin/book_sle_admin.html
>

malcolmlewis
10-Aug-2012, 18:01
Hi thanks,
according the manual this solution is for the installation. the manual
references to the documentation of host.conf. A paramter for multicast
dns is not defined anymore :

http://man.sourcentral.org/SLES11/5+host.conf



On 10.08.2012 15:49, malcolmlewis wrote:
>
In earlier versions of SLES i was able to fix a name
> resolution problem by adding mdns off to the /etc/host.conf file.
>
> What can i do with SLES11 servers? I read that this entry is no longer
> supported.
>
> Hi
> Try adding the following to your grub boot option;
>

> nomdns=1
>
> See section 2.13;
> http://www.suse.com/documentation/sled11/singlehtml/book_sle_admin/book_sle_admin.html
>


Hi
Just a thought to try, since it's a passable option at boot time....

Have you disabled the avahi-daemon? Either that or maybe configuring
options in avahi-daemon.conf (both have man pages)

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 12 days 13:24, 2 users, load average: 0.46, 0.44, 0.41
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Magic31
11-Aug-2012, 11:40
In earlier versions of SLES i was able to fix a name resolution problem
by adding mdns off to the /etc/host.conf file.

What can i do with SLES11 servers? I read that this entry is no longer
supported.

The setting has been moved to /etc/nsswitch.conf. If the line "hosts:" contains a listing for mdns*, mdns4_minimal - simply remove it. If it's set, you can also remove the "[NOTFOUND=return]" option so the search entry after it (dns in most cases) will also be searched when nothing is found in the previous search. That might be enough while keeping a setting like mdns4_minimal in there.

Hope that helps,
Willem

Magic31
11-Aug-2012, 11:51
The setting has been moved to /etc/nsswitch.conf.

Added note so specify this more correctly... the setting in /etc/host.conf has not so much moved to /etc/nsswitch.conf. Both those configuration methods/files could be used in the past, but the /etc/host.conf is an older way of configuring things and has become somewhat obsolete. nsswitch.conf can also control many more aspects and host.conf mainly still there for compatibility with older packages AFAIK.

-Willem