PDA

View Full Version : NFS client mapping to NETAPP will not automount with "lock"



richlyall
17-Aug-2012, 02:08
Hi All,

first post..

servers are SLES11SP1 connectiong to a Netapp NFS export
Two servers connecting to same NFS mount point on Netapp (building an MQ 7.5 HA cluster)

When servers are rebooted, the will mount with the following
netapp-iscsi:/vol/nfs_server_export on /opt/MQHA type nfs (rw,noac,hard,intr,nolock,addr=xxx.xxx.xxx.xxx)

I need lock enabled (I am putting in MQ-HA, so for the Qmanager failover I need lock support enabled)

Now the WEIRD thing is that is I umount the /opt/MQHA and run mount -a I get the lock enabled!!!!!!!
netapp-iscsi:/vol/nfs_server_export on /opt/MQHA type nfs (rw,noac,hard,intr,lock,addr=xxx.xxx.xxx.xxx)

I was not even getting nfs locks working when i was using another SLES server to export the filesyste, so I have moved to the NETAPP (which is the ned-game anyway)

Cheers
rich

Automatic reply
23-Aug-2012, 13:30
richlyall,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com