PDA

View Full Version : CUPS (IPP) does not print correctly from windows



Flako000
17-Aug-2012, 13:33
Hello
I am trying to print from Windows, an HP 1160 (parallel port) that is connected in a SLED 10 SP2 (cups-1.1.23-40.4)
The printer prints fine from SLED, but to configure the printer from windows as a network printer (IPP) not walk properly.
When sending a test page from windows, not printed out the test page expected, only @ PJL printer commands. example:




-12345X@PJL SET STRINGCODESET=UTF8
@PJL JOB NAME=" test page"
@PJL COMMENT="\\http://pcName:631\NamePrinter (61.63.461.42); Microsoft Windows XP 5.1.2600.1; (and more numbers)
@PJL COMMENT="Username: Adminstrator; App Filename:test page; 8-14-2012"
@PJL SET JOBATTR="jobAcct1=Admistrator"
@PJL SET JOBATTR="jobAcct2=pcName"

(many lines more of SET ...)

@PJL ENTER LANGUAGE=PCLXL
) HP-PLC XL;2;0; Comment fast raster packager
)


You dont know what else to look, if not look at the cups or windows .. (and reinstall the latest printer driver in Windows)

Any idea where to look?

Automatic reply
23-Aug-2012, 13:30
Flako000,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

Flako000
30-Aug-2012, 13:14
Well, answer me ..
The error indicates that the printer must be configured as raw cups and use the Windows printer driver. (doing that works well)

mikewillis
30-Aug-2012, 18:42
Well, answer me ..
People who post on the forums do so on their own time of their own will. Forums are not an official support channel. If you want to ask a question of someone obligated to answer you, raise a Service Request. ;)

I have no idea how to solve your problem, but I can tell you that SLED 10 SP2 is end of life and hence unsupported. It has been for some time. SLED 10 is still supported but you need to be on SLED 10 SP4. Sometimes problems are solved simply by updating to the latest version(s).



The error indicates that the printer must be configured as raw cups and use the Windows printer driver.

Which error?



(doing that works well)
So... do that? I don't think I understand what you mean.

Flako000
06-Sep-2012, 13:37
Hello mikewillis
Totally agree with what you say .. nobody is forced to answer .. (it was not my intention to ask that way)
Just answer my own post to make it for future reading. :)

I'm using google translate, and I guess I passed the subtleties.

Greetings.