PDA

View Full Version : Need Help Please GNUTLS, update



Karim C Kronfli
20-Aug-2012, 10:14
Hi All, I am setting up a SLES 11 SP2 box.

I have taken an SP1 Template on my VMWare Estate and booted from the SP2
ISO to do the upgrade.

I have updated the repos to the appropriate ones on my SMT server

I then got the following error during the initial patch sequence

nothing provides gnutls(cert-auth) needed by
libsoup-2_4-1-2.32.2-4.11.1.x86_64

At the moment I have refused that particular patch

Can anyone help me by explaining what I am missing or I need to fix this?

I have tried installing gnutls but that does not provide the
requirement. Do I need some kind of certificate setting up?

TIA

Karim

malcolmlewis
20-Aug-2012, 12:29
Hi All, I am setting up a SLES 11 SP2 box.

I have taken an SP1 Template on my VMWare Estate and booted from the
SP2 ISO to do the upgrade.

I have updated the repos to the appropriate ones on my SMT server

I then got the following error during the initial patch sequence

nothing provides gnutls(cert-auth) needed by
libsoup-2_4-1-2.32.2-4.11.1.x86_64

At the moment I have refused that particular patch

Can anyone help me by explaining what I am missing or I need to fix
this?

I have tried installing gnutls but that does not provide the
requirement. Do I need some kind of certificate setting up?

TIA

Karim

Hi
Do you have the SP2 update repository active? You need to run;


zypper in libgnutls26

Have you seen this document;
http://www.suse.com/support/kb/doc.php?id=7010225

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 14:50, 2 users, load average: 0.22, 0.20, 0.15
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Karim C Kronfli
20-Aug-2012, 16:42
On 20/08/2012 12:29, malcolmlewis wrote:
>
Hi All, I am setting up a SLES 11 SP2 box.
>
> I have taken an SP1 Template on my VMWare Estate and booted from the
> SP2 ISO to do the upgrade.
>
> I have updated the repos to the appropriate ones on my SMT server
>
> I then got the following error during the initial patch sequence
>
> nothing provides gnutls(cert-auth) needed by
> libsoup-2_4-1-2.32.2-4.11.1.x86_64
>
> At the moment I have refused that particular patch
>
> Can anyone help me by explaining what I am missing or I need to fix
> this?
>
> I have tried installing gnutls but that does not provide the
> requirement. Do I need some kind of certificate setting up?
>
> TIA
>
> Karim
>
> Hi
> Do you have the SP2 update repository active? You need to run;
>

> zypper in libgnutls26
>
> Have you seen this document;
> http://www.suse.com/support/kb/doc.php?id=7010225
>

Hi Yes I did have the repositories active but was missing one of them
the Extension Store.

I'll give that a go

Thanks

Karim

Karim C Kronfli
22-Aug-2012, 13:17
On 20/08/2012 12:29, malcolmlewis wrote:
>
Hi All, I am setting up a SLES 11 SP2 box.
>
> I have taken an SP1 Template on my VMWare Estate and booted from the
> SP2 ISO to do the upgrade.
>
> I have updated the repos to the appropriate ones on my SMT server
>
> I then got the following error during the initial patch sequence
>
> nothing provides gnutls(cert-auth) needed by
> libsoup-2_4-1-2.32.2-4.11.1.x86_64
>
> At the moment I have refused that particular patch
>
> Can anyone help me by explaining what I am missing or I need to fix
> this?
>
> I have tried installing gnutls but that does not provide the
> requirement. Do I need some kind of certificate setting up?
>
> TIA
>
> Karim
>
> Hi
> Do you have the SP2 update repository active? You need to run;
>

> zypper in libgnutls26
>
> Have you seen this document;
> http://www.suse.com/support/kb/doc.php?id=7010225
>

Hi Malcolm we were indeed missing the one of the repos specifcally the
"extension store"
I added it to my SMT and re-registered the server, it picked up the
details and bingo that seems to have cracked it.

Thanks

Karim