PDA

View Full Version : Default gateway on SLES11sp1 with 2 NIC's



John_Gill
24-Aug-2012, 10:33
Hi,

In the server I have 2 NIC's configured to connect to 2 different VLAN's. I have set up several VM's connecting to either of the interfaces. This is all working correctly.
The issue I am having is trying to set a default gateway to each physical interface.

Eth0 10.1.1.10 VLAN1 Br0 and the gateway should be 10.1.1.1
Eth1 10.2.2.10 VLAN2 Br1 and the gateway should be 10.2.2.1

From the server I can ping each interface, and any device on both subnets, but nothing on any other remote subnet.

If I am on the 10.1.1.0 network I can ping all the VMs and the 10.1.1.10, but not the 10.2.2.10
If I am on the 10.2.2.0 network I can ping all the VMs and the 10.2.2.10, but not the 10.1.1.10

The "route" command returns the following:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.1.0 * 255.255.255.0 U 0 0 0 br0
10.2.2.0 * 255.255.255.0 U 0 0 0 br1
loopback * 255.0.0.0 U 0 0 0 lo

I need to configure a default gateway for each interface, without bridging the network.
Any ideas or help would be great.
Regards
John

smflood
24-Aug-2012, 13:49
On 24/08/2012 10:34, John Gill wrote:

> In the server I have 2 NIC's configured to connect to 2 different
> VLAN's. I have set up several VM's connecting to either of the
> interfaces. This is all working correctly.
> The issue I am having is trying to set a default gateway to each
> physical interface.
>
> Eth0 10.1.1.10 VLAN1 Br0 and the gateway should be 10.1.1.1
> Eth1 10.2.2.10 VLAN2 Br1 and the gateway should be 10.2.2.1
>
> From the server I can ping each interface, and any device on both
> subnets, but nothing on any other remote subnet.
>
> If I am on the 10.1.1.0 network I can ping all the VMs and the
> 10.1.1.10, but not the 10.2.2.10
> If I am on the 10.2.2.0 network I can ping all the VMs and the
> 10.2.2.10, but not the 10.1.1.10
>
> The "route" command returns the following:
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 10.1.1.0 * 255.255.255.0 U 0 0
> 0 br0
> 10.2.2.0 * 255.255.255.0 U 0 0
> 0 br1
> loopback * 255.0.0.0 U 0
> 0 0 lo
>
> I need to configure a default gateway for each interface, without
> bridging the network.
> Any ideas or help would be great.

Duplicate post - answered in SLES: Networking forum @
https://forums.suse.com/showthread.php?1457
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------