PDA

View Full Version : SLED 11 with KDE and autoyast- autologin and start the X



satanowicz
03-Sep-2012, 14:53
Hi.

I'm trying to do an unattended install of SLED with KDE.
After the install, reboot and preconfiguration the system just boots into the console and ask me to login.
After the manual login and "startx" command everything is fine but I want those to be automated.

The runlevel is set to 5

<runlevel>
<default>5</default>
</runlevel>

And the displaymanager is set to autologin as root:

<sysconfig config:type="list" >
<sysconfig_entry>
<sysconfig_key>DISPLAYMANAGER_AUTOLOGIN</sysconfig_key>
<sysconfig_path>/etc/sysconfig/displaymanager</sysconfig_path>
<sysconfig_value>root</sysconfig_value>
</sysconfig_entry>
</sysconfig>
The autologin_user is also fixed:

<login_settings>
<autologin_user>root</autologin_user>
</login_settings>

I know it's now safe to autologin as root but I need it on a test machine (not connected to the Internet)

malcolmlewis
03-Sep-2012, 16:23
Hi.

I'm trying to do an unattended install of SLED with KDE.
After the install, reboot and preconfiguration the system just boots
into the console and ask me to login.
After the manual login and "startx" command everything is fine but I
want those to be automated.

The runlevel is set to 5

Code:
--------------------
<runlevel>
<default>5</default>
</runlevel>
--------------------


And the displaymanager is set to autologin as root:

Code:
--------------------
<sysconfig config:type="list" >
<sysconfig_entry>
<sysconfig_key>DISPLAYMANAGER_AUTOLOGIN</sysconfig_key>
<sysconfig_path>/etc/sysconfig/displaymanager</sysconfig_path>
<sysconfig_value>root</sysconfig_value>
</sysconfig_entry>
</sysconfig>
--------------------

The autologin_user is also fixed

Code:
--------------------
<login_settings>
<autologin_user>root</autologin_user>
</login_settings>
--------------------



Hi
Autologin as root into X??? yikes!

Have via YaST /etc/sysconfig editor, I'm pretty sure it's disabled for
root user to autologin.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 1:25, 3 users, load average: 0.06, 0.42, 0.52
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

satanowicz
04-Sep-2012, 10:04
Hi
Autologin as root into X??? yikes!

I know it's now safe to autologin as root but I need it on a test machine (not connected to the Internet)


Have via YaST /etc/sysconfig editor, I'm pretty sure it's disabled for
root user to autologin.

I've tried it also with a normal user, with the same result
What exactly do I have to modify to make it work?

malcolmlewis
04-Sep-2012, 13:45
malcolmlewis;6653 Wrote:
> Hi
> Autologin as root into X??? yikes!
>
I know it's now safe to autologin as root but I need it on a test
machine (not connected to the Internet)
malcolmlewis;6653 Wrote:
>
> Have via YaST /etc/sysconfig editor, I'm pretty sure it's disabled for
> root user to autologin.
>
I've tried it also with a normal user, with the same result
What exactly do I have to modify to make it work?



Hi
These settings worked for me;


DISPLAYMANAGER_SHUTDOWN = all
DISPLAYMANAGER_AUTOLOGIN = root



--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 11:27, 4 users, load average: 0.05, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU