PDA

View Full Version : Touchpad



naren_bishayee
13-Sep-2012, 06:39
Hi all,
Lastday I re-installed SLED-11-SP2 32 bit with Gnome, but I cant able to only scroll with my touchpad, rest of the functions are well (click, cursor movement). Whenever I tried to open "Touchpad" from Control Center, it displaying the below message,
"GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics"

But system automatically installed GSynaptics, checked from "Software manager"

Can any one give me the suggestion, how to activate the touchpad.

malcolmlewis
14-Sep-2012, 04:14
Hi all,
Lastday I re-installed SLED-11-SP2 32 bit with Gnome, but I
cant able to only scroll with my touchpad, rest of the functions are
well (click, cursor movement). Whenever I tried to open "Touchpad" from
Control Center, it displaying the below message,
"GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use
GSynaptics"

But system automatically installed GSynaptics, checked from "Software
manager"

Can any one give me the suggestion, how to activate the touchpad.



Hi
Have you used YaST to setup the display (including the touchpad)?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 3 days 7:22, 4 users, load average: 0.21, 0.16, 0.13
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

naren_bishayee
16-Sep-2012, 04:15
Hi malcolm,
Yes, I also used Yast to setup touchpad, but, when I open "Mouse Model", I found "Mouse 1" is enabled & "Mouse : <undefined>" and also the "Mouse 2" is disabled, so if I set it ("Mouse 1") to "Synaptics Touchpad" & during saveing the settings without test sax2 display the following error popup

"Saving Configuration Failed"
"The following report has been created"
"saX library : success"
"X configuration : Data incomplete in file"
"/var/lib/sax/xorg.confData incomplete in file"
"/var/lib/sax/xorg.conf Undefined Screen "aticonfig-Screen[0]-0" referenced by ServerLayout"
""Layout[all]". Undefined Screen "aticonfig-Screen[0]-0" referenced by ServerLayout "Layout[all]""

One thing is that, for display problem, I remove ati packages from Software Management , restart the system, boot from PAE kernel and installed "amd-driver-installer-12.6-legacy-x86.x86_64.run" from amd site, where I choose 4300 series card, because before doing these I opened "Amd catalyst Control center" & there I found my graphics card is 4300 series. And after a restart, compiz is working with PAE kernel.

But still touchpad is not working (scroll).

malcolmlewis
16-Sep-2012, 04:37
Hi malcolm,
Yes, I also used Yast to setup touchpad, but, when
I open "Mouse Model", I found "Mouse 1" is enabled & "Mouse :
<undefined>" and also the "Mouse 2" is disabled, so if I set it ("Mouse
1") to "Synaptics Touchpad" & during saveing the settings without test
sax2 display the following error popup

"Saving Configuration Failed"
"The following report has been created"
"saX library : success"
"X configuration : Data incomplete in file"
"/var/lib/sax/xorg.confData incomplete in file"
"/var/lib/sax/xorg.conf Undefined Screen "aticonfig-Screen[0]-0"
referenced by ServerLayout"
""Layout[all]". Undefined Screen "aticonfig-Screen[0]-0" referenced by
ServerLayout "Layout[all]""

One thing is that, for display problem, I remove ati packages from
Software Management , restart the system, boot from PAE kernel and
installed "amd-driver-installer-12.6-legacy-x86.x86_64.run" from amd
site, where I choose 4300 series card, because before doing these I
opened "Amd catalyst Control center" & there I found my graphics card is
4300 series. And after a restart, compiz is working with PAE kernel.

But still touchpad is not working (scroll).



Hi
OK, do you get any output that identifies the device from the command;


xinput
and
synclient


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 5 days 7:44, 4 users, load average: 0.19, 0.20, 0.18
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

naren_bishayee
17-Sep-2012, 10:18
HI malcolm,
can you give me the proper code to execute, I tried "xinput" "synclient" two individual command & outcome is help from above two commands.

AlexDudko
18-Sep-2012, 10:17
HI malcolm,
can you give me the proper code to execute, I tried "xinput" "synclient" two individual command & outcome is help from above two commands.


xinput list

For the latter command it should be

synclient -l
to list current user settings, but in my case the output is "Couldn't find synaptics properties. No synaptics driver loaded?" though touchpad is working.

naren_bishayee
18-Sep-2012, 12:41
Thanks Alex,

naren_bishayee@linux-9dxj:~> xinput list
"Virtual core pointer" id=0 [XPointer]
Num_buttons is 32
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 0
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 0
"Virtual core keyboard" id=1 [XKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
"Keyboard[0]" id=2 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
"Mouse[1]" id=3 [XExtensionPointer]
Type is MOUSE
Num_buttons is 9
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 1
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 1
=========================================

naren_bishayee@linux-9dxj:~> synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?
naren_bishayee@linux-9dxj:~>

sollndas
29-Dec-2014, 09:51
Hi all,
Lastday I re-installed SLED-11-SP2 32 bit with Gnome, but I cant able to only scroll with my touchpad, rest of the functions are well (click, cursor movement). Whenever I tried to open "Touchpad" from Control Center, it displaying the below message,
"GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics"

But system automatically installed GSynaptics, checked from "Software manager"

Can any one give me the suggestion, how to activate the touchpad.

I had the same problem in openSUSE 13.1 with LXDE.
The touchpad was disabled by the boot option "psmouse.proto=bare".
Deleting this option cured the problem.

Regards
sollndas