PDA

View Full Version : Driver for SLED



olcerel
22-Sep-2012, 17:42
I want to install the driver for a Mellanox ConnectX IB/gigE card running on SLED11 SP1. The driver Mellanox offers is for SLES11 SP1. When I try to install this version, I get "libstdc++ rpm is required" although it already is. Any suggestions ? Should I still be able to install The SLES version of the driver on SLED ? What is the difference ?

malcolmlewis
22-Sep-2012, 18:08
I want to install the driver for a Mellanox ConnectX IB/gigE card
running on SLED11 SP1. The driver Mellanox offers is for SLES11 SP1.
When I try to install this version, I get "libstdc++ rpm is required"
although it already is. Any suggestions ? Should I still be able to
install The SLES version of the driver on SLED ? What is the difference
?



Hi
Differing kernels release between SP1 and SP2. Can you provide some
more info;

Do you have the download link for the driver?

Can you post the output from for the device;


lspci -nn

eg on this system;
0b:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5761e Gigabit Ethernet PCIe [14e4:1680] (rev 10)


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 13:00, 5 users, load average: 0.09, 0.09, 0.10
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

olcerel
24-Sep-2012, 06:05
Hi Malcolm,

Here is some info :

mistika:/install # lspci | grep Mellanox
03:00.0 InfiniBand: Mellanox Technologies MT26428 [ConnectX VPI PCIe 2.0 5GT/s - IB QDR / 10GigE] (rev b0)
--------------------------------------------------------------------------------------------
mistika:/mnt # uname -a
Linux mistika 2.6.32.12-0.7-default #1 SMP 2010-05-20 11:14:20 +0200 x86_64 x86_64 x86_64 GNU/Linux
----------------------------------------------------------------------------------------------------------------------------
mistika:/mnt # cat /etc/issue
Welcome to SUSE Linux Enterprise Desktop 11 SP1 (x86_64) - Kernel \r (\l).
-----------------------------------------------------------------------------------------------------------------------------
downloaded : MLNX_OFED_LINUX-1.5.3-3.1.0-sles11sp1-x86_64.iso
from :
http://www.mellanox.com/content/pages.php?pg=products_dyn&product_family=26&menu_section=34#tab-three
---------------------------------------------------------------------------------------------------------------------------
when I do :
mount -o ro,loop MLNX_OFED_LINUX-1.5.3-3.1.0-sles11sp1-x86_64.iso /mnt
cd /mnt
mistika:/mnt # ./mlnxofedinstall
I get :
libstdc++ rpm is required to install mft rpm is required to install
libstdc++ ibutils2 rpm is required to install ibutils rpm is required to
libstdc++ install cc_mgr rpm is required to install dump_pr rpm is
libstdc++ required to install ar_mgr rpm is required to install ibdump
libstdc++ rpm is required to install mxm rpm is required to install
libstdc++ openmpi_gcc

"rpm -qa|grep libstdc++" gives :

mistika:~ # rpm -qa|grep libstdc++
libstdc++43-32bit-4.3.4_20091019-0.7.35
libstdc++43-4.3.4_20091019-0.7.35
libstdc++43-devel-4.3.4_20091019-0.7.35
libstdc++-devel-4.3-62.198
libstdc++43-devel-32bit-4.3.4_20091019-0.7.35

Thanks.
Oner Olcerel




Hi
Differing kernels release between SP1 and SP2. Can you provide some
more info;

Do you have the download link for the driver?

Can you post the output from for the device;


lspci -nn

eg on this system;
0b:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5761e Gigabit Ethernet PCIe [14e4:1680] (rev 10)


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 13:00, 5 users, load average: 0.09, 0.09, 0.10
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

mikewillis
24-Sep-2012, 13:02
mistika:/mnt # ./mlnxofedinstall
I get :
libstdc++ rpm is required to install mft rpm is required to install
libstdc++ ibutils2 rpm is required to install ibutils rpm is required to
libstdc++ install cc_mgr rpm is required to install dump_pr rpm is
libstdc++ required to install ar_mgr rpm is required to install ibdump
libstdc++ rpm is required to install mxm rpm is required to install
libstdc++ openmpi_gcc

That looks badly formatted and possibly truncated. Is that exactly how it appears on screen? If not can you post what you see but wrap it in CODE tags to preserve the formatting? (CODE tags can be applied by selecting text then clicking the # button on the toolbar.)

You seem to be approaching the problem on the assumption that you need to install llibstdc++ but I'm not sure that's the case. If you read that dubiously formatted output it seems to be saying that other rpms need to be installed. E.g. "ibutils2 rpm is required" "ar_mgr rpm is required". Some of those RPMS are in the SLED repos or the SLE-SDK (http://download.novell.com/index.jsp?&search=Search&families=8389) repos. Some of them aren't, but if you look in the RPMS directory of what you've downloaded you'll find rpms for dump_pr and cc_mgr.

Have you looked at the stuff in the docs directory of what you've downloaded?

I've not been able to get it to installed. I don't have SLED/SLED 11 SP1 around any more. I downloaded the packages for SLES SP2 but I get


localhost:/tmp/MLNX_OFED_LINUX-1.5.3-3.1.0-sles11sp2-x86_64 # ./mlnxofedinstall
The 3.0.38-0.5-default kernel is installed, MLNX_OFED does not have drivers available for this kernel.
You can run docs/mlnx_add_kernel_support.sh in order to to generate an MLNX_OFED package with drivers for this kernel.
localhost:/tmp/MLNX_OFED_LINUX-1.5.3-3.1.0-sles11sp2-x86_64 # ./mlnx_add_kernel_support.sh -i ../MLNX_OFED_LINUX-1.5.3-3.1.0-sles11sp2-x86_64.iso
ERROR: Linux Distribution (sled-release-11.2-1.513) is not supported
Which seems somewhat contradictory but there you go.