PDA

View Full Version : SLES11, Prepping to install Oracle 11g - X Window issues



jpquinn
23-Sep-2012, 00:46
Hello,

I have recently installed SLES 11 SP2, and now I'm prepping to install Oracle 11g R2.

I am following the steps of:

Oracle« Database
Quick Installation Guide
11g Release 2 (11.2) for Linux x86-64
E24326-02
May 2012

And I'm not procedure 8, Configuring the oracle Userĺs Environment.

I open an xterm (I'm logged as a regular user, and have sudo sh to su)

I key in (an example here)

sh-3.2# xhost xhost somehost.us.example.com
xhost: unable to open display ""

sh-3.2# xhost +
xhost: unable to open display ""


I have also tried to log on the the Oracle user "oracle" and I can get in with the username and password, but as soon as it comes up, a message displays saying that X Windows is not enabled.

I understand that X Windows is used for the Oracle install, and that it is done via the Oracle user "oracle". I cant find anything on the SLES box that has anything related to X Windows installed, or configuration.

Any advise of help in getting X Windows and I presume the x11 server, and getting the oracle user running on X Windows to get Oracle installed would be greatly appreciated.

Thanks, Jay

malcolmlewis
23-Sep-2012, 01:59
Hello,

I have recently installed SLES 11 SP2, and now I'm prepping to install
Oracle 11g R2.

I am following the steps of:

Oracle® Database
Quick Installation Guide
11g Release 2 (11.2) for Linux x86-64
E24326-02
May 2012

And I'm not procedure 8, Configuring the oracle User┬ĺs Environment.

I open an xterm (I'm logged as a regular user, and have sudo sh to su)

I key in (an example here)

sh-3.2# xhost xhost somehost.us.example.com
xhost: unable to open display ""

sh-3.2# xhost +
xhost: unable to open display ""


I have also tried to log on the the Oracle user "oracle" and I can get
in with the username and password, but as soon as it comes up, a message
displays saying that X Windows is not enabled.

I understand that X Windows is used for the Oracle install, and that it
is done via the Oracle user "oracle". I cant find anything on the SLES
box that has anything related to X Windows installed, or configuration.

Any advise of help in getting X Windows and I presume the x11 server,
and getting the oracle user running on X Windows to get Oracle installed
would be greatly appreciated.

Thanks, Jay



Hi
If you can open an xterm, you are in an X windows session, be it twm,
gnome, kde etc

Open a terminal and temporarily allow the connection;


xhost +
su -
sh
do your stuff
exit
exit
xhost -



--
Cheers Malcolm ┬░┬┐┬░ (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 7:02, 5 users, load average: 0.10, 0.17, 0.32
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
23-Sep-2012, 02:05
Hello,

I have recently installed SLES 11 SP2, and now I'm prepping to install
Oracle 11g R2.

I am following the steps of:

Oracle® Database
Quick Installation Guide
11g Release 2 (11.2) for Linux x86-64
E24326-02
May 2012

And I'm not procedure 8, Configuring the oracle User┬ĺs Environment.

I open an xterm (I'm logged as a regular user, and have sudo sh to su)

I key in (an example here)

sh-3.2# xhost xhost somehost.us.example.com
xhost: unable to open display ""

sh-3.2# xhost +
xhost: unable to open display ""


I have also tried to log on the the Oracle user "oracle" and I can get
in with the username and password, but as soon as it comes up, a message
displays saying that X Windows is not enabled.

I understand that X Windows is used for the Oracle install, and that it
is done via the Oracle user "oracle". I cant find anything on the SLES
box that has anything related to X Windows installed, or configuration.

Any advise of help in getting X Windows and I presume the x11 server,
and getting the oracle user running on X Windows to get Oracle installed
would be greatly appreciated.

Thanks, Jay



Hi
If you can open an xterm, you are in an X windows session, be it twm,
gnome, kde etc

Open a terminal and temporarily allow the connection;


xhost +
su -
sh
do your stuff
exit
exit
xhost -




You could also try this;


xauth add "$(/bin/hostname)/unix:0" MIT-MAGIC-COOKIE-1 $( xauth list "localhost/unix:0" | awk '{print $3}' )


--
Cheers Malcolm ┬░┬┐┬░ (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 7:10, 5 users, load average: 0.16, 0.15, 0.25
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

jpquinn
23-Sep-2012, 03:06
Hi Malcolm,

I ran the x commands you mentioned in the first reply, and when I keyed in xhost + and xhost -, I get this error: "xhost: unable to open display "

I ran the code line you provided in the second reply, and it executed without error,just returned the #_ prompt.

I then ran xhost + and get: "unable to open display "

I ran startx and got this: sh-3.2# startx
xauth: creating new authority file /root/.serverauth.28145

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

malcolmlewis
23-Sep-2012, 03:46
Hi Malcolm,

I ran the x commands you mentioned in the first reply, and when I keyed
in xhost + and xhost -, I get this error: "xhost: unable to open
display "

I ran the code line you provided in the second reply, and it executed
without error,just returned the #_ prompt.

I then ran xhost + and get: "unable to open display "

I ran startx and got this: sh-3.2# startx
xauth: creating new authority file /root/.serverauth.28145

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't
already running

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.



Hi
You don't need to use the xhost command now you ran the other one
(hopefully as your user)....

So, you login as your user, then open an xterm or other terminal in a X
windows session;


xauth add "$(/bin/hostname)/unix:0" MIT-MAGIC-COOKIE-1 $( xauth list "localhost/unix:0" | awk '{print $3}' )
su -
<do your stuff as root user>
exit

You will not have to run the first command again (xauth....)

--
Cheers Malcolm ┬░┬┐┬░ (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 8:47, 5 users, load average: 0.12, 0.20, 0.28
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

jpquinn
23-Sep-2012, 19:44
Hi Malcolm,

You are correct, and as it turns out, after running the xauth command string you provided, it works, The main thing I did, was reboot, Sounds to simple, or obvious, almost MS-Windows like! However it is working. I tested it out with xeyes and xclock. I also deleted the apparent pre-made "oracle" user account, and remade it with proper groups, etc.. and signed on with su - oracle, and switch user to oracle user and tested out with xeyes, and its all in working order as it should be.

Many thanks to you for your help.

Jay