PDA

View Full Version : xmkmf -a



wayneholland
02-Feb-2011, 20:06
I have an old Imakefile with source to build an X11 program.
By typing in at the console xmkmf -a the make program stops with an
error at
MSimpleProgramTarget(program).

It seems that that there may be a discrepancy in one of the rules or
templates that are found
in /usr/share/X11/config

Not sure if this is the correct forum to ask this, but what is
happening here?


--
wayneholland
------------------------------------------------------------------------
wayneholland's Profile: http://forums.novell.com/member.php?userid=103832
View this thread: http://forums.novell.com/showthread.php?t=431508

malcolmlewis
02-Feb-2011, 20:20
On Wed, 02 Feb 2011 19:06:03 GMT
wayneholland <wayneholland@no-mx.forums.novell.com> wrote:

>
> I have an old Imakefile with source to build an X11 program.
> By typing in at the console xmkmf -a the make program stops with an
> error at
> MSimpleProgramTarget(program).
>
> It seems that that there may be a discrepancy in one of the rules or
> templates that are found
> in /usr/share/X11/config
>
> Not sure if this is the correct forum to ask this, but what is
> happening here?
>
>
Hi
That looks like a motif error, do you have the motif devel pacakges
installed? Also what version of SLE and arch are you running?

--
Cheers Malcolm (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
up 15 days 4:45, 2 users, load average: 0.04, 0.05, 0.07
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36

malcolmlewis
02-Feb-2011, 20:24
On Wed, 02 Feb 2011 19:06:03 GMT
wayneholland <wayneholland@no-mx.forums.novell.com> wrote:

>
> I have an old Imakefile with source to build an X11 program.
> By typing in at the console xmkmf -a the make program stops with an
> error at
> MSimpleProgramTarget(program).
>
> It seems that that there may be a discrepancy in one of the rules or
> templates that are found
> in /usr/share/X11/config
>
> Not sure if this is the correct forum to ask this, but what is
> happening here?
>
>
Else try without the -a option as long as your running in the directory
where the Imakefile is.

--
Cheers Malcolm (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
up 15 days 4:49, 2 users, load average: 0.13, 0.05, 0.05
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36

wayneholland
02-Feb-2011, 22:36
I have OpenMotif installed, on a core-2 duo platform, running OpenSuse
11.3.
I've also noticed the same identical problem running on Solaris 10,
which has a CDE environment.
It seems that imake didn't handle MSimpleProgramTarget properly or most
likely one of the configuration files needs further tweaking.
I did make one edit to Imake.tmpl to change a NO to a YES in regards to
HasOpenMotif2. No change. If I add a tab in front of
MSimpleProgramTarget(program), make still chokes on it, and I believe
that this is not what make will deal with.


--
wayneholland
------------------------------------------------------------------------
wayneholland's Profile: http://forums.novell.com/member.php?userid=103832
View this thread: http://forums.novell.com/showthread.php?t=431508

malcolmlewis
02-Feb-2011, 23:03
On Wed, 02 Feb 2011 21:36:04 GMT
wayneholland <wayneholland@no-mx.forums.novell.com> wrote:

>
> I have OpenMotif installed, on a core-2 duo platform, running OpenSuse
> 11.3.
> I've also noticed the same identical problem running on Solaris 10,
> which has a CDE environment.
> It seems that imake didn't handle MSimpleProgramTarget properly or
> most likely one of the configuration files needs further tweaking.
> I did make one edit to Imake.tmpl to change a NO to a YES in regards
> to HasOpenMotif2. No change. If I add a tab in front of
> MSimpleProgramTarget(program), make still chokes on it, and I believe
> that this is not what make will deal with.
>
>
Hi
I suggest asking in the openSUSE forum - Programming/Scripting subforum;
http://forums.opensuse.org/english/other-forums/development/programming-scripting/

--
Cheers Malcolm (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
up 15 days 7:27, 2 users, load average: 0.00, 0.04, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36