PDA

View Full Version : IPv6 and sysctl problem



scarab
25-Sep-2012, 10:03
I`ve got one eth card in my server with interfaces configured as below:

eth0 static IPv4 and IPv6 address
vlan1 static IPv4 address
vlan2 static IPv4 address

The problem is that I`m receiving from my network Router Advertisement and SLES receives and accepts IPv6 addresses and gateways to all of interfaces.
I have to disable it so I configured sysctl.conf as listed below:



net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.vlan1.autoconf = 0
net.ipv6.conf.vlan2.autoconf = 0
net.ipv6.conf.default.autoconf = 0
#
net.ipv6.conf.all.router_solicitations = 0
net.ipv6.conf.default.router_solicitations = 0
net.ipv6.conf.eth0.router_solicitations = 0
net.ipv6.conf.vlan1.router_solicitations = 0
net.ipv6.conf.vlan2.router_solicitations = 0
#
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.eth0.accept_ra = 0
net.ipv6.conf.vlan1.accept_ra = 0
net.ipv6.conf.vlan2.accept_ra = 0


When I`m running sysctl -p everything seems to work fine, when I`m checking for example:



sysctl -a | grep .autoconf
net.ipv6.conf.vlan1.autoconf = 0
net.ipv6.conf.vlan2.autoconf = 0
net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.lo.autoconf = 1


sysctl -a | grep router_solicitations
net.ipv6.conf.vlan1.router_solicitations = 0
net.ipv6.conf.vlan2.router_solicitations = 0
net.ipv6.conf.eth0.router_solicitations = 0
net.ipv6.conf.default.router_solicitations = 0
net.ipv6.conf.all.router_solicitations = 0
net.ipv6.conf.lo.router_solicitations = 3

sysctl -a | grep accept_ra
net.ipv6.conf.vlan1.accept_ra = 0
net.ipv6.conf.vlan2.accept_ra = 0
net.ipv6.conf.eth0.accept_ra = 0
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.lo.accept_ra = 1


But when I`m running rcnetwork restart and then ifconfig I can see that system still has IPv6 configutation captured from router :/
Another thing is that sysctl seems not working after reboot, I`ve got this in /var/log/boot.msg:



Activating remaining swap-devices in /etc/fstab...
doneSetting current sysctl status from /etc/sysctl.conf
net.ipv4.icmp_echo_ignore_broadcasts = 1
net.ipv4.conf.all.rp_filter = 1
/proc/sys/net/ipv6/conf/all/autoconf: No such file or directory
/proc/sys/net/ipv6/conf/eth0/autoconf: No such file or directory
/proc/sys/net/ipv6/conf/vlan1/autoconf: No such file or directory
/proc/sys/net/ipv6/conf/vlan2/autoconf: No such file or directory
/proc/sys/net/ipv6/conf/default/autoconf: No such file or directory
/proc/sys/net/ipv6/conf/all/router_solicitations: No such file or directory
/proc/sys/net/ipv6/conf/default/router_solicitations: No such file or directory
/proc/sys/net/ipv6/conf/eth0/router_solicitations: No such file or directory
/proc/sys/net/ipv6/conf/vlan1/router_solicitations: No such file or directory
/proc/sys/net/ipv6/conf/vlan2/router_solicitations: No such file or directory
/proc/sys/net/ipv6/conf/all/accept_ra: No such file or directory
/proc/sys/net/ipv6/conf/default/accept_ra: No such file or directory
/proc/sys/net/ipv6/conf/eth0/accept_ra: No such file or directory
/proc/sys/net/ipv6/conf/vlan1/accept_ra: No such file or directory
/proc/sys/net/ipv6/conf/vlan2/accept_ra: No such file or directory


How to fix this problems?

Automatic reply
04-Oct-2012, 13:30
scarab,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

frlarson
21-Dec-2012, 19:09
I found your post while attempting to find an answer for a similar problem with SLES. My problem was trying to set sysctl parameters in a /proc entry that did not yet exist because the bridge module was not yet loaded. I added the bridge module to /etc/sysconfig/kernel, ran mkinitrd, and rebooted and it worked. I am not sure which module creates the proc/sys/net/ipv6/conf/ entries but if you find that I think it will solve your problem. Too bad Novell couldn't help a little.