PDA

View Full Version : PostgresSql's client libs uses linux-vdso32.so.1 ?



martinrame
27-Sep-2012, 21:15
Hi, I moved this question from opensuse's forum, hopefully I'll find some help here.

I compiled PostgreSql 9.1 from sources in a OpenSuse 10.1 PowerPC machine. While trying to test one application, I've got errors just before connecting to the database, and found my app is loading linux-vdso64.so.1 while libpq.so uses linux-vdso32.so.1

This means the Postgres libraries where compiled in 32 bits?. This is what ldd gives:


ldd /usr/local/pgsql/lib/libpq.so
linux-vdso32.so.1 => (0x00100000)
libpthread.so.0 => /lib/power6x/libpthread.so.0 (0x6ff85000)
libc.so.6 => /lib/power6x/libc.so.6 (0x6fe11000)
/lib/ld.so.1 (0x08000000)

How can I force PostgreSql to compile in 64 bits?.

BTW: here's more info about my environment:



cat /etc/SuSE-release
SUSE Linux Enterprise Server 10 (ppc)
VERSION = 10
PATCHLEVEL = 2




uname -a
Linux linux-uftu 2.6.16.60-0.21-ppc64 #1 SMP Tue May 6 12:41:02 UTC 2008 ppc64 ppc64 ppc64 GNU/Linux

Regards,
Leonardo.

Automatic reply
04-Oct-2012, 13:30
martinrame,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

martinrame
06-Oct-2012, 21:32
martinrame,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

Nope, the issue wansn't solved yet.