PDA

View Full Version : Re: Samba error on some shares



Walter S
30-Aug-2011, 17:26
Add

Code:
--------------------
follow symlinks = Yes
wide links = Yes
--------------------

to your share configuration in smb.conf

Walter


--
Walter_S
------------------------------------------------------------------------
Walter_S's Profile: http://forums.novell.com/member.php?userid=115997
View this thread: http://forums.novell.com/showthread.php?t=441720

gprater
12-Sep-2011, 19:56
I just tired adding the information and restating the service but I
still get the same error. Strange thing is that two existing shares have
now problems. But the one does and any new ones seem go give me the same
error. Here is the config file. The last two shares are the ones haveing
problmes.

Gary

# smb.conf is the main Samba configuration file. You find a full
commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if
the
# samba-doc package is installed.
# Date: 2010-03-12
[global]
# ADDED BY KASPERSKY ANTI-VIRUS FOR LINUX FILE SERVER VERSION
8.0.1.145/RELEASE
vfs object = kav4fs-smb-vfs22-sles
workgroup = workgroup
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = Yes
debug level = 2
max log size = 0


# BEGIN - Entries made by OES install
netbios name = CC1-W
passdb backend = NDS_ldapsam:ldaps://10.1.1.55:636
ldap admin dn = cn=CC1-sambaProxy,o=cottonwood
ldap suffix = o=cottonwood
ldap passwd sync = on
security = user
encrypt passwords = yes

# NOTE: use sendfile is set to no to support nss filesystem shares.
# To improve performance for other filesystems that support
# sendfile remove this line from the global section and add
only
# to share definitions on nss filesystems.
use sendfile = no
wins support = No
wins server =

# END - Entries made by OES install

# Share disabled by OES Install
# [printers]
# comment = All Printers
# path = /var/tmp
# printable = Yes
# create mask = 0600
# browseable = No
# Share disabled by OES Install
# [print$]
# comment = Printer Drivers
# path = /var/lib/samba/drivers
# write list = @ntadmin root
# force group = ntadmin
# create mask = 0664
# directory mask = 0775
#
### Share disabled by YaST
# [netlogon]


# BEGIN - Entries made by OES install

# END - Entries made by OES install

# BEGIN - Entries made to correct share error

follow symlinks = Yes
wide links = Yes

# END - Entries made to correct share error

[shelby]
path = /media/nss/APPS1/programs/Shelby
read only = No
inherit acls = yes


[dept]
path = /media/nss/APPS1
read only = No
inherit acls = yes
comment = null




[scan_files]
path = /media/nss/APPS1/dept/scanner
read only = No
inherit acls = yes
comment =

[test]
path = /media/nss/APPS1/dept/scanner
read only = No
inherit acls = yes
comment =


--
gprater
------------------------------------------------------------------------
gprater's Profile: http://forums.novell.com/member.php?userid=6407
View this thread: http://forums.novell.com/showthread.php?t=441720

Bob-O-Rama
12-Sep-2011, 22:16
Each share has its own [ShareName] section with options specific to
each. You will need to make sure that the share you want to work with
includes the options you need. Its probably not a good idea to have
those symlink directives in the global config as it may inadvertently
allow data to leak from outside the shares. ( Perhaps those directives
are no longer valid globally. ) So try relocating the directives under a
given share, restart SAMBA, and re-test.

-- Bob


--
Bob Mahar -- Novell Knowledge Partner
Do you do what you do at a .EDU? http://novell.com/ttp
"Programming is like teaching a jellyfish to build a house."
More Bob: 'Twitter' (http://twitter.com/BobMahar) 'Blog'
(http://blog.trafficshaper.com) 'Vimeo' (http://vimeo.com/boborama) <--
Click And Be Amazed!
------------------------------------------------------------------------
Bob-O-Rama's Profile: http://forums.novell.com/member.php?userid=5269
View this thread: http://forums.novell.com/showthread.php?t=441720

gprater
12-Sep-2011, 22:56
I gave that a try but still no luck. Any other ideas?

Gary

Error:
[2011/09/12 14:50:04, 2] smbd/vfs.c:reduce_name(897)
reduce_name: Bad access attempt: desktop.ini is a symlink outside the
share path


Config File

[scan_files]
path = /media/nss/APPS1/dept/scanner
read only = No
inherit acls = yes
comment =
follow symlinks = Yes
wide links = Yes

[test]
path = /media/nss/APPS1/dept/scanner
read only = No
inherit acls = yes
comment =
follow symlinks = Yes
wide links = Yes


--
gprater
------------------------------------------------------------------------
gprater's Profile: http://forums.novell.com/member.php?userid=6407
View this thread: http://forums.novell.com/showthread.php?t=441720

Walter S
13-Sep-2011, 07:36
Try adding

Code:
--------------------
unix extensions = no
--------------------

to the [global] section.


Walter


--
Walter_S
------------------------------------------------------------------------
Walter_S's Profile: http://forums.novell.com/member.php?userid=115997
View this thread: http://forums.novell.com/showthread.php?t=441720

gprater
13-Sep-2011, 16:16
It worked. I really appreciate the help. I could not find a lot of
information on this error and was read to give up.

Gary


--
gprater
------------------------------------------------------------------------
gprater's Profile: http://forums.novell.com/member.php?userid=6407
View this thread: http://forums.novell.com/showthread.php?t=441720