PDA

View Full Version : Evaluation license



thehat
05-Oct-2012, 12:19
Hi,

first time user of sles, been using opensuse for a long time although far from an expert. i bought a proliant dl380 G4 which doesnt work with opensuse so here i am. I installed sles 11 sp2, all went ok, and is up and running, but no matter what i do i cant get the repositories to appear. I have tried registering it online via the server which goes ok, the eval license shows up in my account, but there are still no repositories. Do i have to buy a license to evaluate the repositories ?

I need to make sure i can run the few bits and pieces on this before i buy the license really. I need to run: Nagios, MRTG for traffic graphing, and a few other minor things.

I have tried compiling mrtg manually, but I always get the error "gd.h missing"

Many thanks for your time.

malcolmlewis
05-Oct-2012, 12:38
Hi,

first time user of sles, been using opensuse for a long time although
far from an expert. i bought a proliant dl380 G4 which doesnt work with
opensuse so here i am. I installed sles 11 sp2, all went ok, and is up
and running, but no matter what i do i cant get the repositories to
appear. I have tried registering it online via the server which goes
ok, the eval license shows up in my account, but there are still no
repositories. Do i have to buy a license to evaluate the repositories
?

I need to make sure i can run the few bits and pieces on this before i
buy the license really. I need to run: Nagios, MRTG for traffic
graphing, and a few other minor things.

I have tried compiling mrtg manually, but I always get the error "gd.h
missing"

Many thanks for your time.



Hi
You should ensure your system is not present on the customer web page
(ncc) as in delete.

Then run YaST customer center using your email and eval license.

If that doesn't work, ensure it's not on the ncc page and try the
command line;



suse_register -a regcode-sles=YourActivationCode -a email=YourEmailAddress -a moniker=YourHostname -L .suse_register.log


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 17:24, 3 users, load average: 0.15, 0.18, 0.13
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
05-Oct-2012, 12:49
I need to make sure i can run the few bits and pieces on this before i
buy the license really. I need to run: Nagios, MRTG for traffic
graphing, and a few other minor things.

I have tried compiling mrtg manually, but I always get the error "gd.h
missing"

Many thanks for your time.

Hi
You need to add the SLE SDK, this contains additional files and also
devel files for compiling eg php5(3)-devel for gd.h). There is also the
Open Build Service and http://software.opensuse.org/search? of course
these are 'unsupported' as such.

You only need DVD1 (DVD2 is the source rpms)
http://download.novell.com/Download?buildid=NgW3ToaagDQ~

Once the system is properly registered on ncc, you can use YaST add on
product to add the iso image and online repositories.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 17:30, 3 users, load average: 0.14, 0.12, 0.12
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

thehat
05-Oct-2012, 13:21
thanks guys.

in the ncc, my server is listed under "my systems / systems", it shows as "needs activation" not evaluation. how do i activate it ?

thanks,

malcolmlewis
05-Oct-2012, 13:51
thanks guys.

in the ncc, my server is listed under "my systems / systems", it shows
as "needs activation" not evaluation. how do i activate it ?

thanks,



Hi
You need to delete it and re-activate on the system via YaST or the
command line using your evaluation license.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 18:41, 3 users, load average: 0.10, 0.07, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

thehat
05-Oct-2012, 15:15
Hi
You need to add the SLE SDK, this contains additional files and also
devel files for compiling eg php5(3)-devel for gd.h).


ok, so i have the repositores for updates now (i think), where can i find the above ?

malcolmlewis
05-Oct-2012, 15:45
malcolmlewis;9311 Wrote:
> Hi
> You need to add the SLE SDK, this contains additional files and also
> devel files for compiling eg php5(3)-devel for gd.h).
>

ok, so i have the repositores for updates now (i think), where can i
find the above ?



Hi
Download the iso image from here for your arch, you only need DVD1
(DVD2 is the source rpms);
http://download.novell.com/Download?buildid=NgW3ToaagDQ~

Save it on the system somewhere it can remain and then open YaST -> Add
on products, click add and then browse to the iso image etc. It will
add the iso image as a local repository and add the online and update
repositories.

You should then be good to go, Nagios is already there, grab mrtg from
http://software.opensuse.org/package/mrtg server:monitoring for SLE 11
SP2.

Else compile as required....

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 20:30, 3 users, load average: 0.12, 0.14, 0.14
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU