PDA

View Full Version : Remote desktop blocks certain characters



nisuxservice
15-Oct-2012, 09:29
Hi there,

I've set up a SLES 11.2 server and enabled acces from Windows machines via RDP. That thing works like a charm, but with one significant drawback: None of the keyboard characters who need [AltGr] to access them on the german keyboard (i.e. | ~ \) go thru. On the regular console there's no problem with those keys, nor is with VNC sessions.

I have no clue how to fix that and where. :confused:

Any hint ?

malcolmlewis
15-Oct-2012, 13:48
Hi there,

I've set up a SLES 11.2 server and enabled acces from Windows machines
via RDP. That thing works like a charm, but with one significant
drawback: None of the keyboard characters who need [AltGr] to access
them on the german keyboard (i.e. | ~ \) go thru. On the regular console
there's no problem with those keys, nor is with VNC sessions.

I have no clue how to fix that and where. :confused:

Any hint ?



Hi
Is there an option in the client to select the encoding? If so try "RDP
Unicode" if it's present.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2 days 8:05, 3 users, load average: 0.12, 0.10, 0.14
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

nisuxservice
23-Oct-2012, 11:26
Hi
Is there an option in the client to select the encoding? If so try "RDP
Unicode" if it's present.


I've searched for such an option, but I can't find any. The standard mstsc.exe seems not to have any option for that.

Any chance to config xrdp to behave like its Windows counterpart ?

Greetings

nisuxservice

malcolmlewis
23-Oct-2012, 13:35
malcolmlewis;9478 Wrote:
> Hi
> Is there an option in the client to select the encoding? If so try
> "RDP
> Unicode" if it's present.
>

I've searched for such an option, but I can't find any. The standard
mstsc.exe seems not to have any option for that.

Any chance to config xrdp to behave like its Windows counterpart ?

Greetings

nisuxservice



Hi
Just to confirm;

- Access via vnc from windows(what version?) to the SLES
box and opening a console session is fine?

- Access via rdp from windows(what version?) to the SLES
box and opening a console session is not working?

Can you access via ssh, is this ok?

Have you tried from a different windows version or from a linux system
(boot up from a live cd?)

If all of the above, this would indicate a windows issue with encoding?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1 day 9:15, 3 users, load average: 0.14, 0.24, 0.50
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

nisuxservice
29-Oct-2012, 14:10
Hi
- Access via vnc from windows(what version?) to the SLES
box and opening a console session is fine?


Correct. Seen from Win7 and XP. Client is RealVNC or TightVNC.



- Access via rdp from windows(what version?) to the SLES
box and opening a console session is not working?


Correct, too. Seen at least on Win7 and XP (not sure, but may be on 2003 Server, too).



Can you access via ssh, is this ok?


Yes (PuTTY 0.61). Works like a charm.



Have you tried from a different windows version or from a linux system
(boot up from a live cd?)


As we have a heterogenous environment in Win versions: Yes. At least Win7 and XP, 2003 server (AFAIK), too.



If all of the above, this would indicate a windows issue with encoding?


I don't know ... Win - Win RDP connections are flawless, and it spans all available Windows versions.

I would suspect some weird NLS issue within xrdp, at least a misconfiguration. But I don't know wher to fix that problem ...

Greetings

nisuxservice

nisuxservice
13-Nov-2012, 18:16
Yoohoo ?

Any further tip in the pipeline ?

malcolmlewis
25-Nov-2012, 02:32
On Tue 13 Nov 2012 05:24:03 PM CST, nisuxservice wrote:


Yoohoo ?

Any further tip in the pipeline ?




Hi
Heard back from my SUSE contacts, have a look here at possible work
arounds;

As AltGr is a shortcut to useing CTRL + ALT, would using these keys be
a workable alternative ?
(AltGr+<char> seems to be similar as CTRL+ALT +<char>)

Alternatively, try to see if this works :

Configure Windows to stop applying keyboard shortcuts to Terminal
Services sessions. To do this, follow these steps:

Click Start, click Run, type mstsc.exe, and then click OK.

In the Remote Desktop Connection dialog box, click Options, and
then click the Local resources tab.

In the Apply Windows key combinations list, click On the local
computer.

On the General tab, click Save As, type a name in the File name
box, and then click Save.

(taken from https://support.microsoft.com/kb/926934)


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1 day 1:40, 5 users, load average: 1.78, 1.65, 1.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU