PDA

View Full Version : Problems with Linux after full Paragon restore



s660117
05-Nov-2012, 18:50
Hi,
I am running Windows Vista and Suse Linux under dual boot. After a failure, I used Paragon Hard Disk Manager to restore my disk. I re-initialized grep and booted the PC. Instead of the usual green Startup Options screen, I got the message "(HD0,7) boot message: file not found". I was then thrown into a black and white screen that listed my boot options: Windows Vista, Suse Linux, and Failsafe. I successfully selected Windows, but when I tried to bring up Suse. I got the following series of messages --

root (HD0,7)
File system type unknown, partition type 0x82
Kernel boot/vmlinux oot /dev/disk/by-id/ata-ST31000528As_iVP77IVT-part 8 repair-1 resume=dev/disk/by-id/ata-ST31000628AS_IVP771VT-part 7 splash=silent showopts vga=0x310
Error 17 cannot mount selected partition
Press any key to continue.

I then ran Suse Repair System and got the green Startup Options screen. From there, I was able to select Linux successfully, but when I selected Windows, I got thrown back into the black and white boot screen and selecting Windows only caused the screen to be redisplayed.
I have since restored from backup a second time and am at a point where I can boot into Windows from the black and white screen, but attempting Linux still brings the messages detailed above.
I am wondering at this point if I should simply re-install Linux, but am concerned about whether it is necessary to format the Linux partitions first and whether Windows will be affected in any way.
Thanks in advance,
s660117

ab
05-Nov-2012, 19:24
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> root (HD0,7) File system type unknown, partition type 0x82

0x82 is a swap partition; you should not be having Grub point there for
a main booting area, though it is something Grub may reference for
resuming (from hibernate, aka suspend-to-disk) since that's where the
system is stored, room permitting. My guess is your menu.lst/grub.conf
file is misconfigured to point to the wrong partition, perhaps because
of what you did when you "re-initialized grep".

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQmAR5AAoJEF+XTK08PnB5BSIP/A6nfuc0aF6BlSMYA9pbREkW
PWeIH3x+vCn65J2QwceTdqX87SyQ/IBbS8TjuD5p0jJ3Uu61DixJncY0gwccLAaj
fuTl6PVD19H+wAxwvw7Afup5+o0v6eHgcL4TmIxCvRqeT+XcHx LKvtWtnS2e7U/U
QYX7SgmeWOD2daoPClS3At/RnblanPZnyv4Olr0QHtbPPfVAlpsfVmWv43T5tVeU
J4RBTtMZu0ed096JyXS+fG/kAWokeMmXiBa8/C2CdeVcz4VZ8/ROPhmgZyFs6szC
mezxwLhdXjzTr02ZgIV0v3lXuKBABWFj7+giXglxRS0vFeiwK7 vjiw8lotSWLwWa
cbNRLaJdlSvB56MUknrLvp9WQ0+31XlSJJklEl4zC2iRvRUfON dUA1axkic8VgJn
/aVofrI0PgMZYx4jAziJHARrOa3are9v8qkwtmBF1wMcx3toBwn 7da2fh4eXvrMM
DAXKb0Hv8MAhssIl35GWoQIGqFTDMqnllA8sOK7px9J4G7+2sy PavRgZZ76Hnx1Y
Few6ofqCjrsqV6lDb5Zu2PEXDDm/t/00Hi2Nttkt3W0BRDPrc1q3GRHDDws34Ygj
mIqHzEoZvJ4F9VBfvAPxP+D0gmq9Agij/c7VNO+Y7Rq4hQvR9a7HgW+0o0IYkicC
S9xGdsTwTSKBRqwXUQKN
=+p1I
-----END PGP SIGNATURE-----

s660117
05-Nov-2012, 19:42
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> root (HD0,7) File system type unknown, partition type 0x82

0x82 is a swap partition; you should not be having Grub point there for
a main booting area, though it is something Grub may reference for
resuming (from hibernate, aka suspend-to-disk) since that's where the
system is stored, room permitting. My guess is your menu.lst/grub.conf
file is misconfigured to point to the wrong partition, perhaps because
of what you did when you "re-initialized grep".

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQmAR5AAoJEF+XTK08PnB5BSIP/A6nfuc0aF6BlSMYA9pbREkW
PWeIH3x+vCn65J2QwceTdqX87SyQ/IBbS8TjuD5p0jJ3Uu61DixJncY0gwccLAaj
fuTl6PVD19H+wAxwvw7Afup5+o0v6eHgcL4TmIxCvRqeT+XcHx LKvtWtnS2e7U/U
QYX7SgmeWOD2daoPClS3At/RnblanPZnyv4Olr0QHtbPPfVAlpsfVmWv43T5tVeU
J4RBTtMZu0ed096JyXS+fG/kAWokeMmXiBa8/C2CdeVcz4VZ8/ROPhmgZyFs6szC
mezxwLhdXjzTr02ZgIV0v3lXuKBABWFj7+giXglxRS0vFeiwK7 vjiw8lotSWLwWa
cbNRLaJdlSvB56MUknrLvp9WQ0+31XlSJJklEl4zC2iRvRUfON dUA1axkic8VgJn
/aVofrI0PgMZYx4jAziJHARrOa3are9v8qkwtmBF1wMcx3toBwn 7da2fh4eXvrMM
DAXKb0Hv8MAhssIl35GWoQIGqFTDMqnllA8sOK7px9J4G7+2sy PavRgZZ76Hnx1Y
Few6ofqCjrsqV6lDb5Zu2PEXDDm/t/00Hi2Nttkt3W0BRDPrc1q3GRHDDws34Ygj
mIqHzEoZvJ4F9VBfvAPxP+D0gmq9Agij/c7VNO+Y7Rq4hQvR9a7HgW+0o0IYkicC
S9xGdsTwTSKBRqwXUQKN
=+p1I
-----END PGP SIGNATURE-----


Ok... I redid grub and now get something very different. When I select Linux, I see a stream of messages which end with the following --

EXT3 FS on SDA8, internal journal.
EXT3-fs: mounted filesystem with ordered data mode
No init found. Try passing int=option to the kernal
unmount: /dev/pts: device is busy
(In some cases, useful info about processes that use the device is foud by lsof(8) or fuser(1))
unmount: /dev: the device is busy
Kernel panic - not synching attempted to kill init! that use

The boot then stops.
s660117