PDA

View Full Version : Frequent memory limit reached



ayel 86
10-Oct-2011, 07:06
Hi all. Need some help. Already install SLES in 6 server and found that
in the /var/log/message, the content of the log files:


Aug 30 05:00:22 pgw2 rcd[28133]: Running heartbeat at Tue Aug 30
05:00:22 2011
Aug 30 05:00:22 pgw2 rcd[28133]: Memory limit reached, restarting
Aug 30 05:00:22 pgw2 rcd[28133]: Shutting down daemon...
Aug 30 05:00:22 pgw2 rcd[28133]: Shutting down local server
Aug 30 05:00:22 pgw2 rcd[28133]: Shutting down remote server
Aug 30 05:00:22 pgw2 rcd[13273]: Red Carpet Daemon 2.4.9
Aug 30 05:00:22 pgw2 rcd[13273]: Copyright (C) 2000-2003 Ximian Inc.
Aug 30 05:00:22 pgw2 rcd[13273]: Start time: Tue Aug 30 05:00:22 2011
Aug 30 05:00:22 pgw2 rcd[13273]: Initializing RPC system
Aug 30 05:00:22 pgw2 rcd[13273]: Initializing modules
Aug 30 05:00:22 pgw2 rcd[13273]: [rcd.serverpoll] Starting server-poll
Aug 30 05:00:22 pgw2 rcd[13273]: Starting local server
Aug 30 05:00:22 pgw2 rcd[13273]: Starting remote server
Aug 30 05:00:23 pgw2 rcd[13273]: Loading system packages
Aug 30 05:00:23 pgw2 rcd[13273]: Done loading system packages
Aug 30 05:00:30 pgw2 rcd[13273]: id=1 COMPLETE 'Downloading
https://update.novell.com/data/serviceinfo.xml' time=7s (failed)
Aug 30 05:00:30 pgw2 rcd[13273]: Unable to download service info: IO
error - Soup error: Cannot resolve hostname (2)
Aug 30 05:00:30 pgw2 rcd[13273]: Unable to load service for default
host URL 'https://update.novell.com/data': Unable to download service
info: IO error - Soup error: Cannot resolve hostname (2)
Aug 30 05:00:30 pgw2 rcd[13273]: Can't find rcd 1.x subscription file
'/var/lib/redcarpet/subscriptions.xml'
Aug 30 05:00:30 pgw2 rcd[13273]: Starting heartbeat
Aug 30 05:22:43 pgw2 -- MARK --
Aug 30 05:42:43 pgw2 -- MARK --
Aug 30 05:59:01 pgw2 /USR/SBIN/CRON[5035]: (root) CMD ( rm -f
/var/spool/cron/lastrun/cron.hourly)
Aug 30 06:22:44 pgw2 -- MARK --
Aug 30 06:42:44 pgw2 -- MARK --

This report is keep repeating. Somehow, I believe this report is the
cause of the problem:
Aug 30 05:00:30 pgw2 rcd[13273]: id=1 COMPLETE 'Downloading
https://update.novell.com/data/serviceinfo.xml' time=7s (failed)
Aug 30 05:00:30 pgw2 rcd[13273]: Unable to download service info: IO
error - Soup error: Cannot resolve hostname (2)
Aug 30 05:00:30 pgw2 rcd[13273]: Unable to load service for default
host URL 'https://update.novell.com/data': Unable to download service
info: IO error - Soup error: Cannot resolve hostname (2)
Aug 30 05:00:30 pgw2 rcd[13273]: Can't find rcd 1.x subscription file
'/var/lib/redcarpet/subscriptions.xml'
Aug 30 05:00:30 pgw2 rcd[13273]: Starting heartbeat

Why this keep failed to download?

And one more thing, what is the red carpet deamon? What is it for?


--
ayel_86
------------------------------------------------------------------------
ayel_86's Profile: http://forums.novell.com/member.php?userid=117626
View this thread: http://forums.novell.com/showthread.php?t=446401

jmozdzen
10-Oct-2011, 12:46
Hi ayel_86,

> Why this keep failed to download?

If I were to believe thee output you've posted... it cannot resolve the
host name where it is supposed to download from.

Are you required to go via a proxy server to access https servers
outside your network, with the DNS set up so it wouldn't even resolve
their names?

Regards
Jens


--
from the times when today's "old school" was "new school" :eek:
------------------------------------------------------------------------
jmozdzen's Profile: http://forums.novell.com/member.php?userid=32246
View this thread: http://forums.novell.com/showthread.php?t=446401

ayel 86
11-Oct-2011, 09:26
Is there any way to disable this?


--
ayel_86
------------------------------------------------------------------------
ayel_86's Profile: http://forums.novell.com/member.php?userid=117626
View this thread: http://forums.novell.com/showthread.php?t=446401

jmozdzen
11-Oct-2011, 09:46
ayel_86;2145329 Wrote:
> Is there any way to disable this?

Disable what?


--
from the times when today's "old school" was "new school" :eek:
------------------------------------------------------------------------
jmozdzen's Profile: http://forums.novell.com/member.php?userid=32246
View this thread: http://forums.novell.com/showthread.php?t=446401

ayel 86
11-Oct-2011, 09:56
disable the red carpet daemon from restarting?


--
ayel_86
------------------------------------------------------------------------
ayel_86's Profile: http://forums.novell.com/member.php?userid=117626
View this thread: http://forums.novell.com/showthread.php?t=446401

jmozdzen
11-Oct-2011, 10:26
I've never done that (our SLES11 doesn't seem to even have rcd) - but
since it's part of the Novell update mechanism, you might want to check
how to disable that on your specific version of SLES. First try could be
to disable those in YaST and if that doesn't help, check what other
services rely on rcd in the rc scripts...


--
from the times when today's "old school" was "new school" :eek:
------------------------------------------------------------------------
jmozdzen's Profile: http://forums.novell.com/member.php?userid=32246
View this thread: http://forums.novell.com/showthread.php?t=446401

ayel 86
11-Oct-2011, 10:46
This is the version of suse linux that is being used: SUSE LINUX
Enterprise Server 9:x86. Just for information


--
ayel_86
------------------------------------------------------------------------
ayel_86's Profile: http://forums.novell.com/member.php?userid=117626
View this thread: http://forums.novell.com/showthread.php?t=446401

Simon Flood
24-Oct-2011, 14:38
On 11/10/2011 09:56, ayel 86 wrote:

> disable the red carpet daemon from restarting?

Try:

chkconfig rcd off

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------