PDA

View Full Version : Install FFMpeg on SLES 11



zabidin2
20-Nov-2012, 05:11
Hi,

I want to install ffmpeg on SLES 11. How to install ffmpeg using Yast? What i found in google totally different in Yast. There are no repo call packman. Please assist me. I'm not familiar with SLES.

Thanks.

zabidin2
20-Nov-2012, 10:54
Got error:

svr-prod01:~ # zypper in ffmpeg
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libgsm.so.1()(64bit) needed by libavcodec54-1.0-1.5.x86_64
Solution 1: do not ask to install a solvable providing ffmpeg
Solution 2: break libavcodec54 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2
Resolving dependencies...
Resolving package dependencies...

Problem: nothing provides libjack.so.0()(64bit) needed by libavdevice54-1.0-1.5.x86_64
Solution 1: do not ask to install a solvable providing ffmpeg
Solution 2: break libavdevice54 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2
Resolving dependencies...
Resolving package dependencies...

The following NEW packages are going to be installed:
ffmpeg libavcodec54 libavdevice54 libavfilter3 libavformat54 libavresample0 libavutil51 libmp3lame0 libopencore-amrnb0 libopencore-amrwb0
liborc-0_4-0 libpostproc52 librtmp0 libschroedinger-1_0-0 libswresample0 libswscale2 libva1 libvpx1 libx264-128 libxvidcore4

The following packages are not supported by their vendor:
ffmpeg libavcodec54 libavdevice54 libavfilter3 libavformat54 libavresample0 libavutil51 libmp3lame0 libopencore-amrnb0 libopencore-amrwb0
liborc-0_4-0 libpostproc52 librtmp0 libschroedinger-1_0-0 libswresample0 libswscale2 libva1 libvpx1 libx264-128 libxvidcore4

20 new packages to install.
Overall download size: 6.2 MiB. After the operation, additional 18.3 MiB will be used.
Continue? [y/n/?] (y): y
Retrieving package libopencore-amrnb0-0.1.3-4.16.x86_64 (1/20), 93.0 KiB (177.0 KiB unpacked)
Retrieving: libopencore-amrnb0-0.1.3-4.16.x86_64.rpm [done (28.2 KiB/s)]
Installing: libopencore-amrnb0-0.1.3-4.16 [error]
Installation of libopencore-amrnb0-0.1.3-4.16 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/packman/Essentials/x86_64/libopencore-amrnb0-0.1.3-4.16.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/packman/Essentials/x86_64/libopencore-amrnb0-0.1.3-4.16.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libmp3lame0-3.99.5-1002.1.x86_64 (2/20), 135.0 KiB (321.0 KiB unpacked)
Retrieving: libmp3lame0-3.99.5-1002.1.x86_64.rpm [done]
Installing: libmp3lame0-3.99.5-1002.1 [error]
Installation of libmp3lame0-3.99.5-1002.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libmp3lame0-3.99.5-1002.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libmp3lame0-3.99.5-1002.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libx264-128-0.128svn20120928-1.1.x86_64 (3/20), 325.0 KiB (860.0 KiB unpacked)
Retrieving: libx264-128-0.128svn20120928-1.1.x86_64.rpm [done]
Installing: libx264-128-0.128svn20120928-1.1 [error]
Installation of libx264-128-0.128svn20120928-1.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libx264-128-0.128svn20120928-1.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libx264-128-0.128svn20120928-1.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libvpx1-1.1.0-7.1.x86_64 (4/20), 228.0 KiB (635.0 KiB unpacked)
Retrieving: libvpx1-1.1.0-7.1.x86_64.rpm [done]
Installing: libvpx1-1.1.0-7.1 [error]
Installation of libvpx1-1.1.0-7.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libvpx1-1.1.0-7.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libvpx1-1.1.0-7.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libopencore-amrwb0-0.1.3-4.1.x86_64 (5/20), 50.0 KiB (89.0 KiB unpacked)
Retrieving: libopencore-amrwb0-0.1.3-4.1.x86_64.rpm [done]
Installing: libopencore-amrwb0-0.1.3-4.1 [error]
Installation of libopencore-amrwb0-0.1.3-4.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libopencore-amrwb0-0.1.3-4.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libopencore-amrwb0-0.1.3-4.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package librtmp0-2.4.git20121102-1.1.x86_64 (6/20), 63.0 KiB (134.0 KiB unpacked)
Retrieving: librtmp0-2.4.git20121102-1.1.x86_64.rpm [done]
Installing: librtmp0-2.4.git20121102-1.1 [error]
Installation of librtmp0-2.4.git20121102-1.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/librtmp0-2.4.git20121102-1.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/librtmp0-2.4.git20121102-1.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package liborc-0_4-0-0.4.16-40.1.x86_64 (7/20), 141.0 KiB (538.0 KiB unpacked)
Retrieving: liborc-0_4-0-0.4.16-40.1.x86_64.rpm [done]
Installing: liborc-0_4-0-0.4.16-40.1 [error]
Installation of liborc-0_4-0-0.4.16-40.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/liborc-0_4-0-0.4.16-40.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/liborc-0_4-0-0.4.16-40.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libxvidcore4-1.3.2-2.1.x86_64 (8/20), 197.0 KiB (676.0 KiB unpacked)
Retrieving: libxvidcore4-1.3.2-2.1.x86_64.rpm [done]
Installing: libxvidcore4-1.3.2-2.1 [error]
Installation of libxvidcore4-1.3.2-2.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libxvidcore4-1.3.2-2.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libxvidcore4-1.3.2-2.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavutil51-1.0-1.5.x86_64 (9/20), 92.0 KiB (163.0 KiB unpacked)
Retrieving: libavutil51-1.0-1.5.x86_64.rpm [done]
Installing: libavutil51-1.0-1.5 [error]
Installation of libavutil51-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavutil51-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavutil51-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libva1-1.0.15-19.1.x86_64 (10/20), 48.0 KiB (137.0 KiB unpacked)
Retrieving: libva1-1.0.15-19.1.x86_64.rpm [done]
Installing: libva1-1.0.15-19.1 [error]
Installation of libva1-1.0.15-19.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libva1-1.0.15-19.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libva1-1.0.15-19.1.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libschroedinger-1_0-0-1.0.11-19.2.x86_64 (11/20), 284.0 KiB (890.0 KiB unpacked)
Retrieving: libschroedinger-1_0-0-1.0.11-19.2.x86_64.rpm [done]
Installing: libschroedinger-1_0-0-1.0.11-19.2 [error]
Installation of libschroedinger-1_0-0-1.0.11-19.2 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libschroedinger-1_0-0-1.0.11-19.2.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libschroedinger-1_0-0-1.0.11-19.2.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libswresample0-1.0-1.5.x86_64 (12/20), 55.0 KiB (83.0 KiB unpacked)
Retrieving: libswresample0-1.0-1.5.x86_64.rpm [done]
Installing: libswresample0-1.0-1.5 [error]
Installation of libswresample0-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libswresample0-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libswresample0-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libswscale2-1.0-1.5.x86_64 (13/20), 111.0 KiB (327.0 KiB unpacked)
Retrieving: libswscale2-1.0-1.5.x86_64.rpm [done]
Installing: libswscale2-1.0-1.5 [error]
Installation of libswscale2-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libswscale2-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libswscale2-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavresample0-1.0-1.5.x86_64 (14/20), 56.0 KiB (107.0 KiB unpacked)
Retrieving: libavresample0-1.0-1.5.x86_64.rpm [done]
Installing: libavresample0-1.0-1.5 [error]
Installation of libavresample0-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavresample0-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavresample0-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libpostproc52-1.0-1.5.x86_64 (15/20), 77.0 KiB (199.0 KiB unpacked)
Retrieving: libpostproc52-1.0-1.5.x86_64.rpm [done]
Installing: libpostproc52-1.0-1.5 [error]
Installation of libpostproc52-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libpostproc52-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libpostproc52-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavcodec54-1.0-1.5.x86_64 (16/20), 2.6 MiB (7.5 MiB unpacked)
Retrieving: libavcodec54-1.0-1.5.x86_64.rpm [done]
Installing: libavcodec54-1.0-1.5 [error]
Installation of libavcodec54-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavcodec54-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavcodec54-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavformat54-1.0-1.5.x86_64 (17/20), 555.0 KiB (1.2 MiB unpacked)
Retrieving: libavformat54-1.0-1.5.x86_64.rpm [done]
Installing: libavformat54-1.0-1.5 [error]
Installation of libavformat54-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavformat54-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavformat54-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavfilter3-1.0-1.5.x86_64 (18/20), 288.0 KiB (747.0 KiB unpacked)
Retrieving: libavfilter3-1.0-1.5.x86_64.rpm [done]
Installing: libavfilter3-1.0-1.5 [error]
Installation of libavfilter3-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavfilter3-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavfilter3-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package libavdevice54-1.0-1.5.x86_64 (19/20), 53.0 KiB (74.0 KiB unpacked)
Retrieving: libavdevice54-1.0-1.5.x86_64.rpm [done]
Installing: libavdevice54-1.0-1.5 [error]
Installation of libavdevice54-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavdevice54-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libavdevice54-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i
Retrieving package ffmpeg-1.0-1.5.x86_64 (20/20), 754.0 KiB (3.5 MiB unpacked)
Retrieving: ffmpeg-1.0-1.5.x86_64.rpm [done]
Installing: ffmpeg-1.0-1.5 [error]
Installation of ffmpeg-1.0-1.5 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/ffmpeg-1.0-1.5.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/ffmpeg-1.0-1.5.x86_64.rpm cannot be installed


Abort, retry, ignore? [a/r/i] (a): i


How to fix it?

malcolmlewis
22-Nov-2012, 17:09
On Tue 20 Nov 2012 04:14:01 AM CST, zabidin2 wrote:


Hi,

I want to install ffmpeg on SLES 11. How to install ffmpeg using Yast?
What i found in google totally different in Yast. There are no repo call
packman. Please assist me. I'm not familiar with SLES.

Thanks.




Hi
So what version of SLES?


cat /etc/SuSE-release

Some files do exist on the Open Build Service (which packman links too
for building), so you may need to add some additional repositories.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 4 days 16:12, 3 users, load average: 0.23, 0.24, 0.19
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

zabidin2
26-Dec-2012, 07:54
Hi
So what version of SLES?


cat /etc/SuSE-release

Some files do exist on the Open Build Service (which packman links too
for building), so you may need to add some additional repositories.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 4 days 16:12, 3 users, load average: 0.23, 0.24, 0.19
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

cat /etc/SuSE-release:
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 1

Module limited on SuSE 11.

malcolmlewis
28-Dec-2012, 05:46
On Wed 26 Dec 2012 07:04:02 AM CST, zabidin2 wrote:


malcolmlewis;10261 Wrote:
> Hi
> So what version of SLES?
> >
Code:
--------------------
> >
> cat /etc/SuSE-release
>
--------------------
> >
> Some files do exist on the Open Build Service (which packman links
> too
> for building), so you may need to add some additional repositories.
>
> --
> Cheers Malcolm °¿° (Linux Counter #276890)
> openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
> up 4 days 16:12, 3 users, load average: 0.23, 0.24, 0.19
> CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

cat /etc/SuSE-release:
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 1

Module limited on SuSE 11.




Hi
I would look at using the versions from the VLC repository;
http://download.videolan.org/pub/videolan/vlc/SuSE/SLE11/

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:35, 3 users, load average: 0.11, 0.10, 0.08
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

zabidin5417
04-Jan-2013, 04:30
This is requirement from developer. They don't use others. I have put library in /usr/lib and /usr/lib64. But still same error. This is installation from source. Any idea why?

BEGIN /tmp/ffconf.ow5uLahA.c
1 #include <math.h>
2 float foo(float f) { return truncf(f); }
3 int main(void){ return (int) foo; }
END /tmp/ffconf.ow5uLahA.c
gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -std=c99 -fomit-frame-pointer -fPIC -pthread -c -o /tmp/ffconf.63EAF1jF.o /tmp/ffconf.ow5uLahA.c
/tmp/ffconf.ow5uLahA.c: In function 'main':
/tmp/ffconf.ow5uLahA.c:3: warning: cast from pointer to integer of different size
gcc -Wl,--as-needed -o /tmp/ffconf.K7vmoJu2 /tmp/ffconf.63EAF1jF.o -lm -pthread -lrt
check_lib lame/lame.h lame_set_VBR_quality -lmp3lame
check_header lame/lame.h
check_cpp
BEGIN /tmp/ffconf.ow5uLahA.c
1 #include <lame/lame.h>
2 int x;
END /tmp/ffconf.ow5uLahA.c
gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -std=c99 -fomit-frame-pointer -fPIC -pthread -E -o /tmp/ffconf.63EAF1jF.o /tmp/ffconf.ow5uLahA.c
check_func lame_set_VBR_quality -lmp3lame
check_ld cc -lmp3lame
check_cc
BEGIN /tmp/ffconf.ow5uLahA.c
1 extern int lame_set_VBR_quality();
2 int main(void){ lame_set_VBR_quality(); }
END /tmp/ffconf.ow5uLahA.c
gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -std=c99 -fomit-frame-pointer -fPIC -pthread -c -o /tmp/ffconf.63EAF1jF.o /tmp/ffconf.ow5uLahA.c
gcc -Wl,--as-needed -o /tmp/ffconf.K7vmoJu2 /tmp/ffconf.63EAF1jF.o -lmp3lame -lm -pthread -lrt
check_lib vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
check_header vorbis/vorbisenc.h
check_cpp
BEGIN /tmp/ffconf.ow5uLahA.c
1 #include <vorbis/vorbisenc.h>
2 int x;
END /tmp/ffconf.ow5uLahA.c
gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -std=c99 -fomit-frame-pointer -fPIC -pthread -E -o /tmp/ffconf.63EAF1jF.o /tmp/ffconf.ow5uLahA.c
/tmp/ffconf.ow5uLahA.c:1:30: error: vorbis/vorbisenc.h: No such file or directory
ERROR: libvorbis not found
svr-apps1:~/ffmpeg-1.0 # ll /usr/lib64 | grep libvorbis
-rw-r--r-- 1 root root 196958 Jan 4 10:46 libvorbis.a
lrwxrwxrwx 1 root root 18 Jan 4 10:59 libvorbis.so -> libvorbis.so.0.3.1
lrwxrwxrwx 1 root root 18 Jan 4 11:00 libvorbis.so.0 -> libvorbis.so.0.3.1
-rw-r--r-- 1 root root 173044 Jan 4 10:54 libvorbis.so.0.3.1
-rwxr-xr-x 1 root root 198280 Feb 21 2009 libvorbis.so.0.4.0
-rw-r--r-- 1 root root 1147922 Jan 4 10:46 libvorbisenc.a
lrwxrwxrwx 1 root root 21 Jan 4 10:58 libvorbisenc.so -> libvorbisenc.so.2.0.2
lrwxrwxrwx 1 root root 21 Jan 4 10:59 libvorbisenc.so.2 -> libvorbisenc.so.2.0.2
-rw-r--r-- 1 root root 1024268 Jan 4 10:54 libvorbisenc.so.2.0.2
-rwxr-xr-x 1 root root 1941760 Feb 21 2009 libvorbisenc.so.2.0.3
-rw-r--r-- 1 root root 24484 Jan 4 10:47 libvorbisfile.a
lrwxrwxrwx 1 root root 22 Jan 4 10:59 libvorbisfile.so -> libvorbisfile.so.3.1.1
lrwxrwxrwx 1 root root 22 Jan 4 10:35 libvorbisfile.so.3 -> libvorbisfile.so.3.1.1
-rw-r--r-- 1 root root 27720 Jan 4 10:55 libvorbisfile.so.3.1.1
-rwxr-xr-x 1 root root 31288 Feb 21 2009 libvorbisfile.so.3.2.0
svr-apps1:~/ffmpeg-1.0 #

malcolmlewis
07-Jan-2013, 13:27
On Fri 04 Jan 2013 03:34:02 AM CST, zabidin5417 wrote:


This is requirement from developer. They don't use others. I have put
library in /usr/lib and /usr/lib64. But still same error. This is
installation from source. Any idea why?



/tmp/ffconf.ow5uLahA.c
/tmp/ffconf.ow5uLahA.c:1:30: error: vorbis/vorbisenc.h: No such file or directory
ERROR: libvorbis not found



Hi
Well I think you might have to download a src rpm and look at how it's
built in the rpm spec file, this will provide a list of BuilRequires so
you need all these installed.

In this case the error advise the install of libvorbis-devel to provide
the header file. The file is in /usr/include maybe you need to add this
to the configure command.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 16:36, 3 users, load average: 0.01, 0.04, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

jmozdzen
08-Jan-2013, 19:20
This is requirement from developer. They don't use others. I have put library in /usr/lib and /usr/lib64. But still same error. This is installation from source. Any idea why?

being a developer myself, I can only say that if developers need a specific package to support a specific system, then they should provide that package. The admin's job is to install packages, not develop them. And compiling complex (in terms of dependencies) source packages is far above that.

Iirc ffmpeg is a rather complex piece of code and might require more development packages than just vorbis-devel. If your developers are so picky, they might have specific requirements for certain versions of those libs...

Just my 2 cents.

Regards,

Jens

zabidin5417
14-Jan-2013, 05:12
I get some error while trying to install other library:

Retrieving package libprojectM2-2.0.1-6.1.x86_64 (3/4), 276.0 KiB (928.0 KiB unpacked)
Retrieving: libprojectM2-2.0.1-6.1.x86_64.rpm [done (50.3 KiB/s)]
Installing: libprojectM2-2.0.1-6.1 [error]
Installation of libprojectM2-2.0.1-6.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libprojectM2-2.0.1-6.1.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman_SLE/Essentials/x86_64/libprojectM2-2.0.1-6.1.x86_64.rpm cannot be installed

jmozdzen
14-Jan-2013, 20:00
I get some error while trying to install other library:

What happens if you try to install the mentioned RPM manually? Looks like either the signature is bad or fails verification because of missing trust.

Regards,
Jens

zabidin5417
15-Jan-2013, 05:03
It's already install.

svr-apps1:~ # rpm -qa | grep libvorbis-devel
libvorbis-devel-1.3.3-40.3
svr-apps1:~ #

Any idea why error come out?

zabidin5417
15-Jan-2013, 05:18
How to retrieve this library using Yast?

libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libpthread.so.0()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libdl.so.2()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
libavutil.so.52()(64bit)
libSDL-1.2.so.0()(64bit)
libavutil.so.52(LIBAVUTIL_52)(64bit)
libavcodec.so.54()(64bit)
libavcodec.so.54(LIBAVCODEC_54)(64bit)
libavformat.so.54()(64bit)
libswscale.so.2()(64bit)
libavformat.so.54(LIBAVFORMAT_54)(64bit)
libswscale.so.2(LIBSWSCALE_2)(64bit)
libpostproc.so.52()(64bit)
libpostproc.so.52(LIBPOSTPROC_52)(64bit)
libavfilter.so.3()(64bit)
libavfilter.so.3(LIBAVFILTER_3)(64bit)
libswresample.so.0()(64bit)
libswresample.so.0(LIBSWRESAMPLE_0)(64bit)
libavdevice.so.54()(64bit)
libavdevice.so.54(LIBAVDEVICE_54)(64bit)
libavutil52 = 1.1
libavcodec54 = 1.1
libswresample0 = 1.1
libswscale2 = 1.1
libavformat54 = 1.1
libavresample1 = 1.1
libavdevice54 = 1.1
libpostproc52 = 1.1

jmozdzen
15-Jan-2013, 14:20
It's already install.


Any idea why error come out?

If it's already installed, could you then locate the include file, that was reported as missing? Does the "make" job of the build process look for it at that location?

Regards,
Jens

jmozdzen
15-Jan-2013, 14:24
Looking at that list, you're facing the typical problem with installing binary packages that were not created for your platform. It's not "this library", but quite a number of them, and some are critical to your system, so forcibly replacing the installed versions with the ones required by some extra package you're trying to install may break the whole system. You're moving on thin ice, be careful.

Regards,
Jens

zabidin5417
17-Jan-2013, 09:16
I just talk to technical support from suse. They said they not shipped video utility on suse. So they suggest to use 3rd party software. But if anything happen when installing 3rd party software, they not handle the issue.

It useless when you sold item but cannot do some other thing that can be done on other OS. Feel pity for them.

jmozdzen
17-Jan-2013, 13:02
Seems like you're frustrated, but I feel you shouldn't blame the OS... if you buy a nice Volvo Sxx, even including service pack, you wouldn't blame your car dealer for not being able to move that nice middle-age heavy-weight chest with it, because the chest is to big to go into the trunk?

SLES is a server OS, with a supported (and documented) set of functionality/packages. IMO it's not right to blame the support team if they limit their support to that set of packages. You *can* extend your SLES installation with any package you like, but you'll be on your own when you run into trouble. Yes, that's different to i.e. community distributions... if you chose one of those, you're on your own right from the start. And no, you wouldn't be able to install packages from any source there, either ;)

Just my 2 cents.

Regards,
Jens

jalmda
04-Feb-2013, 22:44
One useful source would be SLED. Desktop certainly has things Server does not, and I have solved similar problems with SLED packages (and you remain within the warm comforts of supported SUSE packaging....)

--J