PDA

View Full Version : hda: packet command error: in SLES 10SP4



tpro
21-Nov-2012, 07:24
Hi all

I am finding the below error message daily in "dmesg" output of SLES 10 SP4 server

hda: packet command error: status=0x51 { DriveReady SeekComplete Error }
hda: packet command error: error=0x50 { LastFailedSense=0x05 }
ide: failed opcode was: unknown


# hdparm /dev/hda

/dev/hda:
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 1024 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device


# smartctl -a /dev/hda
smartctl version 5.38 [x86_64-suse-linux-gnu] Copyright (C) 2002-7 Bruce Allen
Home page is smartmontools

=== START OF INFORMATION SECTION ===
Device Model: DW-224E-V
Serial Number: [No Information Found]
Firmware Version: C.CC
Device is: Not in smartctl database [for details use: -P showall]
ATA Version is: 7
ATA Standard is: Exact ATA specification draft version not indicated
Local Time is: Tue Nov 20 20:53:48 2012 EST
SMART support is: Unavailable - Packet Interface Devices [this device: CD/DVD] don't support ATA SMART
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


My Suse Linux version running on ProLiant DL585 G5 is
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 4

This error message started coming after updating kernel version from 2.6.16.60-0.97.1-smp to 2.6.16.60-0.99.1-smp.
Is this some serious error? Please give a solution to solve this error.

Thanks in advance...........

malcolmlewis
22-Nov-2012, 17:06
On Wed 21 Nov 2012 06:34:03 AM CST, tpro wrote:


Hi all

I am finding the below error message daily in "dmesg" output of SLES 10
SP4 server

HDA: PACKET COMMAND ERROR: STATUS=0X51 { DRIVEREADY SEEKCOMPLETE ERROR
}
HDA: PACKET COMMAND ERROR: ERROR=0X50 { LASTFAILEDSENSE=0X05 }
IDE: FAILED OPCODE WAS: UNKNOWN


# hdparm /dev/hda

/dev/hda:
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 1024 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device


# smartctl -a /dev/hda
smartctl version 5.38 [x86_64-suse-linux-gnu] Copyright (C) 2002-7
Bruce Allen
Home page is smartmontools

=== START OF INFORMATION SECTION ===
Device Model: DW-224E-V
Serial Number: [No Information Found]
Firmware Version: C.CC
Device is: Not in smartctl database [for details use: -P showall]
ATA Version is: 7
ATA Standard is: Exact ATA specification draft version not indicated
Local Time is: Tue Nov 20 20:53:48 2012 EST
SMART support is: Unavailable - Packet Interface Devices [this device:
CD/DVD] don't support ATA SMART
A mandatory SMART command failed: exiting. To continue, add one or more
'-T permissive' options.


MY SUSE LINUX VERSION RUNNING ON PROLIANT DL585 G5 IS
SUSE LINUX ENTERPRISE SERVER 10 (X86_64)
VERSION = 10
PATCHLEVEL = 4

THIS ERROR MESSAGE STARTED COMING AFTER UPDATING KERNEL VERSION FROM
2.6.16.60-0.97.1-SMP TO 2.6.16.60-0.99.1-SMP.
IS THIS SOME SERIOUS ERROR? PLEASE GIVE A SOLUTION TO SOLVE THIS ERROR.

Thanks in advance...........




Hi
That's coming from a DVD drive, is there a cd or dvd in the device?


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 4 days 16:25, 3 users, load average: 0.27, 0.22, 0.21
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

tpro
23-Nov-2012, 04:05
Hi
That's coming from a DVD drive, is there a cd or dvd in the device?


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 4 days 16:25, 3 users, load average: 0.27, 0.22, 0.21
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

At present there is no cd/DVD inside the drive. I checked the status after inserting a cd in it. After that also same message appears in dmesg.

malcolmlewis
25-Nov-2012, 03:04
On Fri 23 Nov 2012 03:14:01 AM CST, tpro wrote:


malcolmlewis;10260 Wrote:
> Hi
> That's coming from a DVD drive, is there a cd or dvd in the device?
>
At present there is no cd/DVD inside the drive. I checked the status
after inserting a cd in it. After that also same message appears in
dmesg.

Hi
A google on the error shows it may be a kernel bug, can you raise an SR
or bug on the error?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1 day 2:15, 5 users, load average: 0.08, 0.14, 0.44
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU