PDA

View Full Version : Multipath volumes fail to mount at boot time



aacampos
24-Nov-2012, 16:50
I just installed SLES 11 SP2, I got a multipath iscsi volume working fine but it fails to mount at boot time and enters in maintenance mode.

If I remove the volume from the /etc/fstab file the system boots without any problem, I can mount the volume without any problem after boot too.

KBOYLE
24-Nov-2012, 19:05
aacampos wrote:

>
> I just installed SLES 11 SP2, I got a multipath iscsi volume working
> fine but it fails to mount at boot time and enters in maintenance
> mode.
>
> If I remove the volume from the /etc/fstab file the system boots
> without any problem, I can mount the volume without any problem after
> boot too.

I don't have much experience with multipath and you haven't provided a
lot of details. There is a lot of information in the Knowledgebase.
Perhaps you could start there.

https://www.suse.com/support/kb/

Use "multipath" as the search argument.


Can you describe your configuration in more detail? I assume from what
you describe that you aren't trying to boot from the iscsi device?
Also, if you can refer to any technical documents you referenced in
trying to resolve your issue and the results you obtained, that will
also help with the diagnosis.

There are a number of individuals who help out in this forum who have
much more experience with multipath than I do. I'm sure they will jump
in with some suggestions over the next couple of days.

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are using the web interface,
show your appreciation and click on the star below...

aacampos
25-Nov-2012, 18:08
Ok, here we go:

I installed SLES 11 SP2 on a Lenovo RD240 Server, it has two hard drives SAS configured in R1. The installation is working fine, and I'm booting from the internal R1.

Then I attached the Lenovo RD240 to an EMC VNXe3150 through an iSCSI SAN using multipath, the SLES is working fine with the iSCSI initiator and with the multipath too, I can mount the volumes without any problem.

But..., When I restart the server the boot process stops and goes to maintenance mode, the messages on the screen says than the server can't mount the iSCSI multipath volumes configured in /etc/fstab

In maintenance mode all I do is remark the lines of the iscsi multipath volumes and the server comes up without any problem. Once it is up and running I can mount the iscsi multipath volumes. I suppose that the multipath is not running when the server tries to mount the volumes and it needs to be adjusted to make run the multipath prior to the mount process...

KBOYLE
25-Nov-2012, 21:01
aacampos wrote:

> Ok, here we go:

That should certainly help with the diagnosis.

Did you check the Knowledgebase? Were any of those documents helpful?

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are using the web interface,
show your appreciation and click on the star below...

Andy Konecny
27-Nov-2012, 20:34
In article <aacampos.5mli9c@no-mx.forums.suse.com>, Aacampos wrote:
> But..., When I restart the server the boot process stops and goes to
> maintenance mode, the messages on the screen says than the server can't
> mount the iSCSI multipath volumes configured in /etc/fstab
>
> In maintenance mode all I do is remark the lines of the iscsi multipath
> volumes and the server comes up without any problem. Once it is up and
> running I can mount the iscsi multipath volumes. I suppose that the
> multipath is not running when the server tries to mount the volumes and
> it needs to be adjusted to make run the multipath prior to the mount
> process...
>
Just a stab in the dark, but could you be hitting one of those circular
dependencies. I think you may either have to get the multipathing
software to load from the boot partition or have a script that runs after
the mail boot to mount those volumes.


Andy Konecny
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: http://forums.novell.com/member.php?userid=75037

enovaklbank
19-Dec-2012, 10:56
Have you enabled both iscsi and multipath support in the initrd?

mkinitrd -f iscsi -f multipath

also,

> TargetAddress=IP_Address
> [iSCSI] IP Address of the iSCSI Target
>
> InitiatorName=iqn. [iSCSI] Use iqn as the iSCIS initiatorname.

might help...