PDA

View Full Version : Support for gcc 4.7.2 on SLES 10 SP 4?



ejacobso
29-Nov-2012, 16:34
My software stack is planning on moving to gcc 4.7.2 to take advantage of new C++ features and performance improvements.
Unfortunately much of our internal infrastructure is running SLES 10 SP4 and a lot of the dependencies(gmp, mpc, mpfr) needed to compile gcc 4.7.2 appear to be incompatible(Novel doesn't provide binaries for 4.7.2).
Is there any plan to support newer versions of gcc on SLES 10 SP4?
I believe general support for SLES 10 SP4 ends July 2013, so I'm guessing the answer is no.
If that is the case is my only option to upgrade to SLES 11?
Thanks.

malcolmlewis
29-Nov-2012, 17:47
On Thu 29 Nov 2012 03:44:01 PM CST, ejacobso wrote:


My software stack is planning on moving to gcc 4.7.2 to take advantage
of new C++ features and performance improvements.
Unfortunately much of our internal infrastructure is running SLES 10
SP4 and a lot of the dependencies(gmp, mpc, mpfr) needed to compile gcc
4.7.2 appear to be incompatible(Novel doesn't provide binaries for
4.7.2).
Is there any plan to support newer versions of gcc on SLES 10 SP4?
I believe general support for SLES 10 SP4 ends July 2013, so I'm
guessing the answer is no.
If that is the case is my only option to upgrade to SLES 11?
Thanks.




Hi
I've asked my SUSE contacts for further info, bearing in mind that even
the current release of openSUSE (12.2) is still at 4.7.1.

IMHO I wouldn't hold my breath for SLE 10 getting there as you
indicated.

There is an unsupported version for SLE 11 here;
https://build.opensuse.org/package/show?project=devel%3Agcc&package=gcc47

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2 days 1:22, 4 users, load average: 0.02, 0.11, 0.15
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU