PDA

View Full Version : Re: SLES 11 and FreeNX (libpng.so.3 missing)



TronCarter
13-Sep-2011, 00:06
Is there a concise solution to getting FreeNX to work on SLES 11 SP1
64-bit? I just did a default install of SLES 11 SP1 64-bit and the
latest NX Client, Node, and Server from the NoMachine website, but I
can't get connected from a remote client. I see the talk about adding
libpng.so.3 but don't really know which package I need and how to
install it. I'm not even sure that is the problem and I can't get any
additional info from messages:


Code:
--------------------
Sep 13 05:02:00 lx04 sshd[4500]: Accepted publickey for nx from xxx.xxx.xxx.xxx port 57198 ssh2
Sep 13 05:02:01 lx04 sshd[4535]: Accepted keyboard-interactive/pam for cluster from 127.0.0.1 port 34092 ssh2
Sep 13 05:02:01 lx04 NXSERVER-3.5.0-8[4503]: User 'cluster' logged in from 'xxx.xxx.xxx.xxx'. 'NXLogin::set'
Sep 13 05:02:04 lx04 NXSERVER-3.5.0-8[4503]: Selected node host:localhost with port:22 'main::selectNode'
Sep 13 05:02:04 lx04 NXSERVER-3.5.0-8[4503]: Current selected node: localhost is in status: running 'main::selectNode'
Sep 13 05:02:04 lx04 NXSERVER-3.5.0-8[4503]: Selected session type: unix-gnome allowed in the profile of user: cluster 'NXShell::Static'
Sep 13 05:02:05 lx04 sshd[4541]: Accepted publickey for cluster from ::1 port 44570 ssh2
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 ERROR: NXNODE Ver. 3.5.0-6 (Error id e759694) [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 ERROR: create session: run commands [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 ERROR: execution of last command failed [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 last command: /usr/bin/xauth -v -f /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority source /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99
/scripts/authority [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 exit value: 1 [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 stdout: Using authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 Writing authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 stderr: /usr/bin/xauth: creating new authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 /usr/bin/xauth: /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/scripts/authority:3: bad display name "lx04:1004" in "add" command [e759694] Logger::log nxnode 2
963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 . [e759694] Logger::log nxnode 2963
Sep 13 05:02:07 lx04 NXNODE-3.5.0-6[4544]: ERROR: NX> 596 init: stdin arguments: user=cluster,userip=xxx.xxx.xxx.xxx,uniqueid=45FB3 610ED6775AF3E31474DC8CD6A99,display=1004,node_numb er=0,server_name=lx04,license=%28None%29,subscript
ionid=None,productid=LFE,reconnect=1,balance_host= xxx.xxx.xxx.xxx,encryption_mode=3,connection=local ,images=64M,cache=16M,client=winnt,media=0,backing store=1,encryption=1,strict=0,clipboard=both,shpix =1,rootless=0,composite=1,sess
ion=Chung%2520Cluster%2520lx03,shmem=1,type=unix%2 dgnome,virtualdesktop=1,screeninfo=1674x982x32%2br ender,keyboard=pc102%2fen_US,geometry=1674x982,lin k=lan Logger::log nxnode 2963
Sep 13 05:02:08 lx04 NXNODE-3.5.0-6[4544]: getting agent pid: cannot read pid file '/home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/pids/agent'. Exiting. main::get_agent_pid nxnode 9042
Sep 13 05:02:08 lx04 NXNODE-3.5.0-6[4544]: directory '/home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99' moved into '/home/cluster/.nx/F-C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99' for investigation Logger::log nxnode 90
99
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 ERROR: NXNODE Ver. 3.5.0-6 (Error id e759694)
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 ERROR: create session: run commands
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 ERROR: execution of last command failed
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 last command: /usr/bin/xauth -v -f /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority source /home/cluster/.nx/C-lx04-1004-45FB36
10ED6775AF3E31474DC8CD6A99/scripts/authority
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 exit value: 1
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 stdout: Using authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 Writing authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 stderr: /usr/bin/xauth: creating new authority file /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/authority
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 /usr/bin/xauth: /home/cluster/.nx/C-lx04-1004-45FB3610ED6775AF3E31474DC8CD6A99/scripts/authority:3: bad display name "lx04:1004" in "add" command
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NX> 596 init: stdin arguments: user=cluster,userip=xxx.xxx.xxx.xxx,uniqueid=45FB3 610ED6775AF3E31474DC8CD6A99,display=1004,node_numb er=0,server_name=lx04,li
cense=%28None%29,subscriptionid=None,productid=LFE ,reconnect=1,balance_host=xxx.xxx.xxx.xxx,encrypti on_mode=3,connection=local,images=64M,cache=16M,cl ient=winnt,media=0,backingstore=1,encryption=1,str ict=0,clipboard=both,shpix=1,r
ootless=0,composite=1,session=Chung%2520Cluster%25 20lx03,shmem=1,type=unix%2dgnome,virtualdesktop=1, screeninfo=1674x982x32%2brender,keyboard=pc102%2fe n_US,geometry=1674x982,link=lan
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NXNodeExec::exec('startsession', 'user=cluster&userip=xxx.xxx.xxx.xxx&uniqueid=45FB3610ED6775A...', 'localhost', 22) called at handlers/nxserver.pl line 35
82
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NXShell::handler_session_start('--link="lan" --backingstore="1" --encryption="1" --cache="16M" -...') called at NXShell.pm line 373
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NXShell::handle_command('startsession', '--link="lan" --backingstore="1" --encryption="1" --cache="16M" -...') called at NXShell.pm line 145
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) NXShell::run() called at nxserver.pl line 4497
Sep 13 05:02:08 lx04 NXSERVER-3.5.0-8[4503]: ERROR: (exception id 040105DE) eval {...} called at nxserver.pl line 4456

--------------------


And this is what I get on the client:


Code:
--------------------
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.5.0-8 - LFE
NX> 105 Hello NXCLIENT - Version 3.5.0
NX> 134 Accepted protocol: 3.5.0
NX> 105 Set shell_mode: shell
NX> 105 Set auth_mode: password
NX> 105 Login
NX> 101 User: cluster
NX> 102 Password: **********
NX> 103 Welcome to: lx04 user: cluster
NX> 105 Listsession --user="cluster" --status="suspended\054running" --geometry="1680x1050x32+render" --type="unix-kde"
NX> 127 Available sessions:

Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: cluster
NX> 105 Start session with: --link="lan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="johnson\04520cluster" --type="unix-kde" --geometry="1674x982" --client="winnt" --keyboard="pc102\057en_US" --screeninfo="1674x982x32+render"
NX> 595 ERROR: A fatal error occurred in NX Server.
NX> 595 ERROR: The exception id is: A4FE64C0. To get detailed information about
NX> 595 ERROR: the error search for the string A4FE64C0 in the system log
NX> 595 ERROR: file (usually '/var/log/messages').
NX> 500 ERROR: Last operation failed.
NX> 280 Exiting on signal: 15


--------------------

Can anyone help?


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183

malcolmlewis
13-Sep-2011, 00:47
On Mon, 12 Sep 2011 23:06:02 GMT
TronCarter <TronCarter@no-mx.forums.novell.com> wrote:

>
> Is there a concise solution to getting FreeNX to work on SLES 11 SP1
> 64-bit? I just did a default install of SLES 11 SP1 64-bit and the
> latest NX Client, Node, and Server from the NoMachine website, but I
> can't get connected from a remote client. I see the talk about adding
> libpng.so.3 but don't really know which package I need and how to
> install it. I'm not even sure that is the problem and I can't get any
> additional info from messages:
>
<snip>
> Can anyone help?
>
>
Hi
I only have a 32bit machine SLES 11 SP1 with NX, I'm assuming you can
ssh onto the machine as your user name?

It looks like it may not like the host name C-lx04? Can you set a
hostname without the - to test?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 2:43, 3 users, load average: 0.04, 0.14, 0.18
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

TronCarter
13-Sep-2011, 01:06
Yes, I can ssh to the machine with the same username just fine. The
hostname is just lx04:


Code:
--------------------
lx04:/usr # uname -a
Linux lx04 2.6.32.12-0.7-default #1 SMP 2010-05-20 11:14:20 +0200 x86_64 x86_64 x86_64 GNU/Linux

--------------------


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183

malcolmlewis
13-Sep-2011, 01:14
On Tue, 13 Sep 2011 00:06:02 GMT
TronCarter <TronCarter@no-mx.forums.novell.com> wrote:

>
> Yes, I can ssh to the machine with the same username just fine. The
> hostname is just lx04:
>
>
> Code:
> --------------------
> lx04:/usr # uname -a
> Linux lx04 2.6.32.12-0.7-default #1 SMP 2010-05-20 11:14:20 +0200
> x86_64 x86_64 x86_64 GNU/Linux
> --------------------
>
>
Hi
OK, if you ssh onto the machine and move the .nx directory
[/CODE]
mv .nx .old_nx
[/CODE]
Now, I'm guessing your using KDE as the desktop? If it's gnome then
check you have gnome set as the desktop in the NX client.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 3:12, 3 users, load average: 0.43, 0.25, 0.23
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

TronCarter
13-Sep-2011, 02:36
I have both KDE and Gnome installed on the machine, have logged into
both from the console, and have tried both settings in NX Client with
the same result. I have also tried the 32-bit NX packages, and
installing the 64-bit packages from rpm as well as tar. Same result.
In thinking about your previous post, I set the hostname during install
and unchecked "Change hostname via DHCP". Nothing is set in /etc/hosts
except for 127.0.0.1 localhost (maybe there should be a line for lx04,
it's IP, and the University LAN assigned long hostname). We have other
openSUSE boxes that are configured the same (I think) that work. None
the less, it does give me something to look at tomorrow to make sure.


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183

malcolmlewis
13-Sep-2011, 02:44
On Tue, 13 Sep 2011 01:36:10 GMT
TronCarter <TronCarter@no-mx.forums.novell.com> wrote:

>
> I have both KDE and Gnome installed on the machine, have logged into
> both from the console, and have tried both settings in NX Client with
> the same result. I have also tried the 32-bit NX packages, and
> installing the 64-bit packages from rpm as well as tar. Same
> result. In thinking about your previous post, I set the hostname
> during install and unchecked "Change hostname via DHCP". Nothing is
> set in /etc/hosts except for 127.0.0.1 localhost (maybe there should
> be a line for lx04, it's IP, and the University LAN assigned long
> hostname). We have other openSUSE boxes that are configured the same
> (I think) that work. None the less, it does give me something to
> look at tomorrow to make sure.
>
>
Hi
Yes, set the hostname in YaST and uncheck the box so it doesn't change.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 4:44, 5 users, load average: 0.21, 0.33, 0.39
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

NovAlf
13-Sep-2011, 07:16
Hi!
Have NX also on 32bit SLES 11 SP1, does work ok. Have You tried
TightVNC? Yes, it is not NX.
Alar.


--
NovAlf
------------------------------------------------------------------------
NovAlf's Profile: http://forums.novell.com/member.php?userid=19735
View this thread: http://forums.novell.com/showthread.php?t=384183

TronCarter
13-Sep-2011, 13:06
NovAlf;2136714 Wrote:
> Hi!
> Have NX also on 32bit SLES 11 SP1, does work ok. Have You tried
> TightVNC? Yes, it is not NX.
> Alar.

Unfortunately the end user of this machine has a very difficult time
adjusting to even a minor change in anything computer related. I am
actually amazed at how he spends 60+ hours per week writing, compiling,
and running code, and yet when I asked him what compiler he uses, he
didn't know. Could you imagine driving a truck for a living for 60+
hours per week and not knowing what kind of truck it is?

Not to mention that NX -should- work.


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183

NovAlf
13-Sep-2011, 13:36
Hi again!
If I recall correctly TightVNC not require any special installation
from server side (if there isn't set any special restrictions etc.,
default settings should do), You just need to have general remote access
to server and client soft installed, of course.
Alar.


--
NovAlf
------------------------------------------------------------------------
NovAlf's Profile: http://forums.novell.com/member.php?userid=19735
View this thread: http://forums.novell.com/showthread.php?t=384183

TronCarter
13-Sep-2011, 15:06
Hmmmm, now I'm puzzled. I did essentially the exact same installation
on different hardware and it works. The only differences in the
install were that I added KDE during setup and not after it was up and
running (maybe I missed a package or something??) and that I checked
"Add a hostname for loopback" or whatever it says when setting up the
hostname (Change via DHCP was unchecked). The network card is different
hardware, so maybe that is it. I think I also want to run a check on
the HD in the first computer.


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183

TronCarter
13-Sep-2011, 16:36
I did an fsck on reboot and nothing was found. I then did a reinstall
but created new partitions of different sizes, installed as I did the
second machine, and everything works. I'm not really sure what the
problem was, but I'm moving on now. Thank you for the help, everyone!


--
TronCarter
------------------------------------------------------------------------
TronCarter's Profile: http://forums.novell.com/member.php?userid=116613
View this thread: http://forums.novell.com/showthread.php?t=384183