PDA

View Full Version : Install ZAbbix Agent



snap972
26-Dec-2012, 17:23
Hello every one,

I would wish installed ZAbbix agent on SLES 11, how do you do that ?

Thank you for you help

Snap

malcolmlewis
26-Dec-2012, 17:30
On Wed 26 Dec 2012 04:24:02 PM CST, snap972 wrote:


Hello every one,

I would wish installed ZAbbix agent on SLES 11, how do you do that ?

Thank you for you help

Snap




Hi
You would need to compile the agent from the source tarball;
http://www.zabbix.com/documentation/2.0/manual/installation/install#zabbix_agent

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 14:06, 4 users, load average: 0.22, 0.12, 0.07
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
26-Dec-2012, 17:34
On Wed 26 Dec 2012 04:30:57 PM CST, malcolmlewis wrote:



On Wed 26 Dec 2012 04:24:02 PM CST, snap972 wrote:


Hello every one,

I would wish installed ZAbbix agent on SLES 11, how do you do that ?

Thank you for you help

Snap




Hi
You would need to compile the agent from the source tarball;
http://www.zabbix.com/documentation/2.0/manual/installation/install#zabbix_agent



Hi
There is an 2.0.3 agent built for SLE 11 on the Open Build Service also;
http://download.opensuse.org/repositories/server:/monitoring/SLE_11/

Download and install the rpm....

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 14:09, 4 users, load average: 0.14, 0.12, 0.08
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

snap972
27-Dec-2012, 15:39
Hi,

I excute the rpm zabbix agent but I have a error message
I need this libs
libcurl.so.4
liblber-2.4.so.2
libldap-2.4.so.2

Where I can found this ?

Thank you for youre help I debute in Linux

malcolmlewis
28-Dec-2012, 05:50
On Thu 27 Dec 2012 02:44:02 PM CST, snap972 wrote:


Hi,

I excute the rpm zabbix agent but I have a error message
I need this libs
libcurl.so.4
liblber-2.4.so.2
libldap-2.4.so.2

Where I can found this ?

Thank you for youre help I debute in Linux




Hi
What version of SLES? libcurl4 is part of SLES11 SP2 (as are the
others)?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:39, 3 users, load average: 0.01, 0.06, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

snap972
28-Dec-2012, 11:15
Hi
What version of SLES? libcurl4 is part of SLES11 SP2 (as are the
others)?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:39, 3 users, load average: 0.01, 0.06, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
Hi,
Thank for youre help


# cat /etc/issue

Welcome to SUSE Linux Enterprise Server 11 SP2 for VMware (x86_64) - Kernel \r (\l).

snap972
28-Dec-2012, 11:17
# rpm -ivh zabbix-agent-2.0.4-1.1.i586.rpm
warning: zabbix-agent-2.0.4-1.1.i586.rpm: Header V3 DSA signature: NOKEY, key ID ee454f98
error: Failed dependencies:
libcurl.so.4 is needed by zabbix-agent-2.0.4-1.1.i586
liblber-2.4.so.2 is needed by zabbix-agent-2.0.4-1.1.i586
libldap-2.4.so.2 is needed by zabbix-agent-2.0.4-1.1.i586

snap972
28-Dec-2012, 11:21
Hi
it's Ok For ZAbbix agent
I Downlaod the lib that I didn't had

after I execute the install of zabbix agent what do I you ?

malcolmlewis
28-Dec-2012, 15:25
On Fri 28 Dec 2012 10:24:02 AM CST, snap972 wrote:


Hi
it's Ok For ZAbbix agent
I Downlaod the lib that I didn't had

after I execute the install of zabbix agent what do I you ?




Hi
I have no idea, you need to read up on the documentation.... I would
imagine that the server contacts the client for the necessary
monitoring info.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 8:24, 3 users, load average: 0.07, 0.06, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU