PDA

View Full Version : How to configure Samba to allow access to windows 7



Flako000
27-Dec-2012, 22:09
Hello
I need to access resources samba (samba-3.0.24-2.28) for SLES 10 SP1 from my windows 7.
The samba server is defined as a workgroup, which makes windows 7 have problems with it .. (I think that)
The behavior of windows 7 is: Displays the shares, you can access them, but no files appear, and if I want to create a file does not allow indicating no recourse.

Got it working with the 'protocol = LANMAN2' in smb.conf, but this does not work with GNU / Linux (changing the parameters of linux is no option for now)
With options 'min protocol' and 'max protocol' I have not had success, seem not to work.
I've gone round and round, changing the Windows registry, but could not make it work without changing the smb, conf (at least not to stop the access linux).
Right now I'm a little confused, I have not clear if I can make samba use 'protocol = LANMAN2' and I was using before (to work with linux)
Shared resources should allow access without entering username and password.

No way to configure samba 3.0 to work with Windows 7 without using 'protocol = LANMAN2'?
or make samba use various authentication protocols?


Thanks for reading this far .. (sorry for using translate)
Below I leave my smb.conf



[global]
workgroup = SISTEMAS
server string = Servidor de aplitest
map to guest = Bad User
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
preferred master = No
local master = No
domain master = No
usershare allow guests = Yes
cups options = raw
include = /etc/samba/dhcp.conf
;Debug logging information
log level = 5
log file = /var/log/samba/samba.log.%m


[boss]
path = /path/shares/boss
force user = user1
force group = user2
read only = No
inherit acls = Yes
guest ok = Yes




if I add these lines runs windows 7,


#min protocol = CORE
#max protocol = LANMAN2
protocol = LANMAN2
client lanman auth = yes
client ntlmv2 auth = yes
lanman auth = yes
ntlm auth = yes

Automatic reply
03-Jan-2013, 14:30
Flako000,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

enovaklbank
04-Jan-2013, 15:28
Have you tried this already?

http://www.enterprisenetworkingplanet.com/windows/article.php/3849061/Use-Samba-With-Windows-7-Clients.htm

Flako000
11-Jan-2013, 14:01
Hello Enovaklbank, sorry for the delay .. (new Notifier does not work or I do not use it .. :confused: )
The Windows Registry modification I tried it but it did not work.
Concluded that it is the version of samba (in samba website w7 speak in newer verions)
This topic leave it in standby waiting to upgrade SUSE because in SUSE 11 I have no such problems.
I could not think what else to try ..

Thanks for answering.