PDA

View Full Version : OBS BuildRequire gcc46 for SLE_11_SP2 results "unresolvable"



esimone74
03-Jan-2013, 07:53
Hi there,

I would like to compile a package with gcc/c++ 4.6 for SLES11 SP2 within OBS.

I tried to insert the following rules in the relate spec file:


...
BuildRequires: gcc46 gcc46-c++
...
%build
...
export CC=gcc-4.6
export CXX=g++-4.6
...


But this will result in an "unresolvable" status with the hint:
"conflict for provider of libgcc43, (provider libgcc43 is conflicted by installed libgcc46), conflict for provider of libgomp1 >= 4.6.20110701-0.13.9 needed by gcc46, (provider libgomp46 is conflicted by installed libgomp43)"

As suggested in another thread I set the Prefer statement in the project configuration file:
# osc meta prjconf -e


Prefer: gcc46
Prefer: gcc46-c++
Prefer: libgcc46
Prefer: libgomp46


But nothing is changed. Same "unresolvable" error.

In a stand-alone installation of SLES11 SP2 all is working fine after the installation of the complete gcc64 stack and removing the libgcc43.

Is there a way to force the use of gcc 4.6 on SLE_11_SP2 builds?


Best regards,
Ettore Simone

malcolmlewis
03-Jan-2013, 14:47
On Thu 03 Jan 2013 06:54:01 AM CST, esimone74 wrote:


Hi there,

I would like to compile a package with gcc/c++ 4.6 for SLES11 SP2
within OBS.

I tried to insert the following rules in the relate spec file:

Code:
--------------------

...
BuildRequires: gcc46 gcc46-c++
...
%build
...
export CC=gcc-4.6
export CXX=g++-4.6
...

--------------------


But this will result in an "unresolvable" status with the hint:
"conflict for provider of libgcc43, (provider libgcc43 is conflicted by
installed libgcc46), conflict for provider of libgomp1 >=
4.6.20110701-0.13.9 needed by gcc46, (provider libgomp46 is conflicted
by installed libgomp43)"

As suggested in another thread I set the Prefer statement in the
project configuration file:
# osc meta prjconf -e

Code:
--------------------

Prefer: gcc46
Prefer: gcc46-c++
Prefer: libgcc46
Prefer: libgomp46

--------------------


But nothing is changed. Same "unresolvable" error.

In a stand-alone installation of SLES11 SP2 all is working fine after
the installation of the complete gcc64 stack and removing the libgcc43.

Is there a way to force the use of gcc 4.6 on SLE_11_SP2 builds?


Best regards,
Ettore Simone




Hi
You should only need to use BuildRequires: gcc gcc-c++ if the Prefer is
set, do you have a link to your project, or is it a private instance?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 9:22, 3 users, load average: 0.14, 0.05, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

esimone74
03-Jan-2013, 15:49
Hi Malcolm,

The project link is here: Boost C++ Libraries (https://build.opensuse.org/package/show?package=boost&project=home%3AH4T%3Adevel%3Alibraries%3Ac_c%2B%2B )

Unfortunately without the following lines inside the spec file it did not work:



...
BuildRequires: gcc46
#!BuildIgnore: libgomp43
#!BuildIgnore: libgcc43
...


The "Ignore" directive in the Project Conf is not effective.

Best regards,
Ettore Simone

aleeza
22-Dec-2014, 13:57
Hi,

I am not able to find openssl-devel, libopenssl-devel for sles 11 sp2/ sp3 32 bit operating system. And for sles11 64bit we can find libopenssl-devel and zlib-devel manually but couldn't find openssl-devel.

I tried finding these packages in OS image, but these were not there.
____________
sara

ab
22-Dec-2014, 15:06
This is a pretty old thread; if you checked DVD 2 (where most devel things
seem to hang out) and not just the main DVD 1 (primary installation media)
then you may want to start a new thread or perhaps checking the SUSE
download site (download.suse.com) where you can browse by product (SLES)
and then use a keyword search (openssl) to limit results.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...