PDA

View Full Version : SLES 11SP2 on Dell R320 server (custom installer)



tkindig
24-Jan-2013, 22:08
I have a Dell R320 and the stock SLES 11 SP2 installer does not see the RAID 1 virtual drive. If I use the Dell install disk it sees the HD put does not provide options for LVM/EVMS or choosing any file system but RieserFS. It will also delete the Dell diagnostic partition if I proceed.

I think I might be faced with building a custom SLES with the Dell supplied Linux driver at the Open SuSE Build Service. Has anyone here done this (or even read about it)? Any suggestions for a less complicated path to take?

enovaklbank
25-Jan-2013, 09:14
I'd simply look for a separate kmp package for your RAID device on the homepage of Dell, and specify it from an USB drive in the Grub menu when booting from the stock DVD. It this works, then you don't need a custom image, which could be a source of a lot of mystical problems.

According to Dell, you have one of these:
PERC S110 (SW RAID)
PERC H310
PERC H710

if it's the SW RAID one, the solution might be as simple as turning off the RAID capabilities, and to use the linux sw-raid solution.

tkindig
28-Jan-2013, 19:35
Thank you sincerely for pointing this out to me. I have the PERC H310. If I can figure out how to do this it will save me a lot of time and frustration. 'Off the the Dell Support website for a driver.

tkindig
28-Jan-2013, 23:38
What I am finding is no driver at Dell Support for SLES 11 SP2 (only, apparently, SLED 10 SP4). The Linux drivers specify Redhat, except for an upgrade (firmware) package for SLES and RH to be used when the OS is already installed. Having spent a hour doing tech support searched in Google, it would appear that there is little support for the issue I am facing. I figured how to get to the Load Driver Update in the Linuxrc screen in expert mode, following a failed install due to "No Hard Drive Found...". but cannot find a linux driver to load. Frustrating.

Open a support ticket with Dell? Open a support ticket with Novell? Switch off HW RAID and do RAID 1 in software?

I trust SW RAID, but paid for HW RAID 1. Normally these things are seamless for me.

malcolmlewis
29-Jan-2013, 01:08
On Mon 28 Jan 2013 10:44:01 PM CST, tkindig wrote:


What I am finding is no driver at Dell Support for SLES 11 SP2 (only,
apparently, SLED 10 SP4). The Linux drivers specify Redhat, except for
an upgrade (firmware) package for SLES and RH to be used when the OS is
already installed. Having spent a hour doing tech support searched in
Google, it would appear that there is little support for the issue I am
facing. I figured how to get to the Load Driver Update in the Linuxrc
screen in expert mode, following a failed install due to "No Hard Drive
Found...". but cannot find a linux driver to load. Frustrating.

Open a support ticket with Dell? Open a support ticket with Novell?
Switch off HW RAID and do RAID 1 in software?

I trust SW RAID, but paid for HW RAID 1. Normally these things are
seamless for me.




Hi
Do they provide a src rpm? If so can you provide a download link.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 2 days 6:14, 3 users, load average: 0.20, 0.07, 0.06
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile