PDA

View Full Version : SLES 11 SP1 : Unable to load ib_ipoib module



Jeremy_N
12-Feb-2013, 15:47
Hello everyone,

I'm trying to load ib_ipoib module on a SLES 11 SP1 server to configure IP over Infiniband but it didn't work :

raad-bak2:~ # modprobe ib_ipoib
FATAL: Error inserting ib_ipoib (/lib/modules/2.6.32.12-0.7-default/updates/drivers/infiniband/ulp/ipoib/ib_ipoib.ko): Unknown symbol in module, or unknown parameter (see dmesg)

That ib_ipoib.ko file is from the Mellanox software stack that I installed :

raad-bak2:~ # rpm -qf /lib/modules/2.6.32.12-0.7-default/updates/drivers/infiniband/ulp/ipoib/ib_ipoib.ko
mlnx-ofa_kernel-kmp-default-1.5.3_2.6.32.12_0.7-OFED.1.5.3.3.1.0.sles11sp1

When I look into dmesg :

Feb 12 17:37:10 raad-bak2 kernel: [603002.870941] ib_ipoib: Unknown symbol icmpv6_send

All the others ib modules are loaded :

raad-bak2:~ # service openibd status

HCA driver loaded


The following OFED modules are loaded:

mlx4_core
mlx4_ib
mlx4_en
ib_mthca
ib_uverbs
ib_umad
ib_sa
ib_cm
ib_mad
ib_core
iw_cxgb3
iw_nes

And I can see the IB card :

raad-bak2:~ # lspci | grep Mella
82:00.0 Network controller: Mellanox Technologies Device 1003

I tried to disable ipv6 and to find some ipv6 packages to install but I didn't find anything useful, I'm always stuck with the previous Unknown symbol messages.

Do you have any idea of what I can do to solve this issue ?

Thanks

jmozdzen
12-Feb-2013, 18:59
Jeremy,

> I tried to disable ipv6 and to find some ipv6 packages to install but I didn't find anything useful, I'm always stuck with the previous Unknown symbol messages.

seems like that module explicitly *requires* ipv6 support in the kernel, so you need to activate IPv6 (or rather: make sure the proper kernel modules are loaded).

The symbol itself is defined in the kernel module "ipv6", so you might try to start with a preceding "modprobe ipv6".

Regards,
Jens