PDA

View Full Version : full-virtualization create and install with autoyast



echejin
21-Mar-2013, 08:03
Hello.
I am using SLES 11 plus Xen to create VM. previously, I created para-virtualization VM with autoyast to install SLES 11 in guest os automatically. configuration file is as below.

builder="linux"
kernel="/opt/myBuild/boot/vmlinuz-xenpae.sles11.sp2"
ramdisk="/opt/myBuild/boot/inst-initrd.sles11.sp2"
extra=" install=hd:/dev/xvdb autoyast=device://xvdp/autoinst.xml "
disk=[ 'phy:/dev/sda3,xvda,w', 'file:/opt/nsmbuild/linux/3_19089-CNA10802_2_Ux_C.iso,xvdb,r', 'file:/opt/HA/tmp/autoyast.sles11_sp2,xvdp,r', 'file:/opt/HA/patch/fixorg,xvdc,r', ]

in extra field, autoinst.xml is specified and installation can be executed automatically.

now, our feature need to use full-virtualization VM. but I check that full-virtualization VM can not support autoyast in installation. configuration file as below
builder="hvm"
device_model="/usr/lib/xen/bin/qemu-dm"
kernel="/usr/lib/xen/boot/hvmloader"
boot="d"
disk=[ 'phy:/dev/sda3,hda,w', 'file:/var/nsmbuild/linux/3_19089-CNA10802_2_Ux_C.iso,hdb:cdrom,r', 'file:/opt/HA/tmp/autoyast.sles11_sp2,hdp,r']

if a add extra field like para one. VM can not be created.

please help to solve this problem. my requirement is let full-virtualization VM creation supports autoyast in installation.

Thanks.

Jing Chen

Automatic reply
28-Mar-2013, 13:30
echejin,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com