PDA

View Full Version : Client Status in SMT server configuration



pborate
01-May-2013, 21:16
Version: SLES 11 SP1

We have a SMT server installed on one of our suse server.
We have now connected some SMT clients to this server; still these multiple servers are not shown under SMT Management --> Client Status.

The only server shown under Client Status is the last contacted one to the SMT server. The list of all the servers contacted to SMT server is not shown.

Thanks,
Prashant..

pborate
01-May-2013, 21:53
Adding more to the above issue:--

The client status suppose to show all the regirsted client right? But is there is any reason it will not list all the registered clients?

And the one client which shows in the list status is "UnKnown". How to fix this issue?

jmozdzen
01-May-2013, 22:11
Hi Prashant,

are these by chance "cloned servers", created from a a single image? There's a server id in /etc/zmd/deviceid, are these different for all SMT clients?

Regards,
Jens

pborate
01-May-2013, 22:52
Hi jmozdzen,

Thank you for your quick reply...

We have created our servers as:
Created a base image --> then copied this and changed the IP address and hostnames..

And we don't have /etc/zmd/deviceid directory on our servers.

jmozdzen
02-May-2013, 00:03
Hi pborate,


Hi jmozdzen,

Thank you for your quick reply...

We have created our servers as:
Created a base image --> then copied this and changed the IP address and hostnames..

And we don't have /etc/zmd/deviceid directory on our servers.

sounds like the typical cloning problem... each SLES installation has it's unique id... but not when cloning.

With my installations, I see the GUID reported by "smt-client" both in /etc/zmd/deviceid and /etc/zypp/credentials.d/NCCcredentials. You need to erase these (if existent) and re-register the nodes. Until then, all clones are seen as one system by SMT and NCC.

Regards,
Jens