PDA

View Full Version : PHP 5.3 required on SLES 11 (SP2)



bkelsen
02-May-2013, 14:46
As the default is php 5.2 and from what is in other threads the process is a bit cumbersome (deinstall, reconfig apache etc) - I was wondering:

#1 anyone have a simple walkthru for moving from php 5.2 to php 5.3 preserving apache setup incl vhost settings ? (in a clean SLES11 SP2 install fx)

#2 is php 5.3 going to be default choice in the up and comming SLES 11 SP3 ? which would make it a lot easier :)

KR/Bjørn

summitflier
02-May-2013, 16:23
????

Php 53 is already in Sles 11 SP2.

i | apache2-mod_php53 | PHP5 Module for Apache 2.0 | package
i | php53 | PHP5 Core Files | package
| php53 | PHP5 Core Files | srcpackage
| php53-bcmath | PHP5 Core Files | package
i | php53-bz2 | PHP5 Core Files | package
| php53-calendar | PHP5 Core Files | package
i | php53-ctype | PHP5 Extension Module | package
| php53-curl | PHP5 Extension Module | package
| php53-dba | PHP5 Extension Module | package
i | php53-dom | PHP5 Extension Module | package
| php53-exif | PHP5 Extension Module | package
| php53-fastcgi | FastCGI PHP5 Module | package
| php53-fileinfo | PHP5 Extension Module | package
| php53-ftp | PHP5 Extension Module | package
i | php53-gd | PHP5 Extension Module | package
| php53-gettext | PHP5 Extension Module | package
| php53-gmp | PHP5 Extension Module | package
i | php53-iconv | PHP5 Extension Module | package
| php53-intl | PHP5 Extension Module | package
i | php53-json | PHP5 Extension Module | package
i | php53-ldap | PHP5 Extension Module | package
i | php53-mbstring | PHP5 Extension Module | package
i | php53-mcrypt | PHP5 Extension Module | package
i | php53-mysql | PHP5 Extension Module | package
| php53-odbc | PHP5 Extension Module | package
i | php53-openssl | PHP5 Extension Module | package
| php53-pcntl | PHP5 Extension Module | package
i | php53-pdo | PHP5 Extension Module | package
| php53-pear | PHP Extension and Application Repository | package
| php53-pgsql | PHP5 Extension Module | package
| php53-pspell | PHP5 pspell extension | package
| php53-shmop | PHP5 Extension Module | package
| php53-snmp | PHP5 Extension Module | package
i | php53-soap | PHP5 Extension Module | package
| php53-suhosin | PHP5 Extension Module | package
| php53-sysvmsg | PHP5 Extension Module | package
| php53-sysvsem | PHP5 Extension Module | package
| php53-sysvshm | PHP5 Extension Module | package
i | php53-tokenizer | PHP5 Extension Module | package
| php53-wddx | PHP5 Extension Module | package
i | php53-xmlreader | PHP5 Extension Module | package
| php53-xmlrpc | PHP5 Extension Module | package
i | php53-xmlwriter | PHP5 Extension Module | package
| php53-xsl | PHP5 Extension Module | package
| php53-zip | PHP5 Extension Module | package
i | php53-zlib | PHP5 Extension Module | package

The upgrade from 5.0 was painless. It didn't touch any apache files at all, except the /etc/apache2/conf.d/php.conf file.
Upgrading Apache is a slightly different story.

cjcox
03-May-2013, 04:48
On 05/02/2013 10:24 AM, summitflier wrote:
>
> ????
>
> Php 53 is already in Sles 11 SP2....snip....
>
> The upgrade from 5.0 was painless. It didn't touch any apache files at
> all, except the /etc/apache2/conf.d/php.conf file.
> Upgrading Apache is a slightly different story.

Well.. I too thought that this was "painless", but because of various
dependencies, eventually I realized that the whole prefixed php53 thing caused
me a lot of headaches. I eventually just determined that it is what it is and
that the most compatible thing is to use the "default"... which is clearly 5.2..
whether I like that or not.

Obviously there will be cases where the weird hack for 5.3 in SLES 11 works for
you... I'm just saying there are times when it's obvious that it is a hack and
you dream of a 5.3 repo with the normal package names... sigh..

Magic31
03-May-2013, 13:34
On 05/02/2013 10:24 AM, summitflier wrote:
>
> ????
>
> Php 53 is already in Sles 11 SP2....snip....
>
> The upgrade from 5.0 was painless. It didn't touch any apache files at
> all, except the /etc/apache2/conf.d/php.conf file.
> Upgrading Apache is a slightly different story.

Well.. I too thought that this was "painless", but because of various
dependencies, eventually I realized that the whole prefixed php53 thing caused
me a lot of headaches. I eventually just determined that it is what it is and
that the most compatible thing is to use the "default"... which is clearly 5.2..
whether I like that or not.

Obviously there will be cases where the weird hack for 5.3 in SLES 11 works for
you... I'm just saying there are times when it's obvious that it is a hack and
you dream of a 5.3 repo with the normal package names... sigh..

Depending on what you are looking to use this for, the (unsupported) 5.3 repository might be of help: https://build.opensuse.org/package/show?project=home%3Amkubecek%3Aprivate&package=php53

Also, SLES 11 SP3 should be out in a month or so... it might hold newer packages you are looking for.

-Willem

martolvan
13-May-2013, 23:50
I did upgrade to php 5.3 and have had quite an ordeal, there was one web app requiring php 5.3, but several others are all screwed up. Main problem is that I running SLES 11 SP2 32bit and for 32 bit and IMAP module so few Sugar CRM installations are rendered useless where customers can not use incoming mail. Few Joomla 1.5 webs died etc. but that is due to some bad extensions.
There seem to be few PHP modules missing and some settings non standard at least for 32bit version there are some of those modules seem to be available for 64 bit.
Will SP3 fix the PHP module issues or do I need to move all Sugar instances to different server or break my auto patching by recompiling PHP APACHE.

Regards Stefan