PDA

View Full Version : granting cups admin rights to non-root users



jgosney
18-Nov-2011, 23:06
OK, this is probably a dumb (newbie) question but I can't seem to find
the answer. In SLES 11, how do I give non-root users the rights to
add/modify printers and print jobs? I've added the users to a group and
specified that group in the cupsd.conf file and restarted but that
doesn't seem to be enough.

Thanks


--
jgosney
------------------------------------------------------------------------
jgosney's Profile: http://forums.novell.com/member.php?userid=1513
View this thread: http://forums.novell.com/showthread.php?t=448440

malcolmlewis
18-Nov-2011, 23:19
On Fri, 18 Nov 2011 22:06:02 GMT
jgosney <jgosney@no-mx.forums.novell.com> wrote:

>
> OK, this is probably a dumb (newbie) question but I can't seem to find
> the answer. In SLES 11, how do I give non-root users the rights to
> add/modify printers and print jobs? I've added the users to a group
> and specified that group in the cupsd.conf file and restarted but that
> doesn't seem to be enough.
>
> Thanks
>
>
Hi
This should clarify;
http://www.cups.org/articles.php?L237+T+Q

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 2 days 1:43, 5 users, load average: 0.27, 0.13, 0.14
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

jgosney
21-Nov-2011, 15:26
Hi Malcolm, I already tried those steps. I created a group, added the
users to the group, added that group to the SystemGroup entry in the
cupsd.conf file and restarted cups. Still doesn't work. What do you
think could be blocking this setting?


--
jgosney
------------------------------------------------------------------------
jgosney's Profile: http://forums.novell.com/member.php?userid=1513
View this thread: http://forums.novell.com/showthread.php?t=448440

malcolmlewis
21-Nov-2011, 16:19
On Mon, 21 Nov 2011 14:26:02 GMT
jgosney <jgosney@no-mx.forums.novell.com> wrote:

>
> Hi Malcolm, I already tried those steps. I created a group, added
> the users to the group, added that group to the SystemGroup entry in
> the cupsd.conf file and restarted cups. Still doesn't work. What do
> you think could be blocking this setting?
>
>
Hi
You could peruse the pam settings, anything in the logs (/var/log) to
indicate the errors?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 4 days 18:43, 4 users, load average: 0.04, 0.13, 0.17
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

altmas5
14-Nov-2012, 19:55
I modified my /etc/cups/cupsd.conf to disallow authentication for make changes va http://localhost:631/
# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
# AuthType Default
# Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
# Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

It worked for me on openSUSE 12.1

niconecky
16-Oct-2014, 17:43
I modified my /etc/cups/cupsd.conf to disallow authentication for make changes va http://localhost:631/
# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
# AuthType Default
# Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
# Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

It worked for me on openSUSE 12.1

Hi!

in OpenSuSE 13.1 I tried editing /etc/cups/cupsd.conf
I changed in the TAG <Policy default>
JobPrivateAccess default
for
JobPrivateAccess easy

and it worked!

saludos, Nicols.





and instead