PDA

View Full Version : How to make KDE the default desktop in YaST2



GEKen
25-Jun-2013, 09:56
Hi all,

I installed SLED 11 SP2 x86-64 with GNOME as the default desktop but have since switched to KDE.

In the screenshot below from YaST2 however, you can see that GNOME is still set as the default.

How can I make KDE the default?

https://dl.dropboxusercontent.com/u/59050776/snapshot1.png

Many thanks!

mikewillis
25-Jun-2013, 10:59
How can I make KDE the default?


To make KDE the default just for you:

Log out.
At the login screen enter your usercode
In the Session menu at the bottom of the screen, select KDE for your session.
Log in.

Next time you log in you'll get KDE by default. The preference is stored in ~/.dmrc


To make KDE the default for all users:

Either:

As root edit the file /etc/sysconfig/windowmanager in your editor of choice and change the value of DEFAULT_WM. In theory a list of valid values is given in the comments, but in practice they may not all be valid. For example it mentions kde as a possible value but that's not actually valid in SLED 11 SP2, it needs to be kde4. For a full list of valid values for your machine run


grep -h ^Name= /usr/share/xsessions/*desktop | cut -d = -f 2


Or:

Run YaST from the Computer menu.
Enter root password when prompted
Find the /etc/sysconfig Editor module
Go to Desktop > Window manager and edit the value for DEFAULT_WM.

Note that any preference in ~/.dmrc overrides whatever is specified by value of DEFAULT_WM. So if you ~/.dmrc says Gnome you'll still get Gnome next time you log in unless you explicitly chose KDE.

GEKen
25-Jun-2013, 11:06
Hi Mike,

Thanks for the fast response!

I have already done all of that and have KDE fully working.

However, I recently downloaded/installed the SDK and because GNOME is still set as the default under software management when viewed in the "patterns" view (as shown in the screenshot), it installed the GNOME SDK packages by default.

This is why I would like the software management screen to show KDE as the default under patterns->Desktops instead of GNOME (as in the screenshot) for the future.

Any idea how I can achieve that?

Many thanks!

mikewillis
25-Jun-2013, 12:15
However, I recently downloaded/installed the SDK and because GNOME is still set as the default under software management when viewed in the "patterns" view (as shown in the screenshot), it installed the GNOME SDK packages by default.

This is why I would like the software management screen to show KDE as the default under patterns->Desktops instead of GNOME (as in the screenshot) for the future.

Any idea how I can achieve that?


As far as I know you can't. The string 'GNOME (Default)' is specified in the pattern description on the DVD. With the SLED DVD iso mounted at /tmp/SLED:

me@mine:/tmp> gunzip -c SLED/suse/setup/descr/sled-11-89.113.1.x86_64.pat.gz | grep Default
=Sum: Default System
=Sum: GNOME (Default)
So YaST isn't putting the word 'Default' next to GNOME as a reflection of any system settings.

I suspect the reason you got the GNOME SDK packages installed by default is because it is specified somewhere on the SDK DVD, though I can't just work out where. As far as I recall you get the opportunity to chose what's installed from the SDK before it actually gets installed.

GEKen
25-Jun-2013, 12:49
Hi Mike,

ok - many thanks for the info.!