PDA

View Full Version : Unable to Mount NTFS partition



simbha
25-Jun-2013, 11:16
HI,
I'm currently using SUSE SLES 11SP2 x86_64 Patch 2. I'm having issues in mounting my NTFS drives.I can't seem to mount my NTFS drives on my SUSE, I can see them under /windows/ directory listed as C D E F G.. & O respectively (so my assumptions are they are mounted) BUT when I explore those drives I can't view its contents.. it's appears completely blank,I tried searching the internet but didn't get any solution to this.. is it a SUSE sles 11 sp2 limitation or am I not doing it correctly?
I don't know how to fix this so I can browse the files on my NTFS drives. here's what I have tried doing so far...

1)
I did edit the /etc/fstab file after I read some article over here: http://en.opensuse.org/SDB:NTFS
here's my fstab file




/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part8 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part2 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part1 /windows/C ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part1 /windows/D ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part1 /windows/E ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part5 /windows/F ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part6 /windows/G ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part7 /windows/H ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part5 /windows/I ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part6 /windows/J ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part7 /windows/K ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part8 /windows/L ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part5 /windows/M ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part6 /windows/N ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part5 /windows/O ntfs-3g defaults,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0



2)
I tried sharing the drives in windows 8 via the disk properties tab settings
3)
I tried to mnt it via running the following cmds:


fdisk -l
Gave output:


Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00039d5c

Device Boot Start End Blocks Id System
/dev/sda1 2048 209717247 104857600 7 HPFS/NTFS/exFAT
/dev/sda2 * 209717248 419432447 104857600 83 Linux
/dev/sda3 419432448 976773119 278670336 5 Extended
/dev/sda5 419434496 629149695 104857600 7 HPFS/NTFS/exFAT
/dev/sda6 629151744 838866943 104857600 7 HPFS/NTFS/exFAT
/dev/sda7 838868992 964698111 62914560 7 HPFS/NTFS/exFAT
/dev/sda8 964700160 976773119 6036480 82 Linux swap / Solaris

Disk /dev/sdd: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00006a32

Device Boot Start End Blocks Id System
/dev/sdd1 * 2048 62926604 31462278+ 7 HPFS/NTFS/exFAT
/dev/sdd2 62926785 160826714 48949965 f W95 Ext'd (LBA)
/dev/sdd5 62926848 160826714 48949933+ 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 360.1 GB, 360080695296 bytes
255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000607f

Device Boot Start End Blocks Id System
/dev/sdb1 16065 703277504 351630720 f W95 Ext'd (LBA)
/dev/sdb5 16128 175831424 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdb6 175831488 351646784 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdb7 351646848 527462144 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdb8 527462208 703277504 87907648+ 7 HPFS/NTFS/exFAT

Disk /dev/sdc: 360.1 GB, 360080695296 bytes
255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6ece6079

Device Boot Start End Blocks Id System
/dev/sdc1 * 63 175815359 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdc2 175815360 703261439 263723040 f W95 Ext'd (LBA)
/dev/sdc5 175815423 351630719 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdc6 351630783 527446079 87907648+ 7 HPFS/NTFS/exFAT
/dev/sdc7 527446143 703261439 87907648+ 7 HPFS/NTFS/exFAT



After getting the listed drives info I


mount -t ntfs-3g -o noatime /dev/sda8 /mnt/ntfs/

got error as;


mount: unknown filesystem type 'ntfs-3g'

then I did:


mount -t fuse -o noatime /dev/sdd5 /mnt/ntfs/

Got error as:


/bin/sh: /dev/sdd5: Permission denied



So I did CHOWN as


chown simon /windows

but still I was not able to mount the NTFS drives.. or view its contents..


additional info:
I have installed SUSE on 2nd primary partition & is set to active, (1st primary partition is windows 8 enterprise)
Ran cmds as SU

ab
25-Jun-2013, 11:44
On 06/25/2013 04:24 AM, simbha wrote:
>
> HI,
> I'm currently using SUSE SLES 11SP2 x86_64 Patch 2. I'm having issues
> in mounting my NTFS drives.I can't seem to mount my NTFS drives on my
> SUSE, I can see them under /windows/ directory listed as C D E F G.. & O
> respectively (so my assumptions are they are mounted) BUT when I explore
> those drives I can't view its contents.. it's appears completely blank,I
> tried searching the internet but didn't get any solution to this.. is it
> a SUSE sles 11 sp2 limitation or am I not doing it correctly?
> I don't know how to fix this so I can browse the files on my NTFS
> drives. here's what I have tried doing so far...

They do not sound like they are mounted.

> 1)
> I did edit the /etc/fstab file after I read some article over here:
> http://en.opensuse.org/SDB:NTFS
> here's my fstab file
>
>
> Code:
> --------------------
>
>
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part8 swap swap defaults 0 0
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part2 / ext3 acl,user_xattr 1 1
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part1 /windows/C ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part1 /windows/D ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part1 /windows/E ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part5 /windows/F ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part6 /windows/G ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part7 /windows/H ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part5 /windows/I ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part6 /windows/J ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part7 /windows/K ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part8 /windows/L ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part5 /windows/M ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part6 /windows/N ntfs-3g defaults,locale=en_US.UTF-8 0 0
> /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part5 /windows/O ntfs-3g defaults,locale=en_US.UTF-8 0 0
> proc /proc proc defaults 0 0
> sysfs /sys sysfs noauto 0 0
> debugfs /sys/kernel/debug debugfs noauto 0 0
> usbfs /proc/bus/usb usbfs noauto 0 0
> devpts /dev/pts devpts mode=0620,gid=5 0 0
> --------------------

This is a fine start, but it's not proving anything. To see if things are
mounted, just run 'mount' as any old user and post the output.

> 2)
> I tried sharing the drives in windows 8 via the disk properties tab
> settings
> 3)
> I tried to mnt it via running the following cmds:
>
>
> Code:
> --------------------
> fdisk -l
> --------------------
>
> Gave output:
>
>
> Code:
> --------------------
> Disk /dev/sda: 500.1 GB, 500107862016 bytes
> 255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
> Units = sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> Disk identifier: 0x00039d5c
>
> Device Boot Start End Blocks Id System
> /dev/sda1 2048 209717247 104857600 7 HPFS/NTFS/exFAT
> /dev/sda2 * 209717248 419432447 104857600 83 Linux
> /dev/sda3 419432448 976773119 278670336 5 Extended
> /dev/sda5 419434496 629149695 104857600 7 HPFS/NTFS/exFAT
> /dev/sda6 629151744 838866943 104857600 7 HPFS/NTFS/exFAT
> /dev/sda7 838868992 964698111 62914560 7 HPFS/NTFS/exFAT
> /dev/sda8 964700160 976773119 6036480 82 Linux swap / Solaris
>
> Disk /dev/sdd: 82.3 GB, 82348277760 bytes
> 255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
> Units = sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> Disk identifier: 0x00006a32
>
> Device Boot Start End Blocks Id System
> /dev/sdd1 * 2048 62926604 31462278+ 7 HPFS/NTFS/exFAT
> /dev/sdd2 62926785 160826714 48949965 f W95 Ext'd (LBA)
> /dev/sdd5 62926848 160826714 48949933+ 7 HPFS/NTFS/exFAT
>
> Disk /dev/sdb: 360.1 GB, 360080695296 bytes
> 255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
> Units = sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> Disk identifier: 0x0000607f
>
> Device Boot Start End Blocks Id System
> /dev/sdb1 16065 703277504 351630720 f W95 Ext'd (LBA)
> /dev/sdb5 16128 175831424 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdb6 175831488 351646784 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdb7 351646848 527462144 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdb8 527462208 703277504 87907648+ 7 HPFS/NTFS/exFAT
>
> Disk /dev/sdc: 360.1 GB, 360080695296 bytes
> 255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
> Units = sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> Disk identifier: 0x6ece6079
>
> Device Boot Start End Blocks Id System
> /dev/sdc1 * 63 175815359 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdc2 175815360 703261439 263723040 f W95 Ext'd (LBA)
> /dev/sdc5 175815423 351630719 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdc6 351630783 527446079 87907648+ 7 HPFS/NTFS/exFAT
> /dev/sdc7 527446143 703261439 87907648+ 7 HPFS/NTFS/exFAT
>
>
> --------------------
>
>
> After getting the listed drives info I
>
>
> Code:
> --------------------
> mount -t ntfs-3g -o noatime /dev/sda8 /mnt/ntfs/
> --------------------
>
>
> got error as;
>
>
> Code:
> --------------------
> mount: unknown filesystem type 'ntfs-3g'
> --------------------

This makes it sound like you do not have the ntfs-3g driver on your box,
which would be a little odd to me; I thought SLED shipped with that.
Hmmm.....

> then I did:
>
>
> Code:
> --------------------
> mount -t fuse -o noatime /dev/sdd5 /mnt/ntfs/
> --------------------

I doubt that the '-o' does anything... I do not think that 'atime' is
valid for the NTFS filesystem. Every time I've used FUSE for anything,
though, it's been via the GUI, not command line.

> Got error as:
>
>
> Code:
> --------------------
> /bin/sh: /dev/sdd5: Permission denied
>
>
> --------------------

Odd, since below you stated everything was done as 'SU', presumably
meaning the 'root' user.

> So I did CHOWN as
>
>
> Code:
> --------------------
> chown simon /windows
> --------------------

This does not affect mounting as much as being 'root' when running the
'mount' command.

> but still I was not able to mount the NTFS drives.. or view its
> contents..
>
>
> additional info:
> I have installed SUSE on 2nd primary partition & is set to active, (1st
> primary partition is windows 8 enterprise)
> Ran cmds as SU

Try posting the output of 'mount' as mentioned previously. Also see if
you have any ntfs-3g files on your box:

Code:
----------
rpm -qal | grep -i ntfs-3g
----------

Good luck.

ab
25-Jun-2013, 11:47
>> Code:
>> --------------------
>>
>>
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part8 swap swap defaults 0 0
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part2 / ext3 acl,user_xattr 1 1
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part1 /windows/C ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part1 /windows/D ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part1 /windows/E ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part5 /windows/F ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part6 /windows/G ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part7 /windows/H ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part5 /windows/I ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part6 /windows/J ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part7 /windows/K ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part8 /windows/L ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part5 /windows/M ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part6 /windows/N ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part5 /windows/O ntfs-3g defaults,locale=en_US.UTF-8 0 0
>> proc /proc proc defaults 0 0
>> sysfs /sys sysfs noauto 0 0
>> debugfs /sys/kernel/debug debugfs noauto 0 0
>> usbfs /proc/bus/usb usbfs noauto 0 0
>> devpts /dev/pts devpts mode=0620,gid=5 0 0
>> --------------------

One last thing: Have you tried mounting these manually or specifying them
using the older /dev/sda? syntax instead of by ID?

I just noticed from one of your attempted commands that you specified the
wrong partition when trying to mount a volume:

Code:
--------------------
mount -t ntfs-3g -o noatime /dev/sda8 /mnt/ntfs/
--------------------

'sda8' is a Linux partition per your fdisk output, so trying to mount it
as ntfs-3g is not going to work. Specify the correct partition (like
/dev/sdb8, or any of the other NTFS partitions) and see if that helps.

Good luck.

mikewillis
25-Jun-2013, 14:12
This makes it sound like you do not have the ntfs-3g driver on your box,
which would be a little odd to me; I thought SLED shipped with that.
Hmmm.....


SLED SP2 includes ntfs-3g 2011.4.12-0.7.8 and I believe it's installed by default. I currently have two SLED machines installed by booting the DVD, clicking next next next and nothing else has been done to them apart from installing updates and they both have ntfs-3g installed.

malcolmlewis
25-Jun-2013, 14:42
On Tue 25 Jun 2013 01:14:01 PM CDT, mikewillis wrote:


ab;14105 Wrote:
>
> This makes it sound like you do not have the ntfs-3g driver on your
> box,
> which would be a little odd to me; I thought SLED shipped with that.
> Hmmm.....
>

SLED SP2 includes ntfs-3g 2011.4.12-0.7.8 and I believe it's installed
by default. I currently have two SLED machines installed by booting the
DVD, clicking next next next and nothing else has been done to them
apart from installing updates and they both have ntfs-3g installed.




Hi
I always use the expert partitioning option during the install, in my
dual boot setups in creates the following entry for ntfs;

/dev/sda3 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 13:07, 3 users, load average: 0.01, 0.03, 0.05
CPU AMD Athlon(tm) II P360@2.30GHz | GPU Mobility Radeon HD 4200

susecmail
23-Aug-2013, 19:12
Not sure if this was brought up, but I noticed that you used



su


in order to mount the NTFS partition; however, I had to use the '-' in order to set the root environment correctly to do it in openSUSE.



su -


The '-' sets the root environment where as running 'su' without it keeps the user's environment variables, which may or may not allow certain root commands to operate. Not sure if you had that in there