PDA

View Full Version : SLES 11 : Add Japanese Language



pritianki
07-Dec-2011, 04:36
Hi there

I have been having problems with adding japanese language support on my
SLES11 SP 1

So far I have done the following:

1. Added Japanese as my secondary language using
yast2-->System-->Languages---> Primary Language set as English (US) and
Secondary language set as Japanese

2. Changed my Keyboard laytout using
yast2--->System--->Hardware---Keyboard Configuration--->Japanese

However, when I attempted to open files which I had scp'ed from windows
(ANSI and UTF-8 encoded files) with japanese characters in it, all I got
was garbled output:

Code:
--------------------

my-mnag0:/tmp # cat jptest-utf8.txt
良い朝my-mnag0:/tmp # cat jptest.txt
oD0gmy-mnag0:/tmp #
--------------------


I am not sure how to go on, I Googled and for most people it worked
after the keyboard layout was changed. Do I need to reboot for the
change to take affect?

So I am attempting to do these things:

1. System to be able to read Japanese language files
2. On the other hand, we have Nagios installed on this server and the
system's inability to read Japanese is causing the decade alerts emailed
to clients come out in garbled texts

Please help, I am kind of lost here.


--
pritianki
------------------------------------------------------------------------
pritianki's Profile: http://forums.novell.com/member.php?userid=120853
View this thread: http://forums.novell.com/showthread.php?t=449251

malcolmlewis
07-Dec-2011, 14:02
On Wed, 07 Dec 2011 03:36:02 GMT
pritianki <pritianki@no-mx.forums.novell.com> wrote:

>
> Hi there
>
> I have been having problems with adding japanese language support on
> my SLES11 SP 1
>
> So far I have done the following:
>
> 1. Added Japanese as my secondary language using
> yast2-->System-->Languages---> Primary Language set as English (US)
> and Secondary language set as Japanese
>
> 2. Changed my Keyboard laytout using
> yast2--->System--->Hardware---Keyboard Configuration--->Japanese
>
> However, when I attempted to open files which I had scp'ed from
> windows (ANSI and UTF-8 encoded files) with japanese characters in
> it, all I got was garbled output:
>
> Code:
> --------------------
>
> my-mnag0:/tmp # cat jptest-utf8.txt
> 良い朝my-mnag0:/tmp # cat jptest.txt
> ÿþo‚D0gmy-mnag0:/tmp #
> --------------------
>
>
> I am not sure how to go on, I Googled and for most people it worked
> after the keyboard layout was changed. Do I need to reboot for the
> change to take affect?
>
> So I am attempting to do these things:
>
> 1. System to be able to read Japanese language files
> 2. On the other hand, we have Nagios installed on this server and the
> system's inability to read Japanese is causing the decade alerts
> emailed to clients come out in garbled texts
>
> Please help, I am kind of lost here.
>
>
Hi
What is the env output for lang?


env |grep LANG
locale

You may need to set the LANG for the nagios environment.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 23:49, 3 users, load average: 0.00, 0.03, 0.07
GPU GeForce 8600 GTS Silent - Driver Version: 290.10

pritianki
08-Dec-2011, 04:06
hi malcolm

this is out locale and env output:


Code:
--------------------
my-mnag0:~ # env |grep LANG
LANG=POSIX
my-mnag0:~ # locale
LANG=POSIX
LC_CTYPE=en_US
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
my-mnag0:~ # date
Thu Dec 8 12:20:12 MYT 2011

--------------------


how do i change my nagios language environment?

do i have to add it in the .fonts folder? as of now its empty


Code:
--------------------
my-mnag0:/usr/local/nagios/.fonts # ll
total 0
my-mnag0:/usr/local/nagios/.fonts # date
Thu Dec 8 12:24:23 MYT 2011
--------------------


and i checked nagios' locale folder and currently the support i have is
in Deutsch and French:

Code:
--------------------

my-mnag0:/usr/local/nagios/share/locale # ll
total 0
drwxr-xr-x 3 root root 80 Dec 12 2009 de
drwxr-xr-x 3 root root 80 Dec 12 2009 fr
my-mnag0:/usr/local/nagios/share/locale # date
Thu Dec 8 12:25:07 MYT 2011
--------------------


--
pritianki
------------------------------------------------------------------------
pritianki's Profile: http://forums.novell.com/member.php?userid=120853
View this thread: http://forums.novell.com/showthread.php?t=449251

malcolmlewis
08-Dec-2011, 05:44
On Thu, 08 Dec 2011 03:06:02 GMT
pritianki <pritianki@no-mx.forums.novell.com> wrote:

>
> hi malcolm
>
> this is out locale and env output:
>
>
> Code:
> --------------------
> my-mnag0:~ # env |grep LANG
> LANG=POSIX
> my-mnag0:~ # locale
> LANG=POSIX
> LC_CTYPE=en_US
> LC_NUMERIC="POSIX"
> LC_TIME="POSIX"
> LC_COLLATE="POSIX"
> LC_MONETARY="POSIX"
> LC_MESSAGES="POSIX"
> LC_PAPER="POSIX"
> LC_NAME="POSIX"
> LC_ADDRESS="POSIX"
> LC_TELEPHONE="POSIX"
> LC_MEASUREMENT="POSIX"
> LC_IDENTIFICATION="POSIX"
> LC_ALL=
> my-mnag0:~ # date
> Thu Dec 8 12:20:12 MYT 2011
>
> --------------------
>
>
> how do i change my nagios language environment?
>
> do i have to add it in the .fonts folder? as of now its empty
>
>
> Code:
> --------------------
> my-mnag0:/usr/local/nagios/.fonts # ll
> total 0
> my-mnag0:/usr/local/nagios/.fonts # date
> Thu Dec 8 12:24:23 MYT 2011
> --------------------
>
>
> and i checked nagios' locale folder and currently the support i have
> is in Deutsch and French:
>
> Code:
> --------------------
>
> my-mnag0:/usr/local/nagios/share/locale # ll
> total 0
> drwxr-xr-x 3 root root 80 Dec 12 2009 de
> drwxr-xr-x 3 root root 80 Dec 12 2009 fr
> my-mnag0:/usr/local/nagios/share/locale # date
> Thu Dec 8 12:25:07 MYT 2011
> --------------------
>
>
Hi
I would look at using nagios from the SLE SDK, it probably has better
integration as well as updates?

You can download the SLE SDK iso image and add via yaST add on products
it will add the online and update repositories as well.

You need to change from posix to utf-8 for the characters to work I
would guess.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 1 day 15:29, 3 users, load average: 0.03, 0.03, 0.06
GPU GeForce 8600 GTS Silent - Driver Version: 290.10

pritianki
09-Dec-2011, 03:16
hi malcolm, this must sound silly...how do i change the POSIX to UTF-8?

=.=


--
pritianki
------------------------------------------------------------------------
pritianki's Profile: http://forums.novell.com/member.php?userid=120853
View this thread: http://forums.novell.com/showthread.php?t=449251