PDA

View Full Version : Server Hangs / Cant Login / SLES11Sp2



heikoschmiesz
10-Jul-2013, 12:28
Hello,

today in the morning a server hangs, running SLES11 Sp2 on VMWare 5.1 .
It was not posible to login via SSH but ping works.
Then i tryed to login via VMWare Console as root.
So i wrote "root" at the login prompt but i cant write the password... the session hangs after pressing "Enter / Return".

The logs dosent show anything. In the VI Client i saw the VMWare tools are not running.
So I reset the server and now everything works fine again

I was have that problem about 5 times this year on different Servers.

Somebody got the same problems??

Cheers Heiko

jmozdzen
10-Jul-2013, 16:17
Hi Heiko,

we've seen such problems from time to time, too - there's a multitude of possible causes, in our case it always boiled down to problems with the authentication back-end (that's why login and ssh are noticably affected, but other operations failed, too, like resolving user id to textual names, automated "su" calls etc.).

OTOH, it could be a (virtual) disk access problem, too.

Do you have a "self-sufficient setup" or does your server rely on other services, i.e. LDAP or NIS, SAN, ...? And are there any hints in syslog, prior to the reboot/hang?

Regards,
Jens

heikoschmiesz
11-Jul-2013, 10:06
Hi Jens,

tanks for youre replay...

in /var/log/messages i cant find anything

Jul 10 07:00:01 hostname /usr/sbin/cron[31137]: (root) CMD (/usr/lib64/sa/sa1 600 6)
Jul 10 08:22:31 hostname syslog-ng[1702]: syslog-ng starting up; version='2.0.9'

you can see here the last entry at 7 h and then the first after the reset/reboot
everything before 7h looks normal and like the days before

here the part from vmware log (the timestamp is wrong "2 h")

2013-07-10T05:07:24.165Z| vcpu-0| I120: VMMouse: Disabling VMMouse mode
2013-07-10T05:07:28.676Z| vcpu-0| I120: <<< Log Throttled >>>
2013-07-10T05:07:28.676Z| vcpu-0| I120: VMXNET3 user: Driver tried to update VRRS to 0x00000001 while device activated
2013-07-10T05:07:28.676Z| vcpu-0| I120: Ethernet0 MAC Address: 00:50:56:bc:4f:91
2013-07-10T05:07:29.117Z| vcpu-0| I120: VMXNET3 user: Ethernet0 Driver Info: version = 16850176 gosBits = 2 gosType = 1, gosVer = 0, gosMisc = 0
2013-07-10T05:07:36.869Z| vmx| I120: GuestRpcSendTimedOut: message to toolbox timed out.
2013-07-10T05:07:36.869Z| vmx| I120: GuestRpcSendTimedOut: message to toolbox-dnd timed out.
2013-07-10T05:07:42.199Z| vmx| I120: Tools: Tools heartbeat timeout.
2013-07-10T05:07:51.871Z| vmx| I120: GuestRpcSendTimedOut: message to toolbox timed out.
2013-07-10T05:07:51.871Z| vmx| I120: GuestRpc: app toolbox's second ping timeout; assuming app is down
2013-07-10T05:07:51.871Z| vmx| I120: GuestRpcSendTimedOut: message to toolbox-dnd timed out.
2013-07-10T05:07:51.871Z| vmx| I120: GuestRpc: app toolbox-dnd's second ping timeout; assuming app is down
2013-07-10T05:07:51.871Z| vmx| I120: GuestRpc: Reinitializing Channel 0(toolbox)
2013-07-10T05:07:51.871Z| vmx| I120: GuestMsg: Channel 0, Cannot unpost because the previous post is already completed
2013-07-10T05:07:51.872Z| vmx| I120: GuestRpc: Channel 0 reinitialized.
2013-07-10T05:07:51.872Z| vmx| I120: GuestRpc: Channel 0 reinitialized.
2013-07-10T05:07:51.872Z| vmx| I120: GuestRpc: Reinitializing Channel 2(toolbox-dnd)
2013-07-10T05:07:51.872Z| vmx| I120: GuestMsg: Channel 2, Cannot unpost because the previous post is already completed
2013-07-10T05:07:51.872Z| vmx| I120: GuestRpc: Channel 2 reinitialized.
2013-07-10T05:07:51.872Z| vmx| I120: GuestRpc: Channel 2 reinitialized.
2013-07-10T05:10:51.874Z| vmx| I120: GuestRpcSendTimedOut: message to toolbox timed out.
2013-07-10T05:10:51.874Z| vmx| I120: Vix: [981326 guestCommands.c:1926]: Error VIX_E_TOOLS_NOT_RUNNING in VMAutomationTranslateGuestRpcError(): VMware Tools are not running in the guest
2013-07-10T06:16:18.036Z| mks| I120: SOCKET 4 (150) Creating VNC remote connection.
2013-07-10T06:21:57.103Z| vmx| I120: Vix: [981326 vmxCommands.c:669]: VMAutomation_Reset. Trying hard reset
2013-07-10T06:21:57.103Z| vmx| W110:
2013-07-10T06:21:57.103Z| vmx| W110+
2013-07-10T06:21:57.103Z| vmx| W110+ VMXRequestReset

could it be something with VMXNET3 ??

Thats a Standalone Server (No LDAP etc. auth over local passwd)
OK There are running some jobs in the night, like backup and some jobs triggerd over beta48 from the host system.
Other Applications are Tomcat and some Java..

Cheers

Heiko

chintank
04-Sep-2014, 12:13
Hello

I have seen this same exact problem ..
Suse LINUX 11 Sp2 vmware guest , suddenly saw VM hanging and VMware tools not running ..
can anyone with similar experience please suggest on what can be done to avoid it?

Regards
Chintan