PDA

View Full Version : modprobe ocfs2 causing kernel panic with FIPS enabled



guangsu
11-Jul-2013, 18:20
Hi,

I ran into an issue with modprobe ocfs2 causing kernel panic. This only happened when FIPS is enabled via fips=1 in kernel boot parameter.

The error message is
Kernel panic - not syncing: Module verification failed with error -126 in FIPS mode
Pid: 3388, comm: modproble Tainted: G X 3.0.76-0.11-default #1
Call Trace:
[<ffffffff81004945] dump_trace+0x75/0x310
[<ffffffff81459893] dump_stack+0x69/0x6f
[<ffffffff8145992c] panic+0x93/0x201
[<ffffffff8109c815] copy_and_check+0x185/0x190
[<ffffffff8109fb43] load_module+0x63/0x730
[<ffffffff810a0272] sys_init_module+0x62/0x240
.
.

jmozdzen
12-Jul-2013, 12:15
Hi guangsu,

if no-one can offer an immediate solution, I'd like to take this to my SUSE contacts. Could you please tell us which SLES this is, if the latest patches are applied and if you're using HAE (as opposed to having installed OCFS2 from other sources)?

Regards,
Jens

guangsu
13-Jul-2013, 06:41
Hi Jens,

I am using SLES11 SP3 and SLES11 SP3 HAE. The OCFS2 is coming from the HAE.

Thanks

--Guang

jmozdzen
15-Jul-2013, 09:39
Hi Guang,

thanks for those details, I've taken this subject to my SUSE contacts. I'll update this thread as soon as I get any information back.

Regards,
Jens

jmozdzen
15-Jul-2013, 10:48
Hi Guang,

I've noticed that 3.0.80 is available in the update channels... have you tried that already?

Regards,
Jens

guangsu
16-Jul-2013, 18:58
Hi Jens,

Yeah, I just tested the latest 3.0.82 but the problem still exists.

Thanks

--Guang

jmozdzen
17-Jul-2013, 12:15
Hi Guang,

thanks for testing - I'll try to get some feedback from SUSE.

Regards,
Jens

jmozdzen
19-Jul-2013, 15:58
Hi Guang,

I have been asked if you could please provide the output of "modinfo ocfs2.ko" and let me know if the machine was booted in UEFI secure boot mode.

Regards,
Jens

guangsu
19-Jul-2013, 21:54
Hi Jens,

modinfo ocfs2
filename: /lib/modules/3.0.82-0.7-default/updates/ocfs2/ocfs2/ocfs2.ko
license: GPL
author: Oracle
version: 1.5.0
description: OCFS2 1.5.0
srcversion: 7F526186DC7D29AE6C68BAA
depends: jbd2,ocfs2_stackglue,quota_tree,ocfs2_nodemanager
supported: yes
vermagic: 3.0.82-0.7-default SMP mod_unload modversions

The server is not booted in UEFI secure boot mode. And it's a DELL PowerEdge R710

Thanks
--Guang