PDA

View Full Version : ugrading HANA Lifecycle Management LIBSSH2 error



muzavor
23-Jul-2013, 07:57
Hi all,

I am trying to upgrade the HANA Lifecycle Managment to SP06. hwne ever i run ./hdbinst i get the below error.

Installation failed
Cannot initialize custom event handler: Can't load '<Download_Folder>/instruntime/SSH2.so' for module Net::SSH2: libssh2.so.1: cannot open shared object file: No such file or directory at DynaLoader.pm line 190.
at sdbrun/Require.pl line 62
BEGIN failed--compilation aborted at HLM/Installer/OS/SSH2Connection.pm line 9.
BEGIN failed--compilation aborted at HLM/Installer/OS/SSH2RemoteExecutor.pm line 9.
BEGIN failed--compilation aborted at HLM/Installer/BaseExecutionPlanManager.pm line 32.
...propagated at base.pm line 94.
BEGIN failed--compilation aborted at HLM/Installer/ExecutionPlanManager.pm line 35.
BEGIN failed--compilation aborted at HLM/Installer/InstallationEventHandler.pm line 16."


Kindly advice on what needs to be done as this is a very critical for our current scenario.

We are currently running on SUSE ENTERPRISE LINUX SERVER 11.1

Thanks regards

Shaik Arshad

ab
23-Jul-2013, 12:39
Disclaimer: I do not have this exact setup for testing.

On my SLES 11 SP2 x86_64 system the /usr/lib64/libssh2.so.1 symlink points
to /usr/lib64/libssh2.so.1.0.0 and comes from the
libssh2-1-0.19.0+20080814-2.16.1 package. By its install date this RPM
came with the base SLES distribution and was not added manually by me.

Based on its path this file, if present in your system, should be
automatically found by anything needing it, assuming that thing needing it
can use x86_64 libraries. On my system the default 'perl' executable is
also x86_64, so that would work if needed as long as the same is true on
your box and the installer is not, somehow, finding an alternate perl
executable (maybe shipped with the 'hdbinst' software).

Good luck.

sapcoe_basis
24-Jul-2013, 11:16
Thanks for the update.
I cant seem to find any related libssh2.so.1
This should have been part of the OS and no a separate library that comes with SAP. I was hoping to find out of i need to deploy a package. it might not be feasible for me to get the system to SP2 as we are not sure about the functional impact on the SAP application.

Do let me know if have any ray of light for me :)

thanks

Regards

ab
24-Jul-2013, 12:34
Search for the package I mentioned as shown below:

Code:
----------
sudo zypper se libssh2
----------

If something shows up, install that something:

Code:
----------
sudo zypper in libssh2-whatever-it-was-called
----------

Good luck.

sapcoe_basis
25-Jul-2013, 05:15
Hi Ab,

Thanks for the information . I got through with the deployment.
Now back to getting the system ready for the client.

Thanks again.

Regards

Arshad