PDA

View Full Version : Wlan Access Point (Master mode) with tp-link wn350gd (ath5k)



pintilie_luci
31-Jul-2013, 13:16
Hi there! I was just wondering how can I set up a Wlan based access point using the Suse's built in Master mode. I want to mention that, I have used Windows 2003 to do this in Ad-hoc mode, and it worked fine, but I need to "extend" the compatibility of my virtual access point.
I also want to mention that I have installed and configured DNS, DHCP, and the network interfaces (even DSL0)!
My O.S. is Suse Linux Enterprise Server 11 i586 with 2.6 kernel, and Wlan card tp-link wn350gd.

My configuration is something like this: eth0 as the (external zone in firewall, and WAN input, using 192.168.0.1 static ip for initialization) (I use a PPPoE connection to access the Internet), dsl0 as my PPPoE provider connection (with dynamic ip, also external zone), eth1 as the ethernet output to the subnet clients (internal zone in firewall, but it's part of a network bridge so it has 0.0.0.0), wlan0 as the wireless adapter, configured in Master Mode, with WEP shared key, (the same as eth1, this is also internal zone in firewall, ip 0.0.0.0 component of the bridge), and finally the Network Bridge between eth1 and wlan0, (this has a statically asigned ip like 76.45.136.1, this ip serves as DNS, Default Gateway, host address, etc...)

Problem: No Wireless connection on any laptop or device! On the other side of the situation the cable Internet eth0 works fine on the subnet workstations. I have also tried to set up my Wlan as Ad-hoc, but... nothing... At boot time something like this appears: Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0; (The Wlan card IS marked as COMPATIBLE with suse linux ) Invalid argument. an it says that the interface dosen't support IP. Somethimes it cannot de even bridged, an the same error persist for the Ad-hoc mode. I have read about Hostapd but it's hard to understand Linux language whe you sistematically use Windows ;) It's evident why I use Suse graphically ;)

Please help, Thanks in Advance!

jmozdzen
31-Jul-2013, 17:47
Hi pintilie_luci,


Hi there! I was just wondering how can I set up a Wlan based access point using the Suse's built in Master mode. I want to mention that, I have used Windows 2003 to do this in Ad-hoc mode, and it worked fine, but I need to "extend" the compatibility of my virtual access point.
I also want to mention that I have installed and configured DNS, DHCP, and the network interfaces (even DSL0)!
My O.S. is Suse Linux Enterprise Server 11 i586 with 2.6 kernel, and Wlan card tp-link wn350gd.

My configuration is something like this: eth0 as the (external zone in firewall, and WAN input, using 192.168.0.1 static ip for initialization) (I use a PPPoE connection to access the Internet), dsl0 as my PPPoE provider connection (with dynamic ip, also external zone), eth1 as the ethernet output to the subnet clients (internal zone in firewall, but it's part of a network bridge so it has 0.0.0.0), wlan0 as the wireless adapter, configured in Master Mode, with WEP shared key, (the same as eth1, this is also internal zone in firewall, ip 0.0.0.0 component of the bridge), and finally the Network Bridge between eth1 and wlan0, (this has a statically asigned ip like 76.45.136.1, this ip serves as DNS, Default Gateway, host address, etc...)

Problem: No Wireless connection on any laptop or device! On the other side of the situation the cable Internet eth0 works fine on the subnet workstations. I have also tried to set up my Wlan as Ad-hoc, but... nothing... At boot time something like this appears: Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0; (The Wlan card IS marked as COMPATIBLE with suse linux ) Invalid argument. an it says that the interface dosen't support IP. Somethimes it cannot de even bridged, an the same error persist for the Ad-hoc mode. I have read about Hostapd but it's hard to understand Linux language whe you sistematically use Windows ;) It's evident why I use Suse graphically ;)

Please help, Thanks in Advance!

a quick search across the Internet revealed that the ath5k driver included in the kernel did not support switching the card to master mode before kernel 2.6.31, which would perfectly fit your description. SLES11 (no service pack) ran 2.6.27, while SP1 brought that to 2.6.32. You mention no service pack and only "with 2.6 kernel", so I cannot tell for sure.

Are you fixed on SLES11("SP0") or might you consider updating?

While loosing system support this way, you might switch to compat-wireless drivers, otoh this might be more than you'd like to bargain for, given your statement about your background. Especially if upgrading to more recent code (SLES11SP3 is the current level) is an option.

BTW, you are aware that WEP does not provide strong security? Today, WPA2 is the preferred way to encrypt your WLAN traffic.

Regards,
Jens

pintilie_luci
01-Aug-2013, 09:46
First, thank you for answer ;) !
I have to mention that my O.S. Is currently Suse Linux Enterprise Server 11 SP1! Some days ago, I tried to set up on Service Pack 2 with kernel 3 but, the problem is the same, and I can't figure out what is wrong, because this Wlan card works on any linux distribution! and windows the same. I have also seen that the windows driver from this card uses something like "Wireless Intermediate Driver" protocol for all the network cards! I think that is a kind of supplicant or something like, my question is, that "I need to use such supplicant on Suse?". Anyway, I want to use this setup (no router, because of technical reasons, I need to manage the network both wired and wireless at the same time for some devices that don't support routers! an WPA authentication.) and... I have no IDEA how to set up Hostapd, that's why I want to use SUSE's native functions!

pintilie_luci
01-Aug-2013, 09:52
And "for my own culture" :D what causes this error? :Error for wireless request "Set Mode" (8B06): SET failed on device wlan0; No IP supported for this device!
How can i fix it?

jmozdzen
01-Aug-2013, 10:26
Hi pintilie_luci,

And "for my own culture" :D what causes this error? :Error for wireless request "Set Mode" (8B06): SET failed on device wlan0; No IP supported for this device!
How can i fix it?

the error itself describes that an API was invoked to set/change the card mode (probably to "master"), but failed. There are more than one possible causes:
- the driver does not support setting the requested mode
- some other subsystem is already controlling the device (like running NetworkManager)
- the wrong device is used to set the mode
- card failure, bad programming, ... ...


this Wlan card works on any linux distribution! and windows the same.
"works" as in "is usable in master mode", or as in "I can connect to any access point"?

As you're running SP1 and as such should have a driver that is capable of setting the master mode, it might well be possible that you're using NetworkManager to control your server's network interfaces.

To further nail this down, please let us know the output of "iwconfig" and the exact details on how you set up your AP. Do you by chance have two devices for the card, wlan0 and ath0? IIRC, setting the master mode only works on the ath0 device.


I have no IDEA how to set up Hostapd, that's why I want to use SUSE's native functions!

I've seen no mention of using a SLES server as an access point so far, so there may indeed be no "SUSE's native functions" for this. To me, hostapd seems the preferred choice of setting up such functionality, but I couldn't find hostapd packages distributed with SLES11(SP2), which might be another indicator that this is not officially supported. And I've found no SLES11 RPMs on software.opensuse.org either, so the initial efforts to get this started seem rather high.

I'll double-check with my SUSE contacts on their position on this, but it'll may take some days to get a response back, it's holiday season...

With regards,
Jens

pintilie_luci
02-Aug-2013, 18:57
It may be difficult, in any situation to get the sollution as anytime when I have asked someone on the forum, because of the human factor ;)
First: Sorry for any inconvenience, of asking so many times this question! (I really need help over this problem!)
Second: I don't use Netowrk Manager (haven't even enabled it) just the "Traditional Method of ifUP"! I use a network bridge as my virtual default gateway, (or as the DHCP output card); This bridge "distributes the packets" to the eth0 and WLAN0 (there's no ath0 in my setup). The acces to the Internet is provided by PPPoE or DSL.
The iwconfig states that there are some Power managements issues and that it cannot set the card in Master mode, and cannot assign IP and that it can't bridge the device with eth0. About the driver.... How can I install a "Master mode capable" drivere on Linux (particullary SUSE)?
Third: What that means: "...master mode only works on the ath0 device." (shall i change the name of the wlan card wlano --> ath0 ? (I have only one card installed)!

Finally: Sorry again ;) for any inconvenience! I did almost everything to set up this card in both master mode and ad-hoc mode and still the same error occurs!

jmozdzen
04-Aug-2013, 17:26
Hi pintilie_luci,

seems that my Friday response didn't make it to the forum - in case it did, my apologies for this double posting.

It may be difficult, in any situation to get the sollution as anytime when I have asked someone on the forum, because of the human factor ;)
First: Sorry for any inconvenience, of asking so many times this question! (I really need help over this problem!)
Second: I don't use Netowrk Manager (haven't even enabled it) just the "Traditional Method of ifUP"! I use a network bridge as my virtual default gateway, (or as the DHCP output card); This bridge "distributes the packets" to the eth0 and WLAN0 (there's no ath0 in my setup). The acces to the Internet is provided by PPPoE or DSL.
"NetworkManager not enabled" is one information I was looking for - "there's no ath0" *might* be the other: Is there actually no ath0 device available, or are you just not using it?


The iwconfig states that there are some Power managements issues and that it cannot set the card in Master mode, and cannot assign IP and that it can't bridge the device with eth0.
Would you mind sharing the exact output of the commands you were using, starting with "iwconfig" all by itself (see further below, too)?

About the driver.... How can I install a "Master mode capable" drivere on Linux (particullary SUSE)?
You fetch the proper source, make sure your compile environment is properly set up (including kernel source), compile the driver and place the binary in the appropriate directory, along with probably required extra files (like card-specific microcode). But since 2.6.32 and above are said to provide a master-mode capable driver, I doubt you need to take these steps.
Being the bean counter I am, I'd like to mention that "SUSE" is ambiguous: There's openSUSE, SUSE Linux Enterprise Server (SLES) and SUSE Linux Enterprise Desktop (SLED). This forum is about SLES, which you originally mentioned you're running :).

Third: What that means: "...master mode only works on the ath0 device." (shall i change the name of the wlan card wlano --> ath0 ? (I have only one card installed)!
Linux device drivers can provide more than one device file for a single installed device - i.e. to provide a separate interface for device configuration, as opposed to regular usage. AFAIR the Atheros drivers provides an athX device for configuration and wlanX for regular (client) network traffic. So I'm looking for an *extra* interface, besides the wlan0 - no renaming required. "iwconfig" without parameters should list and comment all interfaces available, which is why I ask for the output of the command.


Finally: Sorry again ;) for any inconvenience! I did almost everything to set up this card in both master mode and ad-hoc mode and still the same error occurs!
No need to apologize - we're trying to help as best as we can, and although I believe you'll end setting up hostapd anyhow, I take the challenge to first try to set up things without it :)

Regards,
Jens

pintilie_luci
05-Aug-2013, 10:41
Finally a conclussion can be considdered: I need to install and configure Hostapd, because the MASTER mode does not work at all! I have tried exactly what they have said: even without bridging the device (I have assigned a static ip and set to the master mode), even installed Suse Linux Enterprise server SP. 2 and still the card can't be initialized in Master Mode, and Ad-Hoc the same... the iwconfig message is this: # iwconfig wlan0 mode Master
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument" (and I have disabled Power Management, still the same error.)
I think there's a bug in the Operating System... (because this is a "native function" of the operating system the master mode). About the adapter: Is a relatively new wlan adapter (some forums say that this is a mac80211 driver in hostapd therms), it is even designed for Windows 7 (and i think there's something in Windows 7 that turns the adapter into an Access Point, of Ad-hoc sharing! And I even remember that i have done this some month ago with the same card, and it displayed the SSID as an Access Point! so the card CAN be set on Acces Point master mode but,.... on Windows 7 and 2008 R2 server x64) Problem: my machine is a Pentium III at 990 Mhz, aprox 1 Ghz and 512 MB Ram, 20 GB Hard Disk. Suse Linux Enterprise Server 11 i586 works best, and Windows 2003 R2 x32 the same! (with Comodo Internet Security)

So, On this kind of O.S. I think the Master mode function shall be Revised and rewritten (in programming therms I'm speaking).
If you have any ideea on this iwconfig error code tell me, but I might want to know how to install Hostapd on the current configuration (with bridge)!
Anyway Thanks in Advance!

pintilie_luci
05-Aug-2013, 10:54
devices are: eth0, eth1, wlan0, br0, and dsl0 (PPPoE).... the device wlan0 is tp-link wn350gd listrd with driver ath5k.... no ath0.... anyway....

jmozdzen
05-Aug-2013, 12:07
Hi pintilie_luci,


[...]the card can't be initialized in Master Mode, and Ad-Hoc the same... the iwconfig message is this: # iwconfig wlan0 mode Master
Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid argument" (and I have disabled Power Management, still the same error.)
I think there's a bug in the Operating System... (because this is a "native function" of the operating system the master mode). About the adapter: Is a relatively new wlan adapter (some forums say that this is a mac80211 driver in hostapd therms), it is even designed for Windows 7 (and i think there's something in Windows 7 that turns the adapter into an Access Point, of Ad-hoc sharing! And I even remember that i have done this some month ago with the same card, and it displayed the SSID as an Access Point! so the card CAN be set on Acces Point master mode but,.... on Windows 7 and 2008 R2 server x64) Problem: my machine is a Pentium III at 990 Mhz, aprox 1 Ghz and 512 MB Ram, 20 GB Hard Disk. Suse Linux Enterprise Server 11 i586 works best, and Windows 2003 R2 x32 the same! (with Comodo Internet Security)

So, On this kind of O.S. I think the Master mode function shall be Revised and rewritten (in programming therms I'm speaking).

You may be very well right, a new driver may be in order. So just contact the manufacturer and ask where you can download the proper SLES driver for that adapter, as obviously the Win7/Win2k8 drivers won't work. (Like with Microsoft's Windows, it's not an OS question, but a driver for the device that you need.)


If you have any ideea on this iwconfig error code tell me, but I might want to know how to install Hostapd on the current configuration (with bridge)!
Anyway Thanks in Advance!

Without a proper driver, I doubt hostapd will work.

Regards,
Jens

pintilie_luci
05-Aug-2013, 20:27
Hi, there, I know that drivers from Windows won't work for Linux, (it was just an example about Windows 7 access point...). Anyway, I found this on the ath5k website, and I think, this might be usefull!

Enabling ath5k:

To enable ath5k in the kernel configuration, you must first enable mac80211: (HOW to enable MAC80211?, this explanantion is not as relevant as possible for me :D)

Networking support --->
Wireless --->
<M> cfg80211 - wireless configuration API
<M> Generic IEEE 802.11 Networking Stack (mac80211)
Please note that in older kernels there was another 802.11 networking stack: (what kernels, what stacks????)

< > Generic IEEE 802.11 Networking Stack
You do not need this. This option enables the old SoftMAC which is already removed from newer kernels. You can still safely enable this though. (What is SoftMAC?)

You can then enable ath5k in the kernel configuration under

Device Drivers --->
Network device support --->
Wireless LAN --->
<M> Atheros Wireless Cards --->
<M> Atheros 5xxx wireless cards support
To try the driver you can do something like this:

modprobe ath5k
sudo ip link set wlan%d up (now, if I input this commands the error occurs and it says "Invalid Argument" "Set: Mode")
sudo iwconfig wlan%d essid any
# Make sure you get auth'd and then assoc'd (Wlan mode is Master)
# Then either set an IP manually or get it via DHCP (The Wlan is bridged with a static ip assigned to the bridge)
ping gw

Final conclusion: I don't know anything about how to make things operate in MASTER MODE, I don't know anything, and I forgot even what I already knew! ;) I'm totally lost in all this explanations.... What I finally understood is that: 1. This card uses ath5k driver (and an Atheros chip). 2. It needs hostapd "suite" software (daemon) to operate in master mode. 3. The ath5k driver is a mac80211 based driver (in hostapd therms). 4. I need to install hostapd on Suse Linux Server Enterprise 11 i586 SP1 (with the bridge configuration an the wlan card in Master mode) and I don't know how!
Final question: Can You please tell me exactly (with details) how to install HOSTAPD WITH DEPENDENCIES. If you can tell me how to install from a repository (I think it can be possible from openSuse reponsitories, but, I don't know the links from openSuse repositories, can you provide them? with the hostapd dependencies of course!)

Anyway Thanks for reply!

pintilie_luci
05-Aug-2013, 20:36
Hi pintilie_luci,
You may be very well right, a new driver may be in order. So just contact the manufacturer and ask where you can download the proper SLES driver for that adapter.....


What the manufacturer website says: "The driver is pre-installed in most current Linux distributions....." (Practically this is the only way to get it for Linux and if I search the Internet nothig for SUSE! And it's also the latest driver! :D bad chance for me once again!)

jmozdzen
06-Aug-2013, 10:01
Hi pintilie_luci,

Hi, there, I know that drivers from Windows won't work for Linux, (it was just an example about Windows 7 access point...). Anyway, I found this on the ath5k website, and I think, this might be usefull!

Enabling ath5k:

To enable ath5k in the kernel configuration, you must first enable mac80211: (HOW to enable MAC80211?, this explanantion is not as relevant as possible for me :D)

Networking support --->
Wireless --->
<M> cfg80211 - wireless configuration API
<M> Generic IEEE 802.11 Networking Stack (mac80211)
Please note that in older kernels there was another 802.11 networking stack: (what kernels, what stacks????)

< > Generic IEEE 802.11 Networking Stack
You do not need this. This option enables the old SoftMAC which is already removed from newer kernels. You can still safely enable this though. (What is SoftMAC?)

You can then enable ath5k in the kernel configuration under

Device Drivers --->
Network device support --->
Wireless LAN --->
<M> Atheros Wireless Cards --->
<M> Atheros 5xxx wireless cards support
To try the driver you can do something like this:

modprobe ath5k
sudo ip link set wlan%d up (now, if I input this commands the error occurs and it says "Invalid Argument" "Set: Mode")
sudo iwconfig wlan%d essid any
# Make sure you get auth'd and then assoc'd (Wlan mode is Master)
# Then either set an IP manually or get it via DHCP (The Wlan is bridged with a static ip assigned to the bridge)
ping gw

Final conclusion: I don't know anything about how to make things operate in MASTER MODE, I don't know anything, and I forgot even what I already knew! ;) I'm totally lost in all this explanations.... What I finally understood is that: 1. This card uses ath5k driver (and an Atheros chip). 2. It needs hostapd "suite" software (daemon) to operate in master mode. 3. The ath5k driver is a mac80211 based driver (in hostapd therms). 4. I need to install hostapd on Suse Linux Server Enterprise 11 i586 SP1 (with the bridge configuration an the wlan card in Master mode) and I don't know how!
Final question: Can You please tell me exactly (with details) how to install HOSTAPD WITH DEPENDENCIES. If you can tell me how to install from a repository (I think it can be possible from openSuse reponsitories, but, I don't know the links from openSuse repositories, can you provide them? with the hostapd dependencies of course!)

Anyway Thanks for reply!

seems you're doing the deep-dive ;)

I recommend that you try to get your card into master mode via a current openSUSE release, probably via the Live DVD (to avoid installing openSUSE on your machine). Once you got your adapter into master mode there, it's time to check if and how you could port the required pieces (car ddriver, hostapd) to SLES.

> Can You please tell me exactly (with details) how to install HOSTAPD WITH DEPENDENCIES. If you can tell me how to install from a repository (I think it can be possible from openSuse reponsitories, but, I don't know the links from openSuse repositories, can you provide them? with the hostapd dependencies of course!)

I had already checked software.opensuse.org for hostapd packages for SLES, but there's no such thing. Trying to cross-install openSUSE packages (in terms of "compiled for an openSUSE install") requires almost as much understanding as does preparing and recompiling the source packages, which I feel would be quite a challenge to you ATM.

BTW, it's the *driver* that needs to support "master mode", which is what currently seems to fail for your hardware/driver combo. hostapd just contains the tools to then operate the "WLAN access point" (encryption, access lists etc) via the card.

As you are running SLES - do you have a support subscription for your installation? It'd probably be quicker to issue a service request with official SUSE support, although I still doubt that running an AP is officially supported for SLES. But they'd know and tell you, either that you cannot or how you'd run the AP :)

Regards,
Jens

jmozdzen
06-Aug-2013, 11:09
Hipintilie_luci,

[...]Anyway, I found this on the ath5k website, and I think, this might be usefull!

Enabling ath5k:[....]

I take it you're referencing http://wireless.kernel.org/en/users/Drivers/ath5k where it also says:

Supported Devices
See the ath5k device list (http://wireless.kernel.org/en/users/Drivers/ath5k/devices). This list is still very much incomplete - please add your device/card if it works! A longer but less reliable list can be found at http://madwifi-project.org/wiki/Compatibility. It's worth trying your card with ath5k even though it is not in the list above, if it has one of the following chips:

and concerning problem reports, it also says

Please when submitting a bug report always include your card's silicon revision for MAC and PHY chips, just look at your kernel log for a line like this one... or dmesg |grep "ath5.*chip":


What the manufacturer website says: "The driver is pre-installed in most current Linux distributions....." (Practically this is the only way to get it for Linux and if I search the Internet nothig for SUSE! And it's also the latest driver! :D bad chance for me once again!)
Yes, there's broad community support for that chipset - and on SLES11SP1 I can see via "modinfo ath5k" that version0.6.0 is reported, which is the same version I see in git. So as you wrote, this already is the most current driver - which narrows things down to to possible situations:
- something is sub-optimal with your install / configuration
- your hardware isn't properly supported

Which brings me back to my former suggestion: Try the live version of openSUSE to see if you can activate master mode for your card (running hostapd is an intended use case for openSUSE). If it works there (and if the driver version is the same as in SLES), then you can try to get things running on SLES.

Regards,
Jens

pintilie_luci
11-Sep-2014, 10:38
Finally after almost 2 years of researching over this subject, I have found the answer to this question.
The answer is simple and short: "...use HostAPD in .RPM package format!", because Suse Linux Enterprise Server uses a graphical package management software, and it easily solves all the dependecies (even the driver stack for the WLAN card)...
After that, some command-line (terminal) wizzards done the job very well (questions about how to configure it even about NAT, or Bridged mode)... Some script editing skills were necesary (SSiD and WPA-PSK key configuration) and all the job was done!!!

About the Suse's MASTER MODE: This dosen't work at all even in SUSE LINUX ENTERPRISE SERVER SP3 (I think this function has programming ISSUES - and yes!, it needs to be rewritten (and I wish that shall be replaced with a HostAPD graphical DAEMON) and of course HostAPD supports WPA-PSK, Master mode only WEP! (so, this makes HostAPD much more powerfull!)

Thanks for all your answers guys over this subject! And I wish someone shall give us here a full tutorial on how to install HostAPD on SUSE, and then to mark this subject as SOLVED! I'm very glad that WE ALL came with a conclussion to this question!

God bless you!