PDA

View Full Version : vlan tagging to a Niantic VF function on SLES 11 SP3 GM



sauabhericsson
15-Aug-2013, 19:37
Hi,

Has anybody tried VLAN tagging to a Niantic (ixgbe) VF function on SP3 GM? The Niantic VF function is assigned to a VM running on Xen.

Thanks,
/Saurabh

smflood
16-Aug-2013, 11:03
On 15/08/2013 19:44, sauabhericsson wrote:

> Has anybody tried VLAN tagging to a Niantic (ixgbe) VF function on SP3
> GM? The Niantic VF function is assigned to a VM running on Xen.

So the VM (guest) is SLES11 SP3 but what version of Linux is the Xen
host running? In particular which version of Xen?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
Do you work with SUSE technologies at a university, college or school?
If so, your campus could benefit from joining the Technology Transfer
Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------

sauabhericsson
16-Aug-2013, 17:33
Hi,

dom0 is running SLES 11 SP3 (3.0.76-0.11-xen) and guest VM is running SP3 (3.0.76-0.11) in HVM mode. We also use WindRiver kernel (3.0.75-x) as an HVM guest. It all works very well with SLES 11 SP2 GM.

It worked very well on SP2. For example (working case) :

ssc-lc-9:~ # ip link show eth3
13: eth3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
link/ether 02:00:00:03:00:00 brd ff:ff:ff:ff:ff:ff
vf 0 MAC 9e:59:f7:23:c9:73
vf 1 MAC d6:3b:71:6e:9f:f1
vf 2 MAC e2:65:2d:41:7e:1c
vf 3 MAC 16:c4:dd:1e:fc:df
vf 4 MAC 3e:95:33:16:26:f4
vf 5 MAC d6:01:a7:26:0e:49
vf 6 MAC 62:72:7a:28:50:26
vf 7 MAC 02:00:00:03:08:01
ssc-lc-9:~ # ip link set eth3 vf 0 vlan 100
ssc-lc-9:~ # ip link show eth3
13: eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
link/ether 02:00:00:03:00:00 brd ff:ff:ff:ff:ff:ff
vf 0 MAC 9e:59:f7:23:c9:73, vlan 100
vf 1 MAC d6:3b:71:6e:9f:f1
vf 2 MAC e2:65:2d:41:7e:1c
vf 3 MAC 16:c4:dd:1e:fc:df
vf 4 MAC 3e:95:33:16:26:f4
vf 5 MAC d6:01:a7:26:0e:49
vf 6 MAC 62:72:7a:28:50:26
vf 7 MAC 02:00:00:03:08:01

Non-working case with SP3 GM. Looks like SLES 11 SP3 packaging is broken bit time with iproute and ixgbe.

ssc-lc-9:~ # ip link set eth3 vf 0 vlan 100
ssc-lc-9:~ # ip link show eth3
13: eth3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
link/ether 02:00:00:03:00:00 brd ff:ff:ff:ff:ff:ff


We are using iproute version 3.4.x

ssc-lc-9:~ # modinfo ixgbe | grep version
version: 3.11.33-k
srcversion: 76C492FA0B3CB3518845F24
vermagic: 3.0.76-0.11-xen SMP mod_unload modversions Xen
ssc-lc-9:~ #