PDA

View Full Version : Error with GTK library



pecci
05-Sep-2013, 14:39
Dear all,
yesterday I updated the o.s. and since that moment I have the following error, every time I start any graphical program:

Gtk-Message: failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: Nosuch file or directory
I have tried to install PackageKit-gtk-module but I didn't find in the official repository.

How can I do avoid the message? :(
Thanks in advance for any help,
cheers,
Leda

malcolmlewis
05-Sep-2013, 15:24
On Thu 05 Sep 2013 01:44:02 PM CDT, pecci wrote:


Dear all,
yesterday I updated the o.s. and since that moment I have the following
error, every time I start any graphical program:

Gtk-Message: failed to load module "pk-gtk-module": libpk-gtk-module.so:
cannot open shared object file: Nosuch file or directory
I have tried to install PackageKit-gtk-module but I didn't find in the
official repository.

How can I do avoid the message? :(
Thanks in advance for any help,
cheers,
Leda




Hi
What SLE release are your running? Have you installed any applications
not from the standard repositories?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

jmozdzen
06-Sep-2013, 13:04
Hi Leda,

Dear all,
yesterday I updated the o.s. and since that moment I have the following error, every time I start any graphical program:

Gtk-Message: failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: Nosuch file or directory
I have tried to install PackageKit-gtk-module but I didn't find in the official repository.

How can I do avoid the message? :(
Thanks in advance for any help,
cheers,
Leda

in addition to checking Malcolm's questions towards the cause of the situation, you may try to avoid the message by setting /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module to false via i.e. gconf-editor. But that is solely a work-around - the message (or rather loading that shared object) should not occur on a properly set up SLES system, AFAICT.

Regards,
Jens

pecci
06-Sep-2013, 13:23
Thanks for your reply. I'm using SLES 11 SP3. I have 2 servers with the same problem that I have upgraded from the version SLES 11 SP2 via zypper.
I didn't find the gnome_settings_daemon and neither gtk-modules or pk-gtk-module.
Any other workaround I could try?
Cheers,
Leda


Hi Leda,


in addition to checking Malcolm's questions towards the cause of the situation, you may try to avoid the message by setting /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module to false via i.e. gconf-editor. But that is solely a work-around - the message (or rather loading that shared object) should not occur on a properly set up SLES system, AFAICT.

Regards,
Jens

pecci
06-Sep-2013, 13:32
Thanks Malcomlewis for your reply,
I'm using the SLES SP3 and I have the same problem in 2 different server. I have installed in both server some driver to connect do db and the java virtual machine not using the official repository. I think that is a bug of gtk but I don't know how to avoid the message, it's only annoying because the program starts in spite of the message error.
Cheers,
Leda

So the



Hi
What SLE release are your running? Have you installed any applications
not from the standard repositories?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

jmozdzen
06-Sep-2013, 14:42
Hi Leda,

> I didn't find the gnome_settings_daemon and neither gtk-modules or pk-gtk-module

Have you tried adding them yourself? I see at least gnome_settings_daemon but am missing the gtk-module subnode. For a test you could add them yourself, i.e. in some user-specific gconf file or in /etc/gconf/gconf.xml.vendor/%gconf-tree.xml (your change will most likely be gone if gconf2-branding-SLES ever gets updated)

Regards,
Jens

malcolmlewis
06-Sep-2013, 15:08
On Fri 06 Sep 2013 12:34:04 PM CDT, pecci wrote:


Thanks Malcomlewis for your reply,
I'm using the SLES SP3 and I have the same problem in 2 different
server. I have installed in both server some driver to connect do db
and the java virtual machine not using the official repository. I think
that is a bug of gtk but I don't know how to avoid the message, it's
only annoying because the program starts in spite of the message error.
Cheers,
Leda


Hi
I would guess that your installed program is calling it, the version of
PackageKit shipped with SLE is on 0.3.x the library in question never
appeared until 0.5.x.

If you run the command ldd on the binary your starting it should show it missing.

So, not a bug as such, maybe you can get back to the db/java folks and
ask them.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

pecci
06-Sep-2013, 15:24
Hi Jens,
I didn't get it. I don't know as gtk works, I have tried to find the reference to the error message searching for "pk-gtk-module" with grep but without success.
I have found the file /etc/gconf/gconf.xml.vendor/%gconf-tree.xml but I have no reference to modules. Where I have to put a reference? :rolleyes:
Thanks for your help,

cheers,
Leda




Hi Leda,

> I didn't find the gnome_settings_daemon and neither gtk-modules or pk-gtk-module

Have you tried adding them yourself? I see at least gnome_settings_daemon but am missing the gtk-module subnode. For a test you could add them yourself, i.e. in some user-specific gconf file or in /etc/gconf/gconf.xml.vendor/%gconf-tree.xml (your change will most likely be gone if gconf2-branding-SLES ever gets updated)

Regards,
Jens

jmozdzen
06-Sep-2013, 16:01
Hi Leda,


Hi Jens,
I didn't get it. I don't know as gtk works, I have tried to find the reference to the error message searching for "pk-gtk-module" with grep but without success.
I have found the file /etc/gconf/gconf.xml.vendor/%gconf-tree.xml but I have no reference to modules. Where I have to put a reference? :rolleyes:
Thanks for your help,

cheers,
Leda

may I assume that you had opened "gconf-editor" per my earlier message? It's a program available in SLES11SP3, eventually needs to be installed separately.

It will give you a hierarchical view of gnome configuration settings - the path down the tree was was I referenced in my original message. On a stock SLES11SP3 I didn't see gtk-module or below, though.

If you take a closer look at the "vendor config tree" file, you'll notice it's an XML file of hierarchical structure (hence it's name), where you can add your own elements manually. There are other places, too, where gconf will look for that information, snoop around in /etc/gconf and you'll see. One of them is ~/.gconf, where you could add a (user-specific) file to just define your pk-gtk-module subnode without risking that the global file will be overwritten after some package update.

Regards,
Jens

pecci
09-Sep-2013, 15:50
Hi Jens,
I have tried to change in the files that you have suggested but probably I have made a mistake. I have changed with an editor the entry for pk-gtk-module as it follows:
in the /etc/gconf/gconf.xml.vendor/%gconf-tree.xml in the rows regarding gnome_settings_daemon
<entry name="pk-gtk-module" mtime=" a number" type="bool" value="false"/>

I have tried to use gconf-editor but when I added the entry for pk-gtk-module I had an error that was regarding the absence of an associated schema to the pk-gtk-modules. :confused:
I don't know where is the problem,
thanks for now,
bye,
Leda



Hi Leda,



may I assume that you had opened "gconf-editor" per my earlier message? It's a program available in SLES11SP3, eventually needs to be installed separately.

It will give you a hierarchical view of gnome configuration settings - the path down the tree was was I referenced in my original message. On a stock SLES11SP3 I didn't see gtk-module or below, though.

If you take a closer look at the "vendor config tree" file, you'll notice it's an XML file of hierarchical structure (hence it's name), where you can add your own elements manually. There are other places, too, where gconf will look for that information, snoop around in /etc/gconf and you'll see. One of them is ~/.gconf, where you could add a (user-specific) file to just define your pk-gtk-module subnode without risking that the global file will be overwritten after some package update.

Regards,
Jens

pecci
09-Sep-2013, 15:54
Hi Malcom,
thanks for your reply. I have found a lot of people in the internet that has the same problem but I'm still working to find a solution for SLES. Maybe is related with the java virtual machine but I have to use the type sun jre. The most part of suggestions are related with gtk configuration.
Bye for now,
cheers,
Leda


Hi
I would guess that your installed program is calling it, the version of
PackageKit shipped with SLE is on 0.3.x the library in question never
appeared until 0.5.x.

If you run the command ldd on the binary your starting it should show it missing.

So, not a bug as such, maybe you can get back to the db/java folks and
ask them.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

jmozdzen
09-Sep-2013, 17:09
Hi Leda,

while I received a similar message when running gconf-editor, I took it for more of a hint or warning ;)

I have decided to create the change in user space only, not to mess with the system installation, leading to the following:

jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon> find . -ls
549240028 4 drwx------ 3 jmozdzen users 41 Sep 9 17:58 .
549240044 0 -rw------- 1 jmozdzen users 0 Sep 9 17:58 ./%gconf.xml
899437811 4 drwx------ 2 jmozdzen users 23 Sep 9 17:59 ./gtk-modules
903926680 4 -rw------- 1 jmozdzen users 115 Sep 9 17:59 ./gtk-modules/%gconf.xml
jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon> cat ./gtk-modules/\%gconf.xml
<?xml version="1.0"?>
<gconf>
<entry name="pk-gtk-module" mtime="1378742272" type="bool" value="false"/>
</gconf>
jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon>

> In the /etc/gconf/gconf.xml.vendor/%gconf-tree.xml in the rows regarding gnome_settings_daemon

You might be missing the "encapsulating" <directory> part, to create "gtk-modules", where you then would set pk-gtk-module as you (in my eyes correctly) stated in your message.


<dir name="gnome_settings_daemon">
<dir name="gtk-modules">
<entry name="pk-gtk-module" mtime="1378742272" type="bool" value="false"/>
</dir>
</dir>

Regards,
Jens

pecci
10-Sep-2013, 15:35
Hi Jens,
I tried all your suggestions. Even if in the .gconf directory the setting is to false, the configuration is like the one you wrote I have always the same message.
I'll give up. :( I have found some suggestions in the network said to install "PackageKit-gtk3-module" but in the SLES there isn't any official repository for this.
Thanks for your help.
Ciao,
Leda


Hi Leda,

while I received a similar message when running gconf-editor, I took it for more of a hint or warning ;)

I have decided to create the change in user space only, not to mess with the system installation, leading to the following:

jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon> find . -ls
549240028 4 drwx------ 3 jmozdzen users 41 Sep 9 17:58 .
549240044 0 -rw------- 1 jmozdzen users 0 Sep 9 17:58 ./%gconf.xml
899437811 4 drwx------ 2 jmozdzen users 23 Sep 9 17:59 ./gtk-modules
903926680 4 -rw------- 1 jmozdzen users 115 Sep 9 17:59 ./gtk-modules/%gconf.xml
jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon> cat ./gtk-modules/\%gconf.xml
<?xml version="1.0"?>
<gconf>
<entry name="pk-gtk-module" mtime="1378742272" type="bool" value="false"/>
</gconf>
jmozdzen@myhost:~/.gconf/apps/gnome_settings_daemon>

> In the /etc/gconf/gconf.xml.vendor/%gconf-tree.xml in the rows regarding gnome_settings_daemon

You might be missing the "encapsulating" <directory> part, to create "gtk-modules", where you then would set pk-gtk-module as you (in my eyes correctly) stated in your message.


<dir name="gnome_settings_daemon">
<dir name="gtk-modules">
<entry name="pk-gtk-module" mtime="1378742272" type="bool" value="false"/>
</dir>
</dir>

Regards,
Jens

pecci
10-Sep-2013, 17:30
Hi Jens and Malcom,
I have read on Internet that the library is only referenced but it is not used, for a bug in gtk2, so I finally I have solved in this way:
have found in the network the required module: libpk-gtk-module.so and I have added in /usr/lib64/gtk-2.0/modules/
I hope that this will be usefull for someone else.
Thanks to you, :)
bye for now,
ciao,
Leda