PDA

View Full Version : Network driver for Atheros AR8161



jgb
13-Sep-2013, 15:36
Hi,

I'm "only" a Linuy user and not a developer. So I need help to compile / get a netcard driver for an Atheros AR8161 chip for SLES11 SP3.

I've tried to compile different version of backport sources and also the sources from the "alx standalone development tree" https://github.com/erikarn/alx .
I get always a lot of error about "redefinition of xxxx" .

The kernel version is 3.0.76-0.11 default #1 SMP x86_64 from Jun 14 2013 ( ccab990) .
Kernel sources, sym etc installed.

The Atheros chip version is:

AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Any ideas ?

Jens

malcolmlewis
13-Sep-2013, 16:03
On Fri 13 Sep 2013 02:44:02 PM CDT, jgb wrote:


Hi,

I'm "only" a Linuy user and not a developer. So I need help to compile /
get a netcard driver for an Atheros AR8161 chip for SLES11 SP3.

I've tried to compile different version of backport sources and also the
sources from the "alx standalone development tree"
https://github.com/erikarn/alx .
I get always a lot of error about "redefinition of xxxx" .

The kernel version is 3.0.76-0.11 default #1 SMP x86_64 from Jun 14
2013 ( ccab990) .
Kernel sources, sym etc installed.

The Atheros chip version is:

AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Any ideas ?

Jens




Hi
If you grab this src rpm and rebuild it, it's for your pci id;


http://ftp5.gwdg.de/pub/opensuse/repositories/home:/Akoellh:/Kernelmodules/openSUSE_12.3/src/alx-1.2.3+git20130403-2.1.src.rpm

You may need to modify the spec file to remove the;


BuildRequires: %kernel_module_package_buildreqs

Since SLE knows nothing about this rpm macro.

Build project is here;
https://build.opensuse.org/package/show?project=home%3AAkoellh%3AKernelmodules&package=alx

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
13-Sep-2013, 17:11
On Fri 13 Sep 2013 03:03:23 PM CDT, malcolmlewis wrote:



On Fri 13 Sep 2013 02:44:02 PM CDT, jgb wrote:


Hi,

I'm "only" a Linuy user and not a developer. So I need help to compile /
get a netcard driver for an Atheros AR8161 chip for SLES11 SP3.

I've tried to compile different version of backport sources and also the
sources from the "alx standalone development tree"
https://github.com/erikarn/alx .
I get always a lot of error about "redefinition of xxxx" .

The kernel version is 3.0.76-0.11 default #1 SMP x86_64 from Jun 14
2013 ( ccab990) .
Kernel sources, sym etc installed.

The Atheros chip version is:

AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Any ideas ?

Jens




Hi
If you grab this src rpm and rebuild it, it's for your pci id;


http://ftp5.gwdg.de/pub/opensuse/repositories/home:/Akoellh:/Kernelmodules/openSUSE_12.3/src/alx-1.2.3+git20130403-2.1.src.rpm

You may need to modify the spec file to remove the;


BuildRequires: %kernel_module_package_buildreqs

Since SLE knows nothing about this rpm macro.

Build project is here;
https://build.opensuse.org/package/show?project=home%3AAkoellh%3AKernelmodules&package=alx



Hi
A further look (and branched to my home obs project) shows it's not
building. I found it in the compat backports, so will look at building
as a standalone KMP on OBS. Stay tuned.....

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
14-Sep-2013, 12:56
On Fri 13 Sep 2013 04:11:01 PM CDT, malcolmlewis wrote:



On Fri 13 Sep 2013 03:03:23 PM CDT, malcolmlewis wrote:



On Fri 13 Sep 2013 02:44:02 PM CDT, jgb wrote:


Hi,

I'm "only" a Linuy user and not a developer. So I need help to compile /
get a netcard driver for an Atheros AR8161 chip for SLES11 SP3.

I've tried to compile different version of backport sources and also the
sources from the "alx standalone development tree"
https://github.com/erikarn/alx .
I get always a lot of error about "redefinition of xxxx" .

The kernel version is 3.0.76-0.11 default #1 SMP x86_64 from Jun 14
2013 ( ccab990) .
Kernel sources, sym etc installed.

The Atheros chip version is:

AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Any ideas ?

Jens




Hi
If you grab this src rpm and rebuild it, it's for your pci id;


http://ftp5.gwdg.de/pub/opensuse/repositories/home:/Akoellh:/Kernelmodules/openSUSE_12.3/src/alx-1.2.3+git20130403-2.1.src.rpm

You may need to modify the spec file to remove the;


BuildRequires: %kernel_module_package_buildreqs

Since SLE knows nothing about this rpm macro.

Build project is here;
https://build.opensuse.org/package/show?project=home%3AAkoellh%3AKernelmodules&package=alx



Hi
A further look (and branched to my home obs project) shows it's not
building. I found it in the compat backports, so will look at building
as a standalone KMP on OBS. Stay tuned.....



Hi
Well not having much luck with the SP3 kernel, SP1 and SP2 build
fine... (I had it already built in another home project for openSUSE).

Will try and revisit over the weekend...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
17-Sep-2013, 02:28
Hi
Haven't had a chance to followup on this, hopefully in the next few days Any thoughts on getting an alternative supported (as having an in-kernel driver) card for the system?

jgb
19-Sep-2013, 14:41
Hi Malcolm,

unfortunatley I haven't any other network card. I'm out of office the next two weeks, so it's not so urgent to solve the problem. But I would be very glad, if you can help me to get the card up and running.

Regards

Jens

nwbasson
01-Oct-2013, 23:43
Hi, I am looking for a 1969:1803 driver for SLES 11 SP2. I have tried everything in this thread: https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/485001-get-your-wired-ethernet-working-attansic-ethernet-controller-1969-1091-a.html but no luck.

Any idea where I should look for a solution?

Thanks,

Nico

EDIT: ok so according to this http://www.linuxfoundation.org/collaborate/workgroups/networking/alx I found out i needed atl1c.

I got it to work by the looks of it.

cokecolt
07-Nov-2013, 23:58
Hello,

Any one got correct drivers?
I tried many drivers, but it still have compile errors.

Thanks!