PDA

View Full Version : YaST2 (Apache2 error: cannot adjust Apache2 service) at 50%



tarzy
14-Sep-2013, 06:10
I'll surmise in advance that I'm in for some serious reading; but acknowledge that I'm always looking for a quicker way out due to a redundant Dyslexia issue that cropped up half a dozen years back.

I am not sure I like the YaST controll of all the things it does, but I'll reserve judgement for a bit later.

So, using YaST Control Center, I got into looking at the modules, and using what I believed to be common sense, started tinkering with enabling a few modules and then encountered this error while YaST was writing/"adjusting" the config: "Cannot adjust Apache2 Service". I went to the extent of disabling all of the modules (not keeping any notes) and nothing I tried would stop this error.

What I initially was looking for in YaST was MySQL, which I know I installed once I fixed my initial Networking Problem. Like a Kid in a Sandbox, I got sidetracked, and here I am!

The beauty of this is that I have my 2 domain's vhosts on my old Fedora 9 rig, which I can examine some items without Danger, and hopefully learn a few things.

Anyhow, while I'm reading in the next few days, if I've posted in the correct spot and anyone has any tips, I'll be happy to have them. Any YaST ones too.

Regards, tarzy...........

malcolmlewis
14-Sep-2013, 06:21
Hi
What version of SLES are you running? If your not to far down the track, you can always force the re-install of Apache2? This should reset everything and the configs.

tarzy
14-Sep-2013, 07:40
Hi
What version of SLES are you running? If your not to far down the track, you can always force the re-install of Apache2? This should reset everything and the configs.

SLES 11 SP3. I'll try that, but will need to find out how as I'm a "goofy GUI Guy". I'll Google it.

malcolmlewis
14-Sep-2013, 12:55
On Sat 14 Sep 2013 06:44:02 AM CDT, tarzy wrote:


malcolmlewis;16257 Wrote:
> Hi
> What version of SLES are you running? If your not to far down the
> track, you can always force the re-install of Apache2? This should
> reset everything and the configs.

SLES 11 SP3. I'll try that, but will need to find out how as I'm a
"goofy GUI Guy". I'll Google it.




Hi
Probably easier from the command line with zypper....


zypper in -f <some_package> <some_package2> <etc>

In your case it will be apache....

You can find out the installed packages with the search feature of
zypper;


zypper se -i apache

This will search for packages with apache in there name and the -i
means it will only show installed ones.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

tarzy
15-Sep-2013, 07:56
SLES 11 SP3. I'll try that, but will need to find out how as I'm a "goofy GUI Guy". I'll Google it.

I may be learning some things after all; here is the output from my search to fix this problem:

# httpd2 -t
httpd2: Syntax error on line 117 of /etc/apache2/httpd.conf: Syntax error on line 26 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib64/apache2-prefork/mod_mem_cache.so into server: /usr/lib64/apache2-prefork/mod_mem_cache.so: undefined symbol: ap_cache_cacheable_hdrs_out

To me, this seems to show I screwed something up with my module fidgiting in YaST. I have a nasty habit of placing roadblocks mentally in my way, but one, whether it is or isn't is it seems like a steep curve for me personally, in learning YaST. I am slowly trying to absorb the documentation, which is lengthy, like everything in Linux. I desperately want to get this SLES tuned and working, it just seems great, even though I know so little!

Also, does anyone know if Webmin can work with SLES? It is what I have grown so used to for day-to-day tweaks, especially MySQL.

Regards, tarzy

malcolmlewis
15-Sep-2013, 15:13
On Sun 15 Sep 2013 07:04:03 AM CDT, tarzy wrote:


tarzy;16258 Wrote:
> SLES 11 SP3. I'll try that, but will need to find out how as I'm a
> "goofy GUI Guy". I'll Google it.

I may be learning some things after all; here is the output from my
search to fix this problem:

# httpd2 -t
httpd2: Syntax error on line 117 of /etc/apache2/httpd.conf: Syntax
error on line 26 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot
load /usr/lib64/apache2-prefork/mod_mem_cache.so into server:
/usr/lib64/apache2-prefork/mod_mem_cache.so: undefined symbol:
ap_cache_cacheable_hdrs_out

To me, this seems to show I screwed something up with my module
fidgiting in YaST. I have a nasty habit of placing roadblocks mentally
in my way, but one, whether it is or isn't is it seems like a steep
curve for me personally, in learning YaST. I am slowly trying to absorb
the documentation, which is lengthy, like everything in Linux. I
desperately want to get this SLES tuned and working, it just seems
great, even though I know so little!

Also, does anyone know if Webmin can work with SLES? It is what I have
grown so used to for day-to-day tweaks, especially MySQL.

Regards, tarzy




Hi
Webmin will work, what ever you use there, don't use in YaST. There is
also WebYaST?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

tarzy
15-Sep-2013, 21:24
Hi
Webmin will work, what ever you use there, don't use in YaST. There is
also WebYaST?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Here is my terminal output:

linux-2u6o:~ # /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
Syntax error on line 10 of /etc/apache2/vhosts.d/ip-based_vhosts.conf:
ScriptAlias takes two arguments, a fakename and a realname

Here is the file in question (which I have not edited):

<VirtualHost playguitarvideos.com>
DocumentRoot /srv/www/htdocs/pgvdotcom
ServerName playguitarvideos.com
ServerAdmin admin@playguitarvideos.com
<Directory /srv/www/htdocs/pgvdotcom>
AllowOverride None
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/
<Directory /srv/www/cgi-bin>
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
UserDir public_html
</VirtualHost>
<VirtualHost craigtarwater.com>
DocumentRoot /srv/www/htdocs/ctdotcom
ServerName craigtarwater.com
ServerAdmin admin@craigtarwater.com
<Directory /srv/www/htdocs/New Folder>
AllowOverride None
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/
<Directory >
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
UserDir public_html
</VirtualHost>

Can I ask what could be the syntax error on line 10 (ScriptAlias /cgi-bin), which is on several lines?

smflood
16-Sep-2013, 11:03
On 15/09/2013 21:25, tarzy wrote:

> Here is the file in question (which I have not edited):
>
> <VirtualHost playguitarvideos.com>
> DocumentRoot /srv/www/htdocs/pgvdotcom
> ServerName playguitarvideos.com
> ServerAdmin admin@playguitarvideos.com
> <Directory /srv/www/htdocs/pgvdotcom>
> AllowOverride None
> Order allow,deny
> Allow from all
> </Directory>
> ScriptAlias /cgi-bin/
> <Directory /srv/www/cgi-bin>
> AllowOverride None
> Options +ExecCGI -Includes
> Order allow,deny
> Allow from all
> </Directory>
> UserDir public_html
> </VirtualHost>
> <VirtualHost craigtarwater.com>
> DocumentRoot /srv/www/htdocs/ctdotcom
> ServerName craigtarwater.com
> ServerAdmin admin@craigtarwater.com
> <Directory /srv/www/htdocs/New Folder>
> AllowOverride None
> Order allow,deny
> Allow from all
> </Directory>
> ScriptAlias /cgi-bin/
> <Directory >
> AllowOverride None
> Options +ExecCGI -Includes
> Order allow,deny
> Allow from all
> </Directory>
> UserDir public_html
> </VirtualHost>
>
> Can I ask what could be the syntax error on line 10 (ScriptAlias
> /cgi-bin), which is on several lines?

The syntax error for the ScriptAlias directive is because you're missing
the file/directory path the alias should map to - correct syntax is

ScriptAlias URL-path file-path|directory-path

There are two ScriptAlias directives that need correcting - lines 10 & 28.

I also see that the Directory directive in line 29 doesn't include a
directory path.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

tarzy
16-Sep-2013, 16:27
Thanks very much, I'll fix it. I forgot to say I solved the error of this thread's subject.




On 15/09/2013 21:25, tarzy wrote:

> Here is the file in question (which I have not edited):
>
> <VirtualHost playguitarvideos.com>
> DocumentRoot /srv/www/htdocs/pgvdotcom
> ServerName playguitarvideos.com
> ServerAdmin admin@playguitarvideos.com
> <Directory /srv/www/htdocs/pgvdotcom>
> AllowOverride None
> Order allow,deny
> Allow from all
> </Directory>
> ScriptAlias /cgi-bin/
> <Directory /srv/www/cgi-bin>
> AllowOverride None
> Options +ExecCGI -Includes
> Order allow,deny
> Allow from all
> </Directory>
> UserDir public_html
> </VirtualHost>
> <VirtualHost craigtarwater.com>
> DocumentRoot /srv/www/htdocs/ctdotcom
> ServerName craigtarwater.com
> ServerAdmin admin@craigtarwater.com
> <Directory /srv/www/htdocs/New Folder>
> AllowOverride None
> Order allow,deny
> Allow from all
> </Directory>
> ScriptAlias /cgi-bin/
> <Directory >
> AllowOverride None
> Options +ExecCGI -Includes
> Order allow,deny
> Allow from all
> </Directory>
> UserDir public_html
> </VirtualHost>
>
> Can I ask what could be the syntax error on line 10 (ScriptAlias
> /cgi-bin), which is on several lines?

The syntax error for the ScriptAlias directive is because you're missing
the file/directory path the alias should map to - correct syntax is

ScriptAlias URL-path file-path|directory-path

There are two ScriptAlias directives that need correcting - lines 10 & 28.

I also see that the Directory directive in line 29 doesn't include a
directory path.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------