PDA

View Full Version : libecpg6 package is missing in SLES 11 SP3



santosh0705
16-Sep-2013, 12:18
Hi all,
I come around this issue while installing postgresql-devel package version 8.3.23 in SLES 11 SP3.
The libecpg6 package for this postgresql version is missing in the driso DVD. Can someone let me help in getting the proper package.

Regards

malcolmlewis
16-Sep-2013, 13:58
Hi all,
I come around this issue while installing postgresql-devel package version 8.3.23 in SLES 11 SP3.
The libecpg6 package for this postgresql version is missing in the driso DVD. Can someone let me help in getting the proper package.

Regards
Hi
It does indeed seem to be an issue, I've asked my SUSE contacts for further investigation.

santosh0705
17-Sep-2013, 09:58
this is not an issue with SLES 11 SP2. Without this I'm not able to build cfengine.

malcolmlewis
17-Sep-2013, 12:35
On Tue 17 Sep 2013 09:04:03 AM CDT, santosh0705 wrote:


this is not an issue with SLES 11 SP2. Without this I'm not able to
build cfengine.




Hi
The libecpg6 package is there, but not the -devel version which is
needed for compiling since it contains the headers.... I came across
another missing package as well when trying to install postgresql.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
18-Sep-2013, 13:18
On Tue 17 Sep 2013 09:04:03 AM CDT, santosh0705 wrote:


this is not an issue with SLES 11 SP2. Without this I'm not able to
build cfengine.




Hi
OK, there is an updated/renamed package...


zypper in postgresql91-devel

This will pull in libecpg6.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

santosh0705
19-Sep-2013, 06:04
Hi
OK, there is an updated/renamed package...


zypper in postgresql91-devel

This will pull in libecpg6.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 12.3 (x86_64) GNOME 3.8.4 Kernel 3.7.10-1.16-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

This is a different version will it work with postgresql version 8?