PDA

View Full Version : fsck.jfs not run after a power outage



Flako000
07-Dec-2011, 14:36
Hello

Install SLES 11 SP1 using the jfs filesystem on partition /
(root), everything works fine except when you turn the gnu / linux on
a
forced (power outage).
When this happens, do not run fsck.jfs
at the beginning and the gnu does not start, showing the error:


Waiting for device /dev/sda2 to Appear: ok
mount-o rw, default,-t jfs /dev/sda2 /root
mount wrong fs type bad option bad superblock on
/dev/sda2
Could not mount root file system exiting to /bin/sh
sh

the /etc/fstab has
/dev/sda2 / jfs defaults 1 1



I searched online but could not find where you set
to force the fsck, just found the jfs filesystem is no longer
supported by SLES 11 SP1.
That filesytems jfs not have official support for me okay (I'll
settle for kernel support), but I do not like me to choose: (
Curiosity kills me where to set this up ..

The solution to this is to enter cdlive and execute a fsck.jfs
/dev/sda2 :)


Any idea where to look? or find it online? (I
run out of ideas)


Thank you, and forgive me not get along with Google Translate


--
Flako000
------------------------------------------------------------------------
Flako000's Profile: http://forums.novell.com/member.php?userid=116010
View this thread: http://forums.novell.com/showthread.php?t=449268

malcolmlewis
07-Dec-2011, 15:05
On Wed, 07 Dec 2011 13:36:01 GMT
Flako000 <Flako000@no-mx.forums.novell.com> wrote:

>
> Hello
>
> Install SLES 11 SP1 using the jfs filesystem on partition /
> (root), everything works fine except when you turn the gnu / linux on
> a
> forced (power outage).
> When this happens, do not run fsck.jfs
> at the beginning and the gnu does not start, showing the error:
>
>
> Waiting for device /dev/sda2 to Appear: ok
> mount-o rw, default,-t jfs /dev/sda2 /root
> mount wrong fs type bad option bad superblock on
> /dev/sda2
> Could not mount root file system exiting to /bin/sh
> sh
>
> the /etc/fstab has
> /dev/sda2 / jfs defaults 1 1
>
>
>
> I searched online but could not find where you set
> to force the fsck, just found the jfs filesystem is no longer
> supported by SLES 11 SP1.
> That filesytems jfs not have official support for me okay (I'll
> settle for kernel support), but I do not like me to choose: (
> Curiosity kills me where to set this up ..
>
> The solution to this is to enter cdlive and execute a fsck.jfs
> /dev/sda2 :)
>
>
> Any idea where to look? or find it online? (I
> run out of ideas)
>
>
> Thank you, and forgive me not get along with Google Translate
>
>
Hi
You would need to grab a SLES 10 dvd/cd and boot from that into rescue
mode and run a fs check.

This filesystem was deprecated in SLE 11.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 1 day 0:52, 3 users, load average: 0.12, 0.10, 0.12
GPU GeForce 8600 GTS Silent - Driver Version: 290.10