PDA

View Full Version : autoyast sles 11 sp1 ask for bond0 IP Address



cschaeferd
22-Dec-2011, 06:26
I can create autoyast to configure bonding with bond0 set at static ip
address, but cannot get an ask statement for the bond0 device's IP
Address (not using DHCP).
The following is my autoyast settings. any idea how I can get this to
work?
In the General Section:
<ask>
<pathlist config:type="list">
<path>networking,interfaces,bond0,ipaddr</path>
</pathlist>
<title>New Server IP Address</title>
<question>Enter the server IP Address:</question>
<stage>cont</stage>
<default>172.16.6.X</default>
</ask>

In the Networking Section:
<interfaces config:type="list">
<interface>
<bonding_master>yes</bonding_master>
<bonding_module_opts>mode=balance-alb
miimon=100</bonding_module_opts>
<bonding_slave0>eth0</bonding_slave0>
<bonding_slave1>eth1</bonding_slave1>
<bootproto>static</bootproto>
<device>bond0</device>
<ipaddr>value</ipaddr>
<netmask>255.255.255.0</netmask>
<prefixlen>24</prefixlen>
<startmode>auto</startmode>
<usercontrol>no</usercontrol>
</interface>
<interface>
<bootproto>none</bootproto>
<device>eth0</device>
<name>Emulex OneConnect 10Gb NIC (be3)</name>
<startmode>off</startmode>
<usercontrol>no</usercontrol>
</interface>
<interface>
<bootproto>none</bootproto>
<device>eth1</device>
<name>Emulex OneConnect 10Gb NIC (be3)</name>
<startmode>off</startmode>
<usercontrol>no</usercontrol>
</interface>
</interfaces>


--
cschaeferd
------------------------------------------------------------------------
cschaeferd's Profile: http://forums.novell.com/member.php?userid=46515
View this thread: http://forums.novell.com/showthread.php?t=449918

Automatic Reply
27-Dec-2011, 17:43
cschaeferd,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

jimc
26-Jan-2012, 18:56
I haven't done anything with bonding, only with the first ip address,
and I'm in early stages of devveloping my installation, but FWIW this
works...

<ask>
<pathlist config:type="list">
<path>networking,interfaces,0,ipaddr</path>
<path>host,hosts,0,host_address</path>
</pathlist>
<question>Enter Primary IP Address</question>
<stage>initial</stage>
<default>10.</default>
</ask>

<interfaces config:type="list">
<interface>
<bootproto>static</bootproto>
<device>eth0</device>
<ipaddr></ipaddr>
<name>82545EM Gigabit Ethernet Controller (Copper)</name>
<netmask>255.255.255.0</netmask>
<prefixlen>24</prefixlen>
<startmode>auto</startmode>
<usercontrol>no</usercontrol>
</interface>
</interfaces>

Differences from yours are stage initial, and nothing at all in
<ipaddr> eg <ipaddr></ipaddr> rather than <ipaddr>value</ipaddr>


--
jimc
------------------------------------------------------------------------
jimc's Profile: http://forums.novell.com/member.php?userid=6130
View this thread: http://forums.novell.com/showthread.php?t=449918