PDA

View Full Version : Active/Active configuration



cisaksen
06-Nov-2013, 21:08
I've been trying to configure a 2 node cluster as active/active and I'm not sure what the correct settings are for each resource.

Background: single shared storage formatted ocfs2. primitive resource dlm and o2cb setup as a group and clone.
sharedfs to mount the shared storage, also setup as a clone. stonith setup as a clone.
ClusterIP setup as a clone.
Apache service setup as a clone.

The trouble I'm having is the ClusterIP clone. From several docs that I've read state to set clone-max=2, clone-node-max=2, globally-unique=true. But the cluster isn't responding as correctly. If I restart a node (simulate a failure) the ClusterIp appears twice on the same node (the one that is still up). I have to restart the ClusertIp for it to start on each node again.

I can't seem to to find the right settings to make this work correctly.

Thanks

jmozdzen
07-Nov-2013, 13:33
Hi cisaksen,

> I've been trying to configure a 2 node cluster as active/active
> ClusterIP setup as a clone

how do you define "active/active" in this context - two IPs or one?

I would have guessed that you're looking for two apache instances, with an individual IP address each, running either one such pair per node or (in case of node failure), both pairs on the same node. But then there'd have to be *two* IP resources, each tied to the apache resource.
You might have a single apache configuration, which binds two both IPs, then you'd only have the IPs moving between the nodes.

If you only have a single IP (and no load balancer), then you cannot run "active/active"?

Regards,
Jens

cisaksen
07-Nov-2013, 14:24
Only 1 IP address that both Apache instances share. According to the docs that is how they configure it.
http://clusterlabs.org/doc/Clusters_from_Scratch-1.0-OCFS2.pdf page 82. Other docs have a similar configuration.

jmozdzen
07-Nov-2013, 14:55
Hi cisaksen,

that document is outdated... have a look at http://clusterlabs.org/doc/en-US/Pacemaker/1.1/html/Clusters_from_Scratch/_reconfigure_pacemaker_for_active_active.html - there's the "globally-unique=true" attribute...

I've found my way around the CLUSTERIP iptables module up until now, so I'll have to leave it up to you to test if adding the parameter will actually help. But I know of others that have reported that auto-reconfiguration of the buckets does not work without that parameter, which is what you seem to be experiencing.

Regards,
Jens